aboutsummaryrefslogtreecommitdiff
path: root/net/mDNSResponder
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-21 22:51:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-21 22:51:16 +0000
commit24e47f5a44ba3ff1d3d1298e75156438a52a72c5 (patch)
tree67b1451733352748d0635d284e06b50574117834 /net/mDNSResponder
parent47da077536e3f5f5a70053d12ba98350331471ac (diff)
downloadports-24e47f5a44ba3ff1d3d1298e75156438a52a72c5.tar.gz
ports-24e47f5a44ba3ff1d3d1298e75156438a52a72c5.zip
Set soname so shared library tracking properly works
Notes
Notes: svn path=/head/; revision=384468
Diffstat (limited to 'net/mDNSResponder')
-rw-r--r--net/mDNSResponder/Makefile1
-rw-r--r--net/mDNSResponder/files/patch-mDNSPosix-Makefile31
2 files changed, 22 insertions, 10 deletions
diff --git a/net/mDNSResponder/Makefile b/net/mDNSResponder/Makefile
index c34b6917fe71..11cbfa066886 100644
--- a/net/mDNSResponder/Makefile
+++ b/net/mDNSResponder/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mDNSResponder
PORTVERSION= 561.1.1
+PORTREVISION= 1
CATEGORIES= net dns
MASTER_SITES= http://opensource.apple.com/tarballs/${PORTNAME}/
diff --git a/net/mDNSResponder/files/patch-mDNSPosix-Makefile b/net/mDNSResponder/files/patch-mDNSPosix-Makefile
index 492a90affd22..c3048907cdb1 100644
--- a/net/mDNSResponder/files/patch-mDNSPosix-Makefile
+++ b/net/mDNSResponder/files/patch-mDNSPosix-Makefile
@@ -1,6 +1,6 @@
---- mDNSPosix/Makefile.orig 2012-10-18 06:11:12.000000000 +0800
-+++ mDNSPosix/Makefile 2014-01-04 11:50:07.945929359 +0800
-@@ -54,8 +54,8 @@
+--- mDNSPosix/Makefile.orig 2012-10-17 22:11:12 UTC
++++ mDNSPosix/Makefile
+@@ -54,8 +54,8 @@ COREDIR = ../mDNSCore
SHAREDDIR ?= ../mDNSShared
JDK = /usr/jdk
@@ -11,7 +11,7 @@
FLEX = @flex
LD = ld -shared
CP = cp
-@@ -122,7 +122,7 @@
+@@ -122,7 +122,7 @@ ifeq ($(os),freebsd)
# If not already defined, set LOCALBASE to /usr/local
LOCALBASE?=/usr/local
INSTBASE=$(LOCALBASE)
@@ -20,7 +20,7 @@
# FreeBSD 4 requires threaded code to be compiled and linked using the "-pthread" option,
# and requires that the "-lpthread" link option NOT be used
# This appies only to FreeBSD -- "man cc" on FreeBSD says:
-@@ -216,7 +216,7 @@
+@@ -216,7 +216,7 @@ CFLAGS = $(CFLAGS_COMMON) $(CFLAGS_OS) $
all: setup Daemon libdns_sd Clients SAClient SAResponder SAProxyResponder Identify NetMonitor dnsextd $(OPTIONALTARG)
@@ -29,8 +29,12 @@
# 'setup' sets up the build directory structure the way we want
setup:
-@@ -259,10 +259,10 @@
- @$(LD) $(LINKOPTS) -o $@ $+
+@@ -256,13 +256,13 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$
+ CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
+
+ $(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
+- @$(LD) $(LINKOPTS) -o $@ $+
++ @$(LD) $(LINKOPTS) -soname=libdns_sd.$(LDSUFFIX).$(LIBVERS) -o $@ $+
@$(STRIP) $@
-Clients: setup libdns_sd ../Clients/build/dns-sd
@@ -42,7 +46,14 @@
@$(MAKE) -C ../Clients
# nss_mdns target builds the Name Service Switch module
-@@ -276,43 +276,43 @@
+@@ -270,49 +270,49 @@ nss_mdns: setup $(BUILDDIR)/$(NSSLIBFILE
+ @echo "Name Service Switch module done"
+
+ $(BUILDDIR)/$(NSSLIBFILE): $(CLIENTLIBOBJS) $(OBJDIR)/nss_mdns.c.so.o
+- @$(LD) $(LINKOPTS) -o $@ $+
++ @$(LD) $(LINKOPTS) -soname=$(NSSLINKNAME) -o $@ $+
+ @$(STRIP) $@
+
#############################################################################
# The Install targets place built stuff in their proper places
@@ -97,7 +108,7 @@
$(CP) $< $@
chmod ugo+x $@
$@ start
-@@ -329,26 +329,26 @@
+@@ -329,26 +329,26 @@ else
endif
endif
@@ -130,7 +141,7 @@
$(CP) $< $@
chmod 444 $@
-@@ -490,6 +490,8 @@
+@@ -490,6 +490,8 @@ $(OBJDIR)/NetMonitor.c.o: $(C
$(BUILDDIR)/dnsextd: $(DNSEXTDOBJ) $(OBJDIR)/dnsextd.c.threadsafe.o
$(CC) $+ -o $@ $(LINKOPTS) $(LINKOPTS_PTHREAD)