aboutsummaryrefslogtreecommitdiff
path: root/net/mgen
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-05-08 21:50:30 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-05-08 21:50:30 +0000
commitf0eb4acc9c00144319efe388e60c765a52a0da10 (patch)
tree0fa71f0ca89640a5c8a55290666ffd243978e1e0 /net/mgen
parent4c23fcb34a62d36a81acaf7bbe7a292acf4baa47 (diff)
downloadports-f0eb4acc9c00144319efe388e60c765a52a0da10.tar.gz
ports-f0eb4acc9c00144319efe388e60c765a52a0da10.zip
- Fix build on -CURRENT and unbreak
- Since i'm here, fix MASTER_SITES, directory has changed since version 5 was released
Notes
Notes: svn path=/head/; revision=233444
Diffstat (limited to 'net/mgen')
-rw-r--r--net/mgen/Makefile10
-rw-r--r--net/mgen/files/patch-protolib_unix_bsdRouteMgr.cpp11
2 files changed, 13 insertions, 8 deletions
diff --git a/net/mgen/Makefile b/net/mgen/Makefile
index 1b3c0a55ceb7..ef7ba5500451 100644
--- a/net/mgen/Makefile
+++ b/net/mgen/Makefile
@@ -8,7 +8,7 @@
PORTNAME= mgen
PORTVERSION= 4.2b6
CATEGORIES= net
-MASTER_SITES= http://downloads.pf.itd.nrl.navy.mil/mgen/ \
+MASTER_SITES= http://downloads.pf.itd.nrl.navy.mil/mgen/mgen4/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= miwi
DISTNAME= src-${PORTNAME}-${PORTVERSION}
@@ -46,10 +46,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800059
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/mgen/files/patch-protolib_unix_bsdRouteMgr.cpp b/net/mgen/files/patch-protolib_unix_bsdRouteMgr.cpp
new file mode 100644
index 000000000000..39599b9f2ae9
--- /dev/null
+++ b/net/mgen/files/patch-protolib_unix_bsdRouteMgr.cpp
@@ -0,0 +1,11 @@
+--- protolib/unix/bsdRouteMgr.cpp.orig 2009-05-08 18:44:06.000000000 -0300
++++ protolib/unix/bsdRouteMgr.cpp 2009-05-08 18:44:35.000000000 -0300
+@@ -255,7 +255,7 @@
+ } // end if(mask[i] is set)
+ } // end for(i=0..RTAX_MAX)
+ if (dst.IsValid() &&
+- (0 == (rtm->rtm_flags & RTF_WASCLONED)))
++ (0 == (rtm->rtm_flags)))
+ {
+ if (prefixLen < 0) prefixLen = dst.GetLength() << 3;
+ if (0 == (rtm->rtm_flags & RTF_GATEWAY)) gw.Invalidate();