aboutsummaryrefslogtreecommitdiff
path: root/net/minidlna
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-05 18:57:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-05 18:57:23 +0000
commitbc685f32c5ec5d34787f7230e4fa15110f59f7a1 (patch)
treeb9e5c514a828ec0a3ad211fa3468e2b9e3c0bc00 /net/minidlna
parent8d14697457e5d957e931c24de117203351987428 (diff)
downloadports-bc685f32c5ec5d34787f7230e4fa15110f59f7a1.tar.gz
ports-bc685f32c5ec5d34787f7230e4fa15110f59f7a1.zip
Increase FD_SETSIZE to 8192
- Bump PORTREVISION for package change PR: 210014 Obtained from: Bob Willcox <bob@immure.com> Submitted by: Masachika ISHIZUKA <ish@amail.plala.or.jp> Notified by: riggs
Notes
Notes: svn path=/head/; revision=471798
Diffstat (limited to 'net/minidlna')
-rw-r--r--net/minidlna/Makefile2
-rw-r--r--net/minidlna/files/extra-patch-kqueue8
2 files changed, 9 insertions, 1 deletions
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index 5aaeea6b60b8..2153a2eeb976 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -3,7 +3,7 @@
PORTNAME= minidlna
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net multimedia www
MASTER_SITES= SF
diff --git a/net/minidlna/files/extra-patch-kqueue b/net/minidlna/files/extra-patch-kqueue
index 07405ef11c71..33233908fec3 100644
--- a/net/minidlna/files/extra-patch-kqueue
+++ b/net/minidlna/files/extra-patch-kqueue
@@ -543,6 +543,14 @@ diff --git upnpevents.c upnpevents.c
index 06ec43a..9827e6e 100644
--- upnpevents.c
+++ upnpevents.c
+@@ -47,6 +47,7 @@
+ */
+ #include "config.h"
+
++#define FD_SETSIZE 8192
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
@@ -417,6 +417,10 @@ void upnpevents_selectfds(fd_set *readset, fd_set *writeset, int * max_fd)
{
struct upnp_event_notify * obj;