aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-01-25 16:34:53 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-01-25 16:34:53 +0000
commit1295d20c38e664bbde710f8996dde2137eb92aaf (patch)
tree814ba4d76fdd0f3d11c5939a932f442d765f6509 /net/miniupnpc
parent0946c66e59984f4889f8dd3577fd9238c99de810 (diff)
downloadports-1295d20c38e664bbde710f8996dde2137eb92aaf.tar.gz
ports-1295d20c38e664bbde710f8996dde2137eb92aaf.zip
UPnP IGD client lightweight library
The usage of the miniUPnP client library is useful whenever an application needs to listen for incoming connections. Examples : P2P applications, FTP clients for active mode, IRC (for DCC) or IM applications, network games, any server. WWW: http://miniupnp.free.fr/
Notes
Notes: svn path=/head/; revision=206184
Diffstat (limited to 'net/miniupnpc')
-rw-r--r--net/miniupnpc/Makefile24
-rw-r--r--net/miniupnpc/distinfo3
-rw-r--r--net/miniupnpc/pkg-descr8
-rw-r--r--net/miniupnpc/pkg-plist9
4 files changed, 44 insertions, 0 deletions
diff --git a/net/miniupnpc/Makefile b/net/miniupnpc/Makefile
new file mode 100644
index 000000000000..166755ee611d
--- /dev/null
+++ b/net/miniupnpc/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: miniupnpc
+# Date created: 31 Oct 2007
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= miniupnpc
+PORTVERSION= 0.1.0.11
+CATEGORIES= net
+MASTER_SITES= http://miniupnp.free.fr/files/
+DISTNAME= ${PORTNAME}-1.0-RC11
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= UPnP IGD client lightweight library
+
+USE_GMAKE= yes
+MAKE_ENV+= INSTALLPREFIX=${PREFIX}
+USE_LDCONFIG= yes
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|--mode=|-m |' -e 's|--symbolic|-s|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/miniupnpc/distinfo b/net/miniupnpc/distinfo
new file mode 100644
index 000000000000..537265adf860
--- /dev/null
+++ b/net/miniupnpc/distinfo
@@ -0,0 +1,3 @@
+MD5 (miniupnpc-1.0-RC11.tar.gz) = 75d46c646e538829fad7ccac97f2cdf9
+SHA256 (miniupnpc-1.0-RC11.tar.gz) = f6e8a2607973ee13f0e25e946b6f3a5d3e690bb3bceb6718d20631b6dc0e4227
+SIZE (miniupnpc-1.0-RC11.tar.gz) = 32161
diff --git a/net/miniupnpc/pkg-descr b/net/miniupnpc/pkg-descr
new file mode 100644
index 000000000000..1af75a21991b
--- /dev/null
+++ b/net/miniupnpc/pkg-descr
@@ -0,0 +1,8 @@
+UPnP IGD client lightweight library
+
+The usage of the miniUPnP client library is useful whenever an application
+needs to listen for incoming connections.
+Examples : P2P applications, FTP clients for active mode, IRC (for DCC)
+or IM applications, network games, any server.
+
+WWW: http://miniupnp.free.fr/
diff --git a/net/miniupnpc/pkg-plist b/net/miniupnpc/pkg-plist
new file mode 100644
index 000000000000..1a41bc3f0fe4
--- /dev/null
+++ b/net/miniupnpc/pkg-plist
@@ -0,0 +1,9 @@
+include/miniupnpc/igd_desc_parse.h
+include/miniupnpc/miniupnpc.h
+include/miniupnpc/miniwget.h
+include/miniupnpc/upnpcommands.h
+include/miniupnpc/upnpreplyparse.h
+lib/libminiupnpc.a
+lib/libminiupnpc.so
+lib/libminiupnpc.so.1
+@dirrm include/miniupnpc