aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpd
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2015-09-19 12:20:32 +0000
committerRenato Botelho <garga@FreeBSD.org>2015-09-19 12:20:32 +0000
commit4476787a1812f8a15f1fe9a862d36176a5f89df8 (patch)
treea300aeb10ed39b698c3b5bcc61c5422dfc17b663 /net/miniupnpd
parent4e7dc1cf18fc93b30ceae1ee8ddffc51c2804ff6 (diff)
downloadports-4476787a1812f8a15f1fe9a862d36176a5f89df8.tar.gz
ports-4476787a1812f8a15f1fe9a862d36176a5f89df8.zip
- Update net/miniupnpd to 1.9.20150721 [1]
- Stop calling uuidgen on port Makefile, miniupnpd Makefile already does it - Do not modify CFLAGS since it's already attributed using ?= - Remove do-install: target from ports Makefile, let miniupnpd Makefile installs it - Patch miniupnpd Makefile to install conf with .sample suffix - Patch miniupnpd Makefile to install manpage in the proper place, respecting MANPREFIX PR: 203191 [1] Submitted by: Tor Halvard Furulund <squat@squat.no> [1] Approved by: Tor Halvard Furulund <squat@squat.no> (maintainer) Sponsored by: Rubicon Communications (Netgate)
Notes
Notes: svn path=/head/; revision=397321
Diffstat (limited to 'net/miniupnpd')
-rw-r--r--net/miniupnpd/Makefile18
-rw-r--r--net/miniupnpd/distinfo4
-rw-r--r--net/miniupnpd/files/patch-Makefile28
3 files changed, 30 insertions, 20 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index adba2f60b24b..3b64596096d1 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= miniupnpd
-PORTVERSION= 1.9
-PORTREVISION= 1
+PORTVERSION= 1.9.20150721
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
@@ -12,12 +11,10 @@ MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
MAINTAINER= squat@squat.no
COMMENT= UPnP IGD implementation which uses pf/ipf
-SUB_FILES= miniupnpd.conf.sample
-SUB_LIST= UUID=${UUID}
+LICENSE= BSD3CLAUSE
USES= cpe
CPE_VENDOR= miniupnp_project
-UUID!= uuidgen
PLIST_FILES= etc/miniupnpd.conf.sample sbin/miniupnpd \
man/man8/miniupnpd.8.gz
MAKE_JOBS_UNSAFE=yes
@@ -42,15 +39,4 @@ UPNP_IGDV2_EXTRA_PATCHES= ${PATCHDIR}/enable_igdv2.patch
UPNP_STRICT_EXTRA_PATCHES= ${PATCHDIR}/enable_upnp_strict.patch
LEASEFILE_EXTRA_PATCHES= ${PATCHDIR}/enable_leasefile.patch
-post-patch:
- @${REINPLACE_CMD} 's|CFLAGS ?= -pipe -Os|CFLAGS ?= -pipe|' \
- ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/miniupnpd ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKDIR}/miniupnpd.conf.sample \
- ${STAGEDIR}${PREFIX}/etc/miniupnpd.conf.sample
- ${INSTALL_MAN} ${WRKSRC}/miniupnpd.8 \
- ${STAGEDIR}${MAN8PREFIX}/man/man8/miniupnpd.8
-
.include <bsd.port.mk>
diff --git a/net/miniupnpd/distinfo b/net/miniupnpd/distinfo
index 1441c684e329..9eb31e236232 100644
--- a/net/miniupnpd/distinfo
+++ b/net/miniupnpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (miniupnpd-1.9.tar.gz) = 6176eb21a6422a7ee68ef1c62ccbbd5003335fa773d8c9013228c2a217bba2ac
-SIZE (miniupnpd-1.9.tar.gz) = 192183
+SHA256 (miniupnpd-1.9.20150721.tar.gz) = 9340224e5023ecb5d1b7f45e4d69734dcfbadbe41a80d1f0182347e6b8104470
+SIZE (miniupnpd-1.9.20150721.tar.gz) = 207562
diff --git a/net/miniupnpd/files/patch-Makefile b/net/miniupnpd/files/patch-Makefile
index 5c48e4774f1a..876c9f10e628 100644
--- a/net/miniupnpd/files/patch-Makefile
+++ b/net/miniupnpd/files/patch-Makefile
@@ -1,6 +1,30 @@
---- Makefile.orig 2014-06-30 12:03:05 UTC
+--- Makefile.orig 2015-04-30 09:08:34 UTC
+++ Makefile
-@@ -204,7 +204,7 @@ depend: config.h
+@@ -160,8 +160,7 @@ LIBS += -lssl -lcrypto
+
+ INSTALLBINDIR = $(PREFIX)/sbin
+ INSTALLETCDIR = $(PREFIX)/etc
+-# INSTALLMANDIR = $(PREFIX)/man
+-INSTALLMANDIR = /usr/share/man
++INSTALLMANDIR = $(MANPREFIX)/man
+
+ all: $(EXECUTABLES)
+
+@@ -178,10 +177,10 @@ install: miniupnpd genuuid
+ $(INSTALL) -d $(DESTDIR)$(INSTALLBINDIR)
+ $(INSTALL) -m 755 miniupnpd $(DESTDIR)$(INSTALLBINDIR)
+ $(INSTALL) -d $(DESTDIR)$(INSTALLETCDIR)
+- $(INSTALL) -b miniupnpd.conf $(DESTDIR)$(INSTALLETCDIR)
++ $(INSTALL) -b miniupnpd.conf $(DESTDIR)$(INSTALLETCDIR)/miniupnpd.conf.sample
+ # TODO : install man page correctly
+-# $(INSTALL) -d $(INSTALLMANDIR)
+-# $(INSTALL) miniupnpd.8 $(INSTALLMANDIR)/cat8/miniupnpd.0
++ $(INSTALL) -d $(DESTDIR)$(INSTALLMANDIR)/man8
++ $(INSTALL) miniupnpd.8 $(DESTDIR)$(INSTALLMANDIR)/man8/miniupnpd.8
+
+ # genuuid is using the uuid cli tool available under OpenBSD 4.0 in
+ # the uuid-1.5.0 package
+@@ -204,7 +203,7 @@ depend: config.h
testgetroute.c testportinuse.c testasyncsendto.c
miniupnpd: config.h $(ALLOBJS)