aboutsummaryrefslogtreecommitdiff
path: root/net/miredo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-13 19:39:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-13 19:39:24 +0000
commit66702080b0f5a895a863fa3c18927a628db450a5 (patch)
treec37a1532ab9fd524abe38c64cd4ed5db0a1495d5 /net/miredo/Makefile
parent5077a80b8b3187edadb23ec04cd6147dc3417abd (diff)
downloadports-66702080b0f5a895a863fa3c18927a628db450a5.tar.gz
ports-66702080b0f5a895a863fa3c18927a628db450a5.zip
Notes
Diffstat (limited to 'net/miredo/Makefile')
-rw-r--r--net/miredo/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
new file mode 100644
index 000000000000..587eb27244a0
--- /dev/null
+++ b/net/miredo/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: miredo
+# Date created: 2006-08-12
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= miredo
+PORTVERSION= 0.9.8
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.remlab.net/files/miredo/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= Opensource Teredo (IPv6 tunneling) implementation
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+USE_GETOPT_LONG= yes
+USE_LDCONFIG= yes
+
+MAN1= teredo-mire.1
+MAN5= miredo-server.conf.5 miredo.conf.5 isatapd.conf.5
+MAN8= miredo-server.8 miredo.8 isatapd.8 miredo-checkconf.8
+USE_RC_SUBR= miredo_server miredo isatapd
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+USE_ICONV= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ CFLAGS="${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>