aboutsummaryrefslogtreecommitdiff
path: root/net/mopd
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-29 21:50:34 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-29 21:50:34 +0000
commit3a82c56aca7f24585025d4c94b1b8f863f636f3a (patch)
treee18ada8fbceacf39630824ce6d261cbad7f65ce5 /net/mopd
parent2d4e03c529b8e94e198d3640d8b13c7ec4bca264 (diff)
downloadports-3a82c56aca7f24585025d4c94b1b8f863f636f3a.tar.gz
ports-3a82c56aca7f24585025d4c94b1b8f863f636f3a.zip
Notes
Diffstat (limited to 'net/mopd')
-rw-r--r--net/mopd/Makefile5
-rw-r--r--net/mopd/files/LICENSE.txt26
-rw-r--r--net/mopd/files/patch-common_device.c (renamed from net/mopd/files/patch-device.c)19
-rw-r--r--net/mopd/files/patch-common_file.c (renamed from net/mopd/files/patch-file.c)12
-rw-r--r--net/mopd/files/patch-common_loop-bsd.c11
-rw-r--r--net/mopd/files/patch-common_pf.c (renamed from net/mopd/files/patch-pf.c)13
-rw-r--r--net/mopd/files/patch-common_put.c (renamed from net/mopd/files/patch-put.c)12
-rw-r--r--net/mopd/files/patch-mopchk_Makefile11
-rw-r--r--net/mopd/files/patch-mopchk_mopchk.c11
-rw-r--r--net/mopd/files/patch-mopd_Makefile11
-rw-r--r--net/mopd/files/patch-mopd_mopd.c11
-rw-r--r--net/mopd/files/patch-mopd_process.c (renamed from net/mopd/files/patch-process.c)14
-rw-r--r--net/mopd/files/patch-mopprobe_Makefile11
-rw-r--r--net/mopd/files/patch-mopprobe_mopprobe.c11
-rw-r--r--net/mopd/files/patch-moptrace_Makefile11
-rw-r--r--net/mopd/files/patch-moptrace_moptrace.c11
-rw-r--r--net/mopd/files/patch-otherOS_Makefile11
-rw-r--r--net/mopd/files/patch-otherOS_loop.c11
-rw-r--r--net/mopd/files/patch-otherOS_pf-snit.c (renamed from net/mopd/files/patch-pf-snit.c)8
19 files changed, 195 insertions, 35 deletions
diff --git a/net/mopd/Makefile b/net/mopd/Makefile
index 6eb8b8b3a21f..e046d5cbb6ee 100644
--- a/net/mopd/Makefile
+++ b/net/mopd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mopd
PORTVERSION= 2.5.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= LOCAL/cy
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -11,6 +11,9 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= MOP Loader Daemon for netbooting DEC machines
+LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${PATCHDIR}/LICENSE.txt
+
USES= uidfix
MAKE_ENV= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man NO_MANCOMPRESS=true
diff --git a/net/mopd/files/LICENSE.txt b/net/mopd/files/LICENSE.txt
new file mode 100644
index 000000000000..00c42edd9bcb
--- /dev/null
+++ b/net/mopd/files/LICENSE.txt
@@ -0,0 +1,26 @@
+Copyright (c) 1993-90 Mats O Jansson. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. All advertising materials mentioning features or use of this software
+ must display the following acknowledgement:
+ This product includes software developed by Mats O Jansson.
+4. The name of the author may not be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/net/mopd/files/patch-device.c b/net/mopd/files/patch-common_device.c
index e6ffd6c7469d..e5727929ccd7 100644
--- a/net/mopd/files/patch-device.c
+++ b/net/mopd/files/patch-common_device.c
@@ -1,6 +1,15 @@
---- common/device.c 1996/09/21 13:49:16 1.1
-+++ common/device.c 2000/02/20 17:45:33 1.4
-@@ -111,7 +113,8 @@
+--- common/device.c.orig 1996-08-08 00:01:54 UTC
++++ common/device.c
+@@ -35,7 +35,7 @@ static char rcsid[] = "$Id: device.c,v 1.21 1996/08/08
+ #include "common/common.h"
+ #include "common/mopdef.h"
+
+-struct if_info *iflist; /* Interface List */
++/*extern*/ struct if_info *iflist; /* Interface List */
+
+ void mopReadDL();
+ void mopReadRC();
+@@ -111,7 +111,8 @@ deviceOpen(ifname, proto, trans)
{
struct if_info *p, tmp;
@@ -10,7 +19,7 @@
tmp.iopen = pfInit;
switch (proto) {
-@@ -138,7 +141,8 @@
+@@ -138,7 +139,8 @@ deviceOpen(ifname, proto, trans)
p->next = iflist;
iflist = p;
@@ -20,7 +29,7 @@
p->iopen = tmp.iopen;
p->write = pfWrite;
p->read = tmp.read;
-@@ -185,12 +199,12 @@
+@@ -185,12 +187,12 @@ deviceInitOne(ifname)
if ((strlen(dev) == 2) &&
(dev[0] == 'e') &&
((dev[1] == 'n') || (dev[1] == 't'))) {
diff --git a/net/mopd/files/patch-file.c b/net/mopd/files/patch-common_file.c
index 04522bab6f70..d40cbd11d294 100644
--- a/net/mopd/files/patch-file.c
+++ b/net/mopd/files/patch-common_file.c
@@ -1,6 +1,6 @@
---- common/file.c.orig Sat Aug 17 00:39:41 1996
-+++ common/file.c Mon Aug 23 16:36:03 2004
-@@ -44,6 +44,7 @@
+--- common/file.c.orig 1996-08-16 22:39:41 UTC
++++ common/file.c
+@@ -44,6 +44,7 @@ static char rcsid[] = "$Id: file.c,v 1.4 1996/08/16 22
#endif
#if defined(__FreeBSD__)
#include <sys/imgact_aout.h>
@@ -8,7 +8,7 @@
#endif
#if !defined(MID_VAX)
#define MID_VAX 140
-@@ -345,7 +346,7 @@
+@@ -345,7 +346,7 @@ getMID(old_mid,new_mid)
mid = MID_ARM6;
break;
#endif
@@ -17,7 +17,7 @@
/*###352 [cc] syntax error before `}'%%%*/
}
-@@ -522,7 +523,7 @@
+@@ -522,7 +523,7 @@ GetAOutFileInfo(fd, load, xfr, a_text, a_text_fill,
ex.a_trsize= mopFileGetBX((u_char *)&ex_swap, 24, 4);
ex.a_drsize= mopFileGetBX((u_char *)&ex_swap, 28, 4);
break;
@@ -26,7 +26,7 @@
/*###525 [cc] syntax error before `}'%%%*/
}
-@@ -575,7 +576,7 @@
+@@ -575,7 +576,7 @@ GetAOutFileInfo(fd, load, xfr, a_text, a_text_fill,
printf("arm32");
break;
#endif
diff --git a/net/mopd/files/patch-common_loop-bsd.c b/net/mopd/files/patch-common_loop-bsd.c
new file mode 100644
index 000000000000..cdca45f562f1
--- /dev/null
+++ b/net/mopd/files/patch-common_loop-bsd.c
@@ -0,0 +1,11 @@
+--- common/loop-bsd.c.orig 1996-08-16 22:41:43 UTC
++++ common/loop-bsd.c
+@@ -89,7 +89,7 @@ mopReadDL()
+ * The list of all interfaces that are being listened to. loop()
+ * "selects" on the descriptors in this list.
+ */
+-struct if_info *iflist;
++extern struct if_info *iflist;
+
+ void mopProcess __P((struct if_info *, u_char *));
+
diff --git a/net/mopd/files/patch-pf.c b/net/mopd/files/patch-common_pf.c
index dad73d14a35a..01730f05c318 100644
--- a/net/mopd/files/patch-pf.c
+++ b/net/mopd/files/patch-common_pf.c
@@ -1,15 +1,16 @@
---- common/pf.c.orig Tue Aug 6 07:20:27 1996
-+++ common/pf.c Wed Oct 15 13:02:19 2003
-@@ -56,7 +56,7 @@
+--- common/pf.c.orig 1996-08-06 14:20:27 UTC
++++ common/pf.c
+@@ -56,8 +56,8 @@ static char rcsid[] = "$Id: pf.c,v 1.16 1996/08/06 14:
#include <strings.h>
#include <syslog.h>
-#include <varargs.h>
-+
++
#include "common/mopdef.h"
-@@ -174,7 +174,8 @@
+ /*
+@@ -174,7 +174,8 @@ pfAddMulti(s, interface, addr)
struct ifreq ifr;
int fd;
@@ -19,7 +20,7 @@
ifr.ifr_addr.sa_family = AF_UNSPEC;
bcopy(addr, ifr.ifr_addr.sa_data, 6);
-@@ -209,7 +210,8 @@
+@@ -209,7 +210,8 @@ pfDelMulti(s, interface, addr)
struct ifreq ifr;
int fd;
diff --git a/net/mopd/files/patch-put.c b/net/mopd/files/patch-common_put.c
index e797bb182cd0..69613b0e7ea4 100644
--- a/net/mopd/files/patch-put.c
+++ b/net/mopd/files/patch-common_put.c
@@ -1,6 +1,6 @@
---- common/put.c.orig Fri Aug 16 15:43:15 1996
-+++ common/put.c Sun Mar 5 09:32:05 2000
-@@ -35,6 +35,9 @@
+--- common/put.c.orig 1996-08-16 22:43:15 UTC
++++ common/put.c
+@@ -35,6 +35,9 @@ static char rcsid[] = "$Id: put.c,v 1.5 1996/08/16 22:
#include <sys/types.h>
#include <time.h>
#include "common/mopdef.h"
@@ -10,7 +10,7 @@
void
mopPutChar(pkt, index, value)
-@@ -137,10 +140,7 @@
+@@ -137,10 +140,7 @@ mopPutHeader(pkt, index, dst, src, proto, trans)
mopPutChar (pkt, index, 0x00);
mopPutChar (pkt, index, 0x2b);
}
@@ -22,7 +22,7 @@
if (trans == TRANS_8023) {
mopPutChar(pkt, index, (proto / 256));
mopPutChar(pkt, index, (proto % 256));
-@@ -148,6 +148,9 @@
+@@ -148,6 +148,9 @@ mopPutHeader(pkt, index, dst, src, proto, trans)
mopPutChar(pkt, index, (proto % 256));
mopPutChar(pkt, index, (proto / 256));
}
@@ -32,7 +32,7 @@
#endif
if (trans == TRANS_ETHER)
mopPutShort(pkt, index, 0);
-@@ -170,12 +173,12 @@
+@@ -170,12 +173,12 @@ mopPutLength(pkt, trans, len)
break;
case TRANS_8023:
index = 12;
diff --git a/net/mopd/files/patch-mopchk_Makefile b/net/mopd/files/patch-mopchk_Makefile
new file mode 100644
index 000000000000..28370b6339ee
--- /dev/null
+++ b/net/mopd/files/patch-mopchk_Makefile
@@ -0,0 +1,11 @@
+--- mopchk/Makefile.orig 1996-08-16 22:46:38 UTC
++++ mopchk/Makefile
+@@ -9,7 +9,7 @@ LDADD= -lkvm
+
+ version.c version.h: ${.CURDIR}/../common/VERSION
+ rm -f version.c; \
+- sed 's/.*/char version[] = "&";/' ${.ALLSRC} > version.c
++ sed 's/.*/static char version[] = "&";/' ${.ALLSRC} > version.c
+ set `sed 's/\([0-9]*\)\.\([0-9]*\).*/\1 \2/' ${.ALLSRC}` ; \
+ { echo '#define VERSION_MAJOR' $$1 ; \
+ echo '#define VERSION_MINOR' $$2 ; } > version.h
diff --git a/net/mopd/files/patch-mopchk_mopchk.c b/net/mopd/files/patch-mopchk_mopchk.c
new file mode 100644
index 000000000000..35c2b65f1371
--- /dev/null
+++ b/net/mopd/files/patch-mopchk_mopchk.c
@@ -0,0 +1,11 @@
+--- mopchk/mopchk.c.orig 1996-08-16 22:47:15 UTC
++++ mopchk/mopchk.c
+@@ -48,7 +48,7 @@ static char rcsid[] = "$Id: mopchk.c,v 1.5 1996/08/16
+ * The list of all interfaces that are being listened to. rarp_loop()
+ * "selects" on the descriptors in this list.
+ */
+-struct if_info *iflist;
++extern struct if_info *iflist;
+
+ #ifdef NO__P
+ void Usage (/* void */);
diff --git a/net/mopd/files/patch-mopd_Makefile b/net/mopd/files/patch-mopd_Makefile
new file mode 100644
index 000000000000..59ad51359223
--- /dev/null
+++ b/net/mopd/files/patch-mopd_Makefile
@@ -0,0 +1,11 @@
+--- mopd/Makefile.orig 1996-08-16 22:36:26 UTC
++++ mopd/Makefile
+@@ -11,7 +11,7 @@ LDADD= -lkvm
+
+ version.c version.h: ${.CURDIR}/../common/VERSION
+ rm -f version.c; \
+- sed 's/.*/char version[] = "&";/' ${.ALLSRC} > version.c
++ sed 's/.*/char version[] = "&";/' ${.ALLSRC} > version.c
+ set `sed 's/\([0-9]*\)\.\([0-9]*\).*/\1 \2/' ${.ALLSRC}` ; \
+ { echo '#define VERSION_MAJOR' $$1 ; \
+ echo '#define VERSION_MINOR' $$2 ; } > version.h
diff --git a/net/mopd/files/patch-mopd_mopd.c b/net/mopd/files/patch-mopd_mopd.c
new file mode 100644
index 000000000000..6aa7d39ed25c
--- /dev/null
+++ b/net/mopd/files/patch-mopd_mopd.c
@@ -0,0 +1,11 @@
+--- mopd/mopd.c.orig 1996-03-31 19:21:00 UTC
++++ mopd/mopd.c
+@@ -54,7 +54,7 @@ static char rcsid[] = "$Id: mopd.c,v 1.14 1996/03/31 1
+ * The list of all interfaces that are being listened to.
+ * "selects" on the descriptors in this list.
+ */
+-struct if_info *iflist;
++extern struct if_info *iflist;
+
+ #ifdef NO__P
+ void Loop (/* void */);
diff --git a/net/mopd/files/patch-process.c b/net/mopd/files/patch-mopd_process.c
index c173382e7ea9..70139d811009 100644
--- a/net/mopd/files/patch-process.c
+++ b/net/mopd/files/patch-mopd_process.c
@@ -1,6 +1,6 @@
---- mopd/process.c 1996/09/21 19:12:26 1.2
-+++ mopd/process.c 2000/07/04 23:46:23 1.8
-@@ -267,7 +267,7 @@
+--- mopd/process.c.orig 1996-08-22 17:07:38 UTC
++++ mopd/process.c
+@@ -265,7 +265,7 @@ mopStartLoad(dst, src, dl_rpr, trans)
dllist[slot].a_lseek = 0;
dllist[slot].count = 0;
@@ -9,7 +9,7 @@
dllist[slot].dl_bsz = 1492;
if (dllist[slot].dl_bsz == 1030) /* VS/uVAX 2000 needs this */
dllist[slot].dl_bsz = 1000;
-@@ -350,10 +350,10 @@
+@@ -348,10 +348,10 @@ mopNextLoad(dst, src, new_count, trans)
close(dllist[slot].ldfd);
dllist[slot].ldfd = 0;
dllist[slot].status = DL_STATUS_FREE;
@@ -22,7 +22,7 @@
return;
}
-@@ -438,7 +438,7 @@
+@@ -436,7 +436,7 @@ mopProcessDL(fd, ii, pkt, index, dst, src, trans, len)
{
u_char tmpc;
u_short moplen;
@@ -31,7 +31,7 @@
char filename[FILENAME_MAX];
char line[100];
int i,nfd,iindex;
-@@ -487,6 +487,8 @@
+@@ -485,6 +485,8 @@ mopProcessDL(fd, ii, pkt, index, dst, src, trans, len)
rpr_pgty = mopGetChar(pkt,index); /* Program Type */
tmpc = mopGetChar(pkt,index); /* Software ID Len */
@@ -40,7 +40,7 @@
for (i = 0; i < tmpc; i++) {
pfile[i] = mopGetChar(pkt,index);
pfile[i+1] = '\0';
-@@ -513,31 +515,32 @@
+@@ -511,31 +513,32 @@ mopProcessDL(fd, ii, pkt, index, dst, src, trans, len)
bcopy((char *)src, (char *)(dl_rpr->eaddr), 6);
mopProcessInfo(pkt,index,moplen,dl_rpr,trans);
diff --git a/net/mopd/files/patch-mopprobe_Makefile b/net/mopd/files/patch-mopprobe_Makefile
new file mode 100644
index 000000000000..424a51034d15
--- /dev/null
+++ b/net/mopd/files/patch-mopprobe_Makefile
@@ -0,0 +1,11 @@
+--- mopprobe/Makefile.orig 1996-08-16 22:48:44 UTC
++++ mopprobe/Makefile
+@@ -9,7 +9,7 @@ LDADD= -lkvm
+
+ version.c version.h: ${.CURDIR}/../common/VERSION
+ rm -f version.c; \
+- sed 's/.*/char version[] = "&";/' ${.ALLSRC} > version.c
++ sed 's/.*/static char version[] = "&";/' ${.ALLSRC} > version.c
+ set `sed 's/\([0-9]*\)\.\([0-9]*\).*/\1 \2/' ${.ALLSRC}` ; \
+ { echo '#define VERSION_MAJOR' $$1 ; \
+ echo '#define VERSION_MINOR' $$2 ; } > version.h
diff --git a/net/mopd/files/patch-mopprobe_mopprobe.c b/net/mopd/files/patch-mopprobe_mopprobe.c
new file mode 100644
index 000000000000..d1f7f1fa8fbf
--- /dev/null
+++ b/net/mopd/files/patch-mopprobe_mopprobe.c
@@ -0,0 +1,11 @@
+--- mopprobe/mopprobe.c.orig 1996-08-11 22:31:43 UTC
++++ mopprobe/mopprobe.c
+@@ -52,7 +52,7 @@ static char rcsid[] = "$Id: mopprobe.c,v 1.11 1996/08/
+ * The list of all interfaces that are being listened to. rarp_loop()
+ * "selects" on the descriptors in this list.
+ */
+-struct if_info *iflist;
++extern struct if_info *iflist;
+
+ #ifdef NO__P
+ void Loop (/* void */);
diff --git a/net/mopd/files/patch-moptrace_Makefile b/net/mopd/files/patch-moptrace_Makefile
new file mode 100644
index 000000000000..801c61c682d5
--- /dev/null
+++ b/net/mopd/files/patch-moptrace_Makefile
@@ -0,0 +1,11 @@
+--- moptrace/Makefile.orig 1996-08-16 22:49:27 UTC
++++ moptrace/Makefile
+@@ -11,7 +11,7 @@ LDADD= -lkvm
+
+ version.c version.h: ${.CURDIR}/../common/VERSION
+ rm -f version.c; \
+- sed 's/.*/char version[] = "&";/' ${.ALLSRC} > version.c
++ sed 's/.*/static char version[] = "&";/' ${.ALLSRC} > version.c
+ set `sed 's/\([0-9]*\)\.\([0-9]*\).*/\1 \2/' ${.ALLSRC}` ; \
+ { echo '#define VERSION_MAJOR' $$1 ; \
+ echo '#define VERSION_MINOR' $$2 ; } > version.h
diff --git a/net/mopd/files/patch-moptrace_moptrace.c b/net/mopd/files/patch-moptrace_moptrace.c
new file mode 100644
index 000000000000..442614afa5c2
--- /dev/null
+++ b/net/mopd/files/patch-moptrace_moptrace.c
@@ -0,0 +1,11 @@
+--- moptrace/moptrace.c.orig 1996-08-07 22:48:04 UTC
++++ moptrace/moptrace.c
+@@ -52,7 +52,7 @@ static char rcsid[] = "$Id: moptrace.c,v 1.10 1996/08/
+ * The list of all interfaces that are being listened to.
+ * "selects" on the descriptors in this list.
+ */
+-struct if_info *iflist;
++extern struct if_info *iflist;
+
+ #ifdef NO__P
+ void Loop (/* void */);
diff --git a/net/mopd/files/patch-otherOS_Makefile b/net/mopd/files/patch-otherOS_Makefile
new file mode 100644
index 000000000000..42b7abca619c
--- /dev/null
+++ b/net/mopd/files/patch-otherOS_Makefile
@@ -0,0 +1,11 @@
+--- otherOS/Makefile.orig 1996-08-13 18:44:15 UTC
++++ otherOS/Makefile
+@@ -164,7 +164,7 @@ VERSION:
+
+ version.o: version.c
+ version.c version.h: VERSION
+- rm -f version.c ; sed 's/.*/char version[] = "&";/' VERSION > version.c
++ rm -f version.c ; sed 's/.*/static char version[] = "&";/' VERSION > version.c
+ set `sed 's/\([0-9]*\)\.\([0-9]*\).*/\1 \2/' VERSION` ; \
+ { echo '#define VERSION_MAJOR' $$1 ; \
+ echo '#define VERSION_MINOR' $$2 ; } > version.h
diff --git a/net/mopd/files/patch-otherOS_loop.c b/net/mopd/files/patch-otherOS_loop.c
new file mode 100644
index 000000000000..a9e7ac2b7bf5
--- /dev/null
+++ b/net/mopd/files/patch-otherOS_loop.c
@@ -0,0 +1,11 @@
+--- otherOS/loop.c.orig 1996-08-07 23:49:12 UTC
++++ otherOS/loop.c
+@@ -39,7 +39,7 @@ static char rcsid[] = "$Id: loop.c,v 1.8 1996/08/07 23
+ * The list of all interfaces that are being listened to. loop()
+ * "selects" on the descriptors in this list.
+ */
+-struct if_info *iflist;
++extern struct if_info *iflist;
+ u_char buf[BUFSIZE];
+
+ void mopProcess (/* struct if_info *, u_char * */);
diff --git a/net/mopd/files/patch-pf-snit.c b/net/mopd/files/patch-otherOS_pf-snit.c
index b2b329fd3df3..d54c2071c109 100644
--- a/net/mopd/files/patch-pf-snit.c
+++ b/net/mopd/files/patch-otherOS_pf-snit.c
@@ -1,6 +1,6 @@
---- otherOS/pf-snit.c 1996/09/21 19:12:50 1.2
-+++ otherOS/pf-snit.c 2000/02/20 17:45:34 1.3
-@@ -239,7 +239,8 @@
+--- otherOS/pf-snit.c.orig 1996-08-08 11:48:50 UTC
++++ otherOS/pf-snit.c
+@@ -237,7 +237,8 @@ pfAddMulti(s, interface, addr)
struct ifreq ifr;
int fd;
@@ -10,7 +10,7 @@
ifr.ifr_addr.sa_family = AF_UNSPEC;
bcopy(addr, ifr.ifr_addr.sa_data, 6);
-@@ -274,7 +275,8 @@
+@@ -272,7 +273,8 @@ char *interface, *addr;
struct ifreq ifr;
int fd;