aboutsummaryrefslogtreecommitdiff
path: root/net/morebalance/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-06-02 10:06:30 +0000
committerClement Laforet <clement@FreeBSD.org>2004-06-02 10:06:30 +0000
commited3c9e74c36f3ec1dcad25ecca4531fb4ed646d7 (patch)
treec466de0b6237da49a6bc6b64a6a4338ed18909ed /net/morebalance/Makefile
parente71642a6393f301e08a86f75db1d9076efdb1965 (diff)
downloadports-ed3c9e74c36f3ec1dcad25ecca4531fb4ed646d7.tar.gz
ports-ed3c9e74c36f3ec1dcad25ecca4531fb4ed646d7.zip
Notes
Diffstat (limited to 'net/morebalance/Makefile')
-rw-r--r--net/morebalance/Makefile31
1 files changed, 13 insertions, 18 deletions
diff --git a/net/morebalance/Makefile b/net/morebalance/Makefile
index a90e2853b9e8..b101bcb78c4c 100644
--- a/net/morebalance/Makefile
+++ b/net/morebalance/Makefile
@@ -6,30 +6,24 @@
#
PORTNAME= morebalance
-PORTVERSION= 0.2
+PORTVERSION= 0.3
CATEGORIES= net
-MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/ \
- http://mindx.dyndns.org/morebalance/
+MASTER_SITES= http://morebalance.coolprojects.org/
MAINTAINER= clement@FreeBSD.org
COMMENT= A modular open source user-space load balancing system
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre \
+ gnutls.13:${PORTSDIR}/security/gnutls \
+ ggz.2:${PORTSDIR}/games/libggz
+
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
-USE_GETOPT_LONG= yes
-
-.if defined(WITH_PCRE)
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-CFLAGS+= -DUSE_PCRE
-LDFLAGS+= -L${LOCALBASE}/lib -lpcre
-.endif
-
-.if defined(WITH_TLS)
-LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls \
- ggz.1:${PORTSDIR}/games/libggz
-CFLAGS+= -DUSE_TLS
-LDFLAGS+= -lggz -lgnutls -L${LOCALBASE}/lib
-.endif
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_GETTEXT= YES
+USE_GETOPT_LONG=yes
+
+LDFLAGS+= -L${LOCALBASE}/lib -lpcre -lggz -lgnutls \
+ -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN1= morebalance.1
MAN5= morebalance.conf.5
@@ -39,5 +33,6 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
@${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MANPREFIX}/man/man1
@${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.conf.5 ${MANPREFIX}/man/man5
+ @${MAKE_ENV} ${MAKE} -C ${WRKSRC} install-messages
.include <bsd.port.mk>