aboutsummaryrefslogtreecommitdiff
path: root/net/mosh/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:22:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:08 +0000
commit1c1859f69df8302b080894ba34312c525cb8287c (patch)
tree84a7f624b596e1e7357e241bbaa9185201397118 /net/mosh/Makefile
parentfb5004c69215be796b94d869d639a213bfecad30 (diff)
Diffstat (limited to 'net/mosh/Makefile')
-rw-r--r--net/mosh/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index 2424791cc5ad..854ab7535ca0 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -11,14 +11,14 @@ LICENSE= GPLv3
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-USES= autoreconf compiler:c++11-lang ncurses perl5 pkgconfig ssl
+USES= autoreconf compiler:c++17-lang ncurses perl5 pkgconfig ssl
USE_PERL5= run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-utempter --without-ncurses
CONFIGURE_ENV+= OpenSSL_CFLAGS="-I${OPENSSLINC}" OpenSSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto" \
TINFO_CFLAGS="-I/usr/include" ac_cv_have_decl_bswap64=yes
INSTALL_TARGET= install-strip
-USE_CXXSTD= c++11
+USE_CXXSTD= c++17
USE_GITHUB= yes
GH_ACCOUNT= mobile-shell