aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-12-08 18:48:41 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-12-08 18:48:41 +0000
commit81947e0a5a37191ee96a5315c0ae24d3c9ab60b5 (patch)
tree85f35e1bff99c0055c88b9964e6c1c11a900e81a /net/mosquitto
parent27630df81e9176b45cfd097970f29e8bb48a9f46 (diff)
downloadports-81947e0a5a37191ee96a5315c0ae24d3c9ab60b5.tar.gz
ports-81947e0a5a37191ee96a5315c0ae24d3c9ab60b5.zip
net/mosquitto: update to 1.5.4
This release fixes a number of security, building and memory leak issues. Announcement: https://mosquitto.org/blog/2018/11/version-154-released/ PR: 233552 Submitted by: iblis@hs.ntnu.edu.tw Approved by: joe@thrallingpenguin.com (maintainer)
Notes
Notes: svn path=/head/; revision=486979
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile12
-rw-r--r--net/mosquitto/distinfo6
-rw-r--r--net/mosquitto/files/patch-lib_socks__mosq.c13
-rw-r--r--net/mosquitto/files/patch-src_CMakeLists.txt22
4 files changed, 20 insertions, 33 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 45789e4162b1..234da85e8010 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mosquitto
-PORTVERSION= 1.5.3
-PORTREVISION= 1
+PORTVERSION= 1.5.4
CATEGORIES= net
MASTER_SITES= http://mosquitto.org/files/source/
@@ -17,21 +16,22 @@ LIB_DEPENDS= libcares.so:dns/c-ares \
BUILD_DEPENDS= xsltproc:textproc/libxslt
USES= cmake ssl
-NOCONFIGURE= yes
USE_RC_SUBR= mosquitto
USE_LDCONFIG= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION}
USERS= nobody
-OPTIONS_DEFINE= WS
+NOCONFIGURE= yes
+PLIST_SUB= PORTVERSION=${PORTVERSION}
-CMAKE_ARGS+= -DCMAKE_LIBDATADIR="${PREFIX}/libdata"
+OPTIONS_DEFINE= WS
WS_DESC= MQTT over Websockets support
WS_LIB_DEPENDS= libwebsockets.so:net/libwebsockets
WS_CMAKE_ON= -DWITH_WEBSOCKETS=ON
+CMAKE_ARGS+= -DCMAKE_LIBDATADIR="${PREFIX}/libdata"
+
post-patch:
# do not run ldconfig in stage dir
@${REINPLACE_CMD} -e '/ldconfig/d' ${WRKSRC}/src/CMakeLists.txt \
diff --git a/net/mosquitto/distinfo b/net/mosquitto/distinfo
index 084f51fb3087..66fafa75c371 100644
--- a/net/mosquitto/distinfo
+++ b/net/mosquitto/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538306679
-SHA256 (mosquitto-1.5.3.tar.gz) = 3081a998d303a883b1cd064009beabc88aa9159e26f5258a4ae6007160491d10
-SIZE (mosquitto-1.5.3.tar.gz) = 425844
+TIMESTAMP = 1542087175
+SHA256 (mosquitto-1.5.4.tar.gz) = 5fd7f3454fd6d286645d032bc07f44a1c8583cec02ef2422c9eb32e0a89a9b2f
+SIZE (mosquitto-1.5.4.tar.gz) = 430602
diff --git a/net/mosquitto/files/patch-lib_socks__mosq.c b/net/mosquitto/files/patch-lib_socks__mosq.c
deleted file mode 100644
index f0ea2bf1d2ef..000000000000
--- a/net/mosquitto/files/patch-lib_socks__mosq.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- lib/socks_mosq.c.orig 2018-09-30 11:40:37 UTC
-+++ lib/socks_mosq.c
-@@ -24,6 +24,10 @@ Contributors:
- #else
- # include <arpa/inet.h>
- #endif
-+#ifdef __FreeBSD__
-+# include <sys/socket.h>
-+# include <netinet/in.h>
-+#endif
-
- #include "mosquitto_internal.h"
- #include "memory_mosq.h"
diff --git a/net/mosquitto/files/patch-src_CMakeLists.txt b/net/mosquitto/files/patch-src_CMakeLists.txt
index 8113be78b1fa..90bb0e36d2e1 100644
--- a/net/mosquitto/files/patch-src_CMakeLists.txt
+++ b/net/mosquitto/files/patch-src_CMakeLists.txt
@@ -1,6 +1,6 @@
--- src/CMakeLists.txt.orig 2018-09-25 15:27:43 UTC
+++ src/CMakeLists.txt
-@@ -114,6 +114,7 @@ if (WIN32 OR CYGWIN)
+@@ -114,6 +114,7 @@
endif (WIN32 OR CYGWIN)
add_definitions (-DWITH_BROKER)
@@ -8,16 +8,16 @@
set (MOSQ_LIBS ${MOSQ_LIBS} ${OPENSSL_LIBRARIES})
-@@ -131,7 +132,7 @@ if (UNIX)
- if (APPLE)
- set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
- else (APPLE)
-- set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
-+ set (MOSQ_LIBS ${MOSQ_LIBS} m)
- find_library(LIBRT rt)
- if (LIBRT)
- set (MOSQ_LIBS ${MOSQ_LIBS} rt)
-@@ -185,7 +186,6 @@ if (${WITH_TLS} STREQUAL ON)
+@@ -132,7 +133,7 @@
+ elseif(QNX)
+ set(MOSQ_LIBS ${MOSQ_LIBS} m socket)
+ else(APPLE)
+- set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
++ set (MOSQ_LIBS ${MOSQ_LIBS} m)
+ find_library(LIBRT rt)
+ if (LIBRT)
+ set (MOSQ_LIBS ${MOSQ_LIBS} rt)
+@@ -186,7 +187,6 @@
endif (${WITH_TLS} STREQUAL ON)
if (UNIX AND NOT APPLE)