aboutsummaryrefslogtreecommitdiff
path: root/net/mpich
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-11-04 18:21:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-11-04 18:25:39 +0000
commit6fa3abe29462e2009e38629be7e46464d32d2e26 (patch)
treee688aeb8c99da68f52f57195d2e44e87301d28e0 /net/mpich
parente437beeb32146b0b1c79ec8bd0e0621c61d69f72 (diff)
downloadports-6fa3abe29462e2009e38629be7e46464d32d2e26.tar.gz
ports-6fa3abe29462e2009e38629be7e46464d32d2e26.zip
Diffstat (limited to 'net/mpich')
-rw-r--r--net/mpich/Makefile2
-rw-r--r--net/mpich/files/patch-l0-1.4.110
2 files changed, 11 insertions, 1 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 9ceea2f9f6d4..bb7fa8918ee2 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mpich
PORTVERSION= 3.4.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net parallel
MASTER_SITES= https://www.mpich.org/static/downloads/${DISTVERSION}/
diff --git a/net/mpich/files/patch-l0-1.4.1 b/net/mpich/files/patch-l0-1.4.1
index 6042bc127616..6f70e435377f 100644
--- a/net/mpich/files/patch-l0-1.4.1
+++ b/net/mpich/files/patch-l0-1.4.1
@@ -1,4 +1,5 @@
https://github.com/pmodels/mpich/pull/5623
++ additional fix from https://github.com/nwchemgit/nwchem/issues/463#issuecomment-960359049
src/gpu/mpl_gpu_ze.c:163:71: error: use of undeclared identifier 'ZE_IPC_MEMORY_FLAG_TBD'
zeMemOpenIpcHandle(global_ze_context, dev_handle, ipc_handle, ZE_IPC_MEMORY_FLAG_TBD, ptr);
@@ -26,6 +27,15 @@ src/gpu/mpl_gpu_ze.c:163:71: error: use of undeclared identifier 'ZE_IPC_MEMORY_
if (ret != ZE_RESULT_SUCCESS) {
mpl_err = MPL_ERR_GPU_INTERNAL;
goto fn_fail;
+@@ -191,6 +191,8 @@ int MPL_gpu_query_pointer_attr(const void *ptr, MPL_po
+ ze_device_handle_t device;
+ memset(&ptr_attr, 0, sizeof(ze_memory_allocation_properties_t));
+ ret = zeMemGetAllocProperties(global_ze_context, ptr, &ptr_attr, &device);
++ attr->type = 0;
++ attr->device = 0;
+ ZE_ERR_CHECK(ret);
+ attr->device = device;
+ switch (ptr_attr.type) {
--- src/pm/hydra2/mpl/src/gpu/mpl_gpu_ze.c.orig 2021-05-25 17:37:05 UTC
+++ src/pm/hydra2/mpl/src/gpu/mpl_gpu_ze.c
@@ -160,7 +160,7 @@ int MPL_gpu_ipc_handle_map(MPL_gpu_ipc_mem_handle_t ip