aboutsummaryrefslogtreecommitdiff
path: root/net/mpich
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-01-06 22:35:16 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-01-06 22:35:16 +0000
commit88f6984ec6739ecde758497de382187545ae9298 (patch)
tree90a150f20412749076f7f161dfed037596021ede /net/mpich
parentfd6055e71cddc5003399d1242baede53ab3a8100 (diff)
downloadports-88f6984ec6739ecde758497de382187545ae9298.tar.gz
ports-88f6984ec6739ecde758497de382187545ae9298.zip
Use ${FC} instead of hard coding gfortran42 (which would need to be
gfortran43 nowadays). Remove F77=${FC} from CONFIGURE_ENV since this provided by Mk/bsd.gcc.mk. Add USE_GCC=4.3 since this port uses both C and Fortran frontends.
Notes
Notes: svn path=/head/; revision=225361
Diffstat (limited to 'net/mpich')
-rw-r--r--net/mpich/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index acfd75eef99e..d7bee186f527 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -23,10 +23,11 @@ USE_BZIP2= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -prefix=${PREFIX}/mpich
USE_FORTRAN= yes
+USE_GCC= 4.3
F90FLAGS+= ${FFLAGS}
-FORTRANLIBDIR= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``
-FORTRANLIBDIR2= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``/../../../
-CONFIGURE_ENV+= F90=${FC} F90FLAGS=${F90FLAGS} F77=${FC} \
+FORTRANLIBDIR= `${DIRNAME} \`${FC} -print-libgcc-file-name\``
+FORTRANLIBDIR2= `${DIRNAME} \`${FC} -print-libgcc-file-name\``/../../../
+CONFIGURE_ENV+= F90=${FC} F90FLAGS=${F90FLAGS} \
LIBS="-L${FORTRANLIBDIR} -L${FORTRANLIBDIR2} -lgfortranbegin -lgfortran -L${LOCALBASE}/lib -lf2c"
OPTIONS= X11 "Enable MPE graphics" on \