aboutsummaryrefslogtreecommitdiff
path: root/net/msend
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-02-27 23:07:12 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-02-27 23:07:12 +0000
commitc8ff63f09c50081c707791ec68b83d8edebaf197 (patch)
tree356495698d0fb7f4cef3c0dbe8129e853f66b7ed /net/msend
parent74cdb2eb8bfec217717b14f6180f51c51baeb78f (diff)
downloadports-c8ff63f09c50081c707791ec68b83d8edebaf197.tar.gz
ports-c8ff63f09c50081c707791ec68b83d8edebaf197.zip
- Unbreak on 9.0
- add rc script - Pass maintainership to submitter PR: ports/165380 Submitted by: Denis Generalov <gd@ramble.ru> (maintainer) Approved by: gabor (mentor, implicit)
Notes
Notes: svn path=/head/; revision=292331
Diffstat (limited to 'net/msend')
-rw-r--r--net/msend/Makefile13
-rw-r--r--net/msend/files/mesgd.in27
-rw-r--r--net/msend/files/patch-common-h10
-rw-r--r--net/msend/pkg-plist2
4 files changed, 47 insertions, 5 deletions
diff --git a/net/msend/Makefile b/net/msend/Makefile
index f195d6eaef91..690e4c0e31f7 100644
--- a/net/msend/Makefile
+++ b/net/msend/Makefile
@@ -7,23 +7,30 @@
PORTNAME= msend
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= markp
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gd@rambler-co.ru
COMMENT= A client and server for the RFC1312 message protocol
+USE_RC_SUBR= mesgd
+USE_AUTOTOOLS= aclocal autoheader autoconf automake
+AUTOMAKE_ARGS+= --add-missing
GNU_CONFIGURE= yes
-CFLAGS+= -DUSE_READLINE
+CFLAGS+= -DUSE_READLINE -DNO_GETDTABLESIZE -DNEW_HEADERS
MAN1= msend.1
MAN8= mesgd.8
+PLIST_FILES= bin/msend \
+ sbin/mesgd
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 900007
-BROKEN= fails to build with new utmpx
+CFLAGS+= -DUSE_UTMPX
.endif
.include <bsd.port.post.mk>
diff --git a/net/msend/files/mesgd.in b/net/msend/files/mesgd.in
new file mode 100644
index 000000000000..a775cc2f01d3
--- /dev/null
+++ b/net/msend/files/mesgd.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: mesgd
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable mesgd:
+#
+# mesgd_enable=(bool): Set it to "YES" to enable mesgd
+#
+# and add appropriate mesgd_flags.
+#
+
+. /etc/rc.subr
+
+name="mesgd"
+rcvar=mesgd_enable
+
+load_rc_config $name
+
+: ${mesgd_enable="NO"}
+
+command=%%PREFIX%%/sbin/${name}
+
+run_rc_command "$1"
diff --git a/net/msend/files/patch-common-h b/net/msend/files/patch-common-h
new file mode 100644
index 000000000000..2705ac0ed488
--- /dev/null
+++ b/net/msend/files/patch-common-h
@@ -0,0 +1,10 @@
+--- common.h.orig 1999-05-02 17:00:39.000000000 +0400
++++ common.h 2012-02-22 02:20:34.000000000 +0400
+@@ -45,6 +45,7 @@
+
+ #ifdef USE_UTMPX
+ #include <utmpx.h>
++#define ut_name ut_user
+ #else
+ #include <utmp.h>
+ #endif
diff --git a/net/msend/pkg-plist b/net/msend/pkg-plist
deleted file mode 100644
index de10ddbee379..000000000000
--- a/net/msend/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/msend
-sbin/mesgd