aboutsummaryrefslogtreecommitdiff
path: root/net/nast/Makefile
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-06-02 15:17:13 +0000
committerMichael Landin <mich@FreeBSD.org>2003-06-02 15:17:13 +0000
commita2c29a16caf45cae0a2e803e8693deb3c5759e8a (patch)
tree8d7c87e0c41c3e0bccb93ad35de8bb0f7d09adce /net/nast/Makefile
parentc3006d849108bd4ff9f44a155662013df0b674fc (diff)
Notes
Diffstat (limited to 'net/nast/Makefile')
-rw-r--r--net/nast/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net/nast/Makefile b/net/nast/Makefile
index 579594cc2a36..7cec87fbbc79 100644
--- a/net/nast/Makefile
+++ b/net/nast/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nast
-PORTVERSION= 0.1.7d
+PORTVERSION= 0.1.7e
CATEGORIES= net
MASTER_SITES= http://nast.berlios.de/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -19,6 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
MAN8= nast.8
+DOC_FILES= README
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -36,11 +37,18 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8/
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
post-install:
${CHMOD} 0755 ${PREFIX}/bin/${PORTNAME}