aboutsummaryrefslogtreecommitdiff
path: root/net/ndisc6
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-09-13 17:05:25 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-09-13 17:05:25 +0000
commitf8676375822b84782813546dea56ee86c22b4d64 (patch)
treec87a911940c93062e9cd0999e4e65a4b69de101c /net/ndisc6
parent0f1910294c2fd47ca9bf14499bf9701822ee921b (diff)
downloadports-f8676375822b84782813546dea56ee86c22b4d64.tar.gz
ports-f8676375822b84782813546dea56ee86c22b4d64.zip
- Update to 1.0.2
PR: ports/160648 Submitted by: Mikhail T. <m.tsatsenko@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=281735
Diffstat (limited to 'net/ndisc6')
-rw-r--r--net/ndisc6/Makefile7
-rw-r--r--net/ndisc6/distinfo4
-rw-r--r--net/ndisc6/files/patch-rdnssd-rdnssd.c10
-rw-r--r--net/ndisc6/files/patch-src-ndisc.c11
4 files changed, 26 insertions, 6 deletions
diff --git a/net/ndisc6/Makefile b/net/ndisc6/Makefile
index ca3aa2a0e8dd..4a47b0cabfcf 100644
--- a/net/ndisc6/Makefile
+++ b/net/ndisc6/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= ndisc6
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTVERSION= 1.0.2
CATEGORIES= net ipv6
-MASTER_SITES= http://www.remlab.net/files/ndisc6/archive/ \
- http://people.via.ecp.fr/~rem/www.remlab.net/files/ndisc6/archive/
+MASTER_SITES= http://www.remlab.net/files/ndisc6/ \
+ http://people.via.ecp.fr/~rem/www.remlab.net/files/ndisc6/
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= IPv6 network diagnostic tools
diff --git a/net/ndisc6/distinfo b/net/ndisc6/distinfo
index 81e97d4bc025..3d96d8af12d9 100644
--- a/net/ndisc6/distinfo
+++ b/net/ndisc6/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ndisc6-1.0.1.tar.bz2) = 1daf9e08783d85aebe1e564d6e83d5a3d57baa231de98cc0d621ce3f7a62efdd
-SIZE (ndisc6-1.0.1.tar.bz2) = 237621
+SHA256 (ndisc6-1.0.2.tar.bz2) = 6acec8a0cb9efa3ac98456f46c3016aeec0598b0c7557c95242b5228ad62ca7a
+SIZE (ndisc6-1.0.2.tar.bz2) = 239249
diff --git a/net/ndisc6/files/patch-rdnssd-rdnssd.c b/net/ndisc6/files/patch-rdnssd-rdnssd.c
new file mode 100644
index 000000000000..df730bbdd30c
--- /dev/null
+++ b/net/ndisc6/files/patch-rdnssd-rdnssd.c
@@ -0,0 +1,10 @@
+--- rdnssd/rdnssd.c.orig 2011-09-10 14:20:44.451134584 +0400
++++ rdnssd/rdnssd.c 2011-09-10 14:21:09.758658207 +0400
+@@ -29,6 +29,7 @@
+ #include <stdbool.h>
+ #include <locale.h>
+ #include <signal.h>
++#include <stdint.h>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/net/ndisc6/files/patch-src-ndisc.c b/net/ndisc6/files/patch-src-ndisc.c
new file mode 100644
index 000000000000..e2b49166603f
--- /dev/null
+++ b/net/ndisc6/files/patch-src-ndisc.c
@@ -0,0 +1,11 @@
+--- src/ndisc.c.orig 2011-09-10 14:17:49.714181834 +0400
++++ src/ndisc.c 2011-09-10 14:17:51.893973268 +0400
+@@ -440,8 +440,6 @@
+ gettext ((v & ND_RA_FLAG_MANAGED) ? N_ ("Yes") : N_("No")));
+ printf (_("Stateful other conf. : %3s\n"),
+ gettext ((v & ND_RA_FLAG_OTHER) ? N_ ("Yes") : N_("No")));
+- printf (_("Mobile home agent : %3s\n"),
+- gettext ((v & ND_RA_FLAG_HOME_AGENT) ? N_ ("Yes") : N_("No")));
+ printf (_("Router preference : %6s\n"), pref_i2n (v));
+ printf (_("Neighbor discovery proxy : %3s\n"),
+ gettext ((v & 0x04) ? N_ ("Yes") : N_("No")));