aboutsummaryrefslogtreecommitdiff
path: root/net/neatvnc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-01-15 21:16:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-01-15 21:16:28 +0000
commit902623646cf720e4945823150769df1ad1f5d4ad (patch)
treeb9a775d82723615caf7b559a9895f1c671aeb197 /net/neatvnc
parent31bced2db6b2d88a7283a5bdc93b8b87d4d61709 (diff)
downloadports-902623646cf720e4945823150769df1ad1f5d4ad.tar.gz
ports-902623646cf720e4945823150769df1ad1f5d4ad.zip
net/wayvnc: add new port
This is a VNC server for wlroots based Wayland compositors. https://github.com/any1/wayvnc
Notes
Notes: svn path=/head/; revision=523172
Diffstat (limited to 'net/neatvnc')
-rw-r--r--net/neatvnc/Makefile29
-rw-r--r--net/neatvnc/distinfo3
-rw-r--r--net/neatvnc/pkg-descr4
-rw-r--r--net/neatvnc/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/net/neatvnc/Makefile b/net/neatvnc/Makefile
new file mode 100644
index 000000000000..b92e470f1a38
--- /dev/null
+++ b/net/neatvnc/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= neatvnc
+PORTVERSION= s20200113
+CATEGORIES= net
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Liberally licensed VNC server library
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/libdrm/drm_fourcc.h:graphics/libdrm
+LIB_DEPENDS= libuv.so:devel/libuv
+
+USES= compiler:c11 meson pkgconfig xorg
+USE_GITHUB= yes
+USE_XORG= pixman
+USE_LDCONFIG= yes
+GH_ACCOUNT= any1
+GH_TAGNAME= 6bb3362
+
+OPTIONS_DEFINE= JPEG
+OPTIONS_DEFAULT=JPEG
+
+JPEG_LIB_DEPENDS= libturbojpeg.so:graphics/libjpeg-turbo
+JPEG_MESON_ENABLED= tight-encoding
+
+.include <bsd.port.mk>
diff --git a/net/neatvnc/distinfo b/net/neatvnc/distinfo
new file mode 100644
index 000000000000..e1fbb749b177
--- /dev/null
+++ b/net/neatvnc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578911972
+SHA256 (any1-neatvnc-s20200113-6bb3362_GH0.tar.gz) = a5cffd98ffbcc36c77aaa1cfdc9dc3dd575120cfeb629305d27af801b7d514d7
+SIZE (any1-neatvnc-s20200113-6bb3362_GH0.tar.gz) = 623811
diff --git a/net/neatvnc/pkg-descr b/net/neatvnc/pkg-descr
new file mode 100644
index 000000000000..fb29c44d9e02
--- /dev/null
+++ b/net/neatvnc/pkg-descr
@@ -0,0 +1,4 @@
+This is a liberally licensed VNC server library that's intended to be
+fast and neat.
+
+WWW: https://github.com/any1/neatvnc
diff --git a/net/neatvnc/pkg-plist b/net/neatvnc/pkg-plist
new file mode 100644
index 000000000000..a3b6e11654f5
--- /dev/null
+++ b/net/neatvnc/pkg-plist
@@ -0,0 +1,5 @@
+include/neatvnc.h
+lib/libneatvnc.so
+lib/libneatvnc.so.0
+lib/libneatvnc.so.0.0.0
+libdata/pkgconfig/neatvnc.pc