aboutsummaryrefslogtreecommitdiff
path: root/net/net-http
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-16 02:41:43 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-16 02:41:43 +0000
commitea7d6dd3f735d4f2c71d87da631cd0d474129742 (patch)
tree015035a1c93bf35137ee454b3d5e643ea8bac57a /net/net-http
parent9e81f50727203b078efde2c799619e1651168f25 (diff)
downloadports-ea7d6dd3f735d4f2c71d87da631cd0d474129742.tar.gz
ports-ea7d6dd3f735d4f2c71d87da631cd0d474129742.zip
- fix pkg-plist (chase guile's version with a PLIST_SUB)
- portlint PR: 52075 Submitted by: Kirill Ponomarew <ponomarew@oberon.net>
Notes
Notes: svn path=/head/; revision=81067
Diffstat (limited to 'net/net-http')
-rw-r--r--net/net-http/Makefile3
-rw-r--r--net/net-http/pkg-plist14
2 files changed, 9 insertions, 8 deletions
diff --git a/net/net-http/Makefile b/net/net-http/Makefile
index ac28281c6fdd..35bd177da7ad 100644
--- a/net/net-http/Makefile
+++ b/net/net-http/Makefile
@@ -9,7 +9,7 @@
PORTNAME= net-http
PORTVERSION= 0.3.1
CATEGORIES= net
-MASTER_SITES= http://evan.prodromou.san-francisco.ca.us/software/net-http/
+MASTER_SITES= http://evan.prodromou.san-francisco.ca.us/software/net-http/
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for doing HTTP client-side programming in Guile
@@ -24,6 +24,7 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
GUILE_VER!= (cd ${PORTSDIR}/lang/guile && make -V GUILE_VER)
+PLIST_SUB= GUILE_VER="${GUILE_VER}"
do-install:
${CP} -R ${WRKSRC}/net/ ${LOCALBASE}/share/guile/${GUILE_VER}/net/
diff --git a/net/net-http/pkg-plist b/net/net-http/pkg-plist
index 151b67f9dce5..67300fdb05c8 100644
--- a/net/net-http/pkg-plist
+++ b/net/net-http/pkg-plist
@@ -1,7 +1,7 @@
-share/guile/1.4.1/net/http.scm
-share/guile/1.4.1/net/http/client.scm
-share/guile/1.4.1/net/http/message.scm
-share/guile/1.4.1/net/http/server.scm
-share/guile/1.4.1/net/http/util.scm
-@dirrm share/guile/1.4.1/net/http
-@dirrm share/guile/1.4.1/net
+share/guile/%%GUILE_VER%%/net/http.scm
+share/guile/%%GUILE_VER%%/net/http/client.scm
+share/guile/%%GUILE_VER%%/net/http/message.scm
+share/guile/%%GUILE_VER%%/net/http/server.scm
+share/guile/%%GUILE_VER%%/net/http/util.scm
+@dirrm share/guile/%%GUILE_VER%%/net/http
+@dirrm share/guile/%%GUILE_VER%%/net