aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk3
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2016-07-26 15:42:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2016-07-26 15:42:45 +0000
commitfff478f7189e02596c34463b479fe63c13c472d7 (patch)
tree80b80e490de741579c2fc9d6fd8ea515e688bcbe /net/netatalk3
parent23d18133f35da95ad3f3322b4d44dc6fd940ed47 (diff)
Remove -L from CFLAGS (and add it to LDFLAGS) to fix a build issue on 10.1.
PR: 211366
Notes
Notes: svn path=/head/; revision=419119
Diffstat (limited to 'net/netatalk3')
-rw-r--r--net/netatalk3/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index aecea4ea29bf..3b4908e976e2 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -84,21 +84,24 @@ SUB_LIST+= ZEROCONF=""
.if ${PORT_OPTIONS:MAVAHI}
CONFIGURE_ARGS+= --enable-zeroconf=${LOCALBASE}
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= libavahi-client.so:net/avahi-app
SUB_LIST+= ZEROCONF="avahi_daemon"
.endif
.if ${PORT_OPTIONS:MMDNSRESPONDER}
CONFIGURE_ARGS+= --enable-zeroconf=${LOCALBASE}
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= libdns_sd.so:net/mDNSResponder
SUB_LIST+= ZEROCONF="mdnsd"
.endif
.if ${PORT_OPTIONS:MLDAP}
CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENLDAP= yes
.else
CONFIGURE_ARGS+= --without-ldap