aboutsummaryrefslogtreecommitdiff
path: root/net/netboot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-27 21:12:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-27 21:12:36 +0000
commitf57b769c716f23fe4ff78a9e8d4b7a8592b6bae9 (patch)
tree2e186c259eacce820602dbd4af25206389331670 /net/netboot
parent9ac8630fb49706ec34ad68c79f8d54f5b20c3b2f (diff)
downloadports-f57b769c716f23fe4ff78a9e8d4b7a8592b6bae9.tar.gz
ports-f57b769c716f23fe4ff78a9e8d4b7a8592b6bae9.zip
Notes
Diffstat (limited to 'net/netboot')
-rw-r--r--net/netboot/Makefile7
-rw-r--r--net/netboot/files/patch-misc::Makefile11
-rw-r--r--net/netboot/pkg-plist3
3 files changed, 20 insertions, 1 deletions
diff --git a/net/netboot/Makefile b/net/netboot/Makefile
index 52cb7a35ef35..d011592f9b33 100644
--- a/net/netboot/Makefile
+++ b/net/netboot/Makefile
@@ -6,7 +6,7 @@
PORTNAME= netboot
PORTVERSION= 0.9.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,4 +20,9 @@ GNU_CONFIGURE= yes
MAN5= netboot.5 netboot.config.5 netboot.drivers.5 netboot.db.5
MAN8= mknbi-mgl.8 makerom.8 mknbi-dos.8 mknbi-linux.8
+post-install:
+ @if [ ! -f ${PREFIX}/etc/netboot.config ]; then \
+ ${CP} ${PREFIX}/etc/netboot.config-dist ${PREFIX}/etc/netboot.config; \
+ fi
+
.include <bsd.port.mk>
diff --git a/net/netboot/files/patch-misc::Makefile b/net/netboot/files/patch-misc::Makefile
new file mode 100644
index 000000000000..c1712d4bc983
--- /dev/null
+++ b/net/netboot/files/patch-misc::Makefile
@@ -0,0 +1,11 @@
+--- misc/Makefile.orig Wed Jan 19 15:24:01 2005
++++ misc/Makefile Wed Jan 19 15:24:27 2005
+@@ -77,7 +77,7 @@
+ $(INSTALL) -d $(sysconfdir)
+ $(INSTALL) -d $(nblibdir)
+ $(INSTALL) -d $(mandir)/man$(MANEXT)
+- $(INSTALL) -m 644 -o bin -g bin $(nbconfig) $(sysconfdir)/$(nbconfig)
++ $(INSTALL) -m 644 -o bin -g bin $(nbconfig) $(sysconfdir)/$(nbconfig)-dist
+ $(INSTALL) -m 644 -o bin -g bin $(drivers) $(nblibdir)/$(drivers)
+ $(INSTALL) -m 644 -o bin -g bin netboot.man $(mandir)/man$(MANEXT)/netboot.$(MANEXT)
+ $(INSTALL) -m 644 -o bin -g bin $(nbconfig).man $(mandir)/man$(MANEXT)/$(nbconfig).$(MANEXT)
diff --git a/net/netboot/pkg-plist b/net/netboot/pkg-plist
index b0906ab1ff73..628d569f101a 100644
--- a/net/netboot/pkg-plist
+++ b/net/netboot/pkg-plist
@@ -2,6 +2,9 @@ bin/makerom
bin/mknbi-dos
bin/mknbi-linux
bin/mknbi-mgl
+@unexec if cmp -s %D/etc/netboot.config %D/etc/netboot.config-dist; then rm -f %D/etc/netboot.config; fi
+etc/netboot.config-dist
+@exec [ -f %B/netboot.config ] || cp %B/%f %B/netboot.config
lib/netboot/netboot.drivers
lib/netboot/binaries/floppy.bin
lib/netboot/binaries/floppy86.bin