aboutsummaryrefslogtreecommitdiff
path: root/net/netembryo/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-22 19:45:34 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-22 19:45:34 +0000
commit453d7f61119d7257f4edada6971c5e0b38fff955 (patch)
treed292d8ac91deab9d17db9101b62cc0b44d651830 /net/netembryo/Makefile
parentf6c01d38664db983567aa79729472dd938c67223 (diff)
downloadports-453d7f61119d7257f4edada6971c5e0b38fff955.tar.gz
ports-453d7f61119d7257f4edada6971c5e0b38fff955.zip
- Update to version 0.1.1
PR: ports/170163 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307664
Diffstat (limited to 'net/netembryo/Makefile')
-rw-r--r--net/netembryo/Makefile32
1 files changed, 26 insertions, 6 deletions
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index 46ad12ee9916..08a1c521c984 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -6,20 +6,40 @@
#
PORTNAME= netembryo
-PORTVERSION= 0.0.5
+PORTVERSION= 0.1.1
CATEGORIES= net
MASTER_SITES= http://lscube.org/files/downloads/netembryo/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A network abstraction library used by for feng, libnemesi, felix
+COMMENT= Network abstraction library used by for feng, libnemesi, felix
LICENSE= LGPL21
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+OPTIONS_DEFINE= OPENSSL
+OPTIONS_DEFAULT=OPENSSL
+
USE_BZIP2= yes
+USE_GNOME= glib20 gnomehack
+USE_PKGCONFIG= build
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool
+CONFIGURE_ARGS= --disable-silent-rules
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
-USE_GNOME= gnomehack
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPENSSL}
+USE_OPENSSL= yes
+CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB}"
+.else
+CONFIGURE_ARGS+=--without-openssl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CPPFLAGS=|#CPPFLAGS| ; \
+ s|freebsd[0-9]|freebsd|' ${WRKSRC}/configure
.include <bsd.port.mk>