aboutsummaryrefslogtreecommitdiff
path: root/net/netpipes
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-10-07 04:32:33 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-10-07 04:32:33 +0000
commit21040de0e2aea77dd534e221ffb9c56133c679e7 (patch)
tree549e9ac0dc8f1fd56964d0bef2f7f0e6ecea09d2 /net/netpipes
parentce82376b7c2dd61d899353443bcee0dac1063909 (diff)
downloadports-21040de0e2aea77dd534e221ffb9c56133c679e7.tar.gz
ports-21040de0e2aea77dd534e221ffb9c56133c679e7.zip
Netpipes is a collection of utilities which attempts to provide the
functionality of pipes over a network. PR: ports/4056 Submitted by: Daniel O'Connor doconnor@ist.flinders.edu.au
Notes
Notes: svn path=/head/; revision=8145
Diffstat (limited to 'net/netpipes')
-rw-r--r--net/netpipes/Makefile18
-rw-r--r--net/netpipes/distinfo1
-rw-r--r--net/netpipes/files/patch-aa43
-rw-r--r--net/netpipes/pkg-comment1
-rw-r--r--net/netpipes/pkg-descr5
-rw-r--r--net/netpipes/pkg-plist8
6 files changed, 76 insertions, 0 deletions
diff --git a/net/netpipes/Makefile b/net/netpipes/Makefile
new file mode 100644
index 000000000000..e4ac597c9f4a
--- /dev/null
+++ b/net/netpipes/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: netpipes3.2
+# Version required: 3.2
+# Date created: 12th April 1997
+# Whom: doconnor@ist.flinders.edu.au
+#
+# $Id$
+#
+
+DISTNAME= netpipes3.2
+PKGNAME= netpipes-3.2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.cis.ufl.edu/pub/staff/thoth/
+
+MAINTAINER= doconnor@ist.flinders.edu.au
+
+MAN1= faucet.1 hose.1 sockdown.1 getpeername.1
+
+.include <bsd.port.mk>
diff --git a/net/netpipes/distinfo b/net/netpipes/distinfo
new file mode 100644
index 000000000000..b21d385811b4
--- /dev/null
+++ b/net/netpipes/distinfo
@@ -0,0 +1 @@
+MD5 (netpipes3.2.tar.gz) = 52402e636772c32a37228e5349042d09
diff --git a/net/netpipes/files/patch-aa b/net/netpipes/files/patch-aa
new file mode 100644
index 000000000000..d5603542cc41
--- /dev/null
+++ b/net/netpipes/files/patch-aa
@@ -0,0 +1,43 @@
+--- Makefile.orig Fri Jun 28 00:03:45 1996
++++ Makefile Tue Jul 8 15:15:40 1997
+@@ -17,7 +17,7 @@
+
+ # You probably want to change this:
+ #INSTROOT = ${HOME}
+-INSTROOT = /depot/collections0/netpipes3.2
++INSTROOT = ${PREFIX}
+ INSTBIN = ${INSTROOT}/bin
+ INSTMAN = ${INSTROOT}/man
+
+@@ -46,8 +46,12 @@
+ # (that system call is used by the -daemon argument to detach faucet from
+ # the controlling terminal)
+
++# FreeBSD 2.1.0
++CFLAGS = -DUSE_IOCTL $(CDEBUGFLAGS)
++CC = gcc
++
+ # SunOS 4.1.4
+-CFLAGS = -DUSE_IOCTL -DNO_MEMMOVE $(CDEBUGFLAGS)
++#CFLAGS = -DUSE_IOCTL -DNO_MEMMOVE $(CDEBUGFLAGS)
+
+ # Linux
+ #CFLAGS = -DUSE_IOCTL -DSYSV $(CDEBUGFLAGS)
+@@ -83,14 +87,9 @@
+ ${CC} ${CFLAGS} -o $@ ${GOBJS} ${LDLIBS}
+
+ install : all
+- [ -d ${INSTROOT} ] || mkdir ${INSTROOT}
+- [ -d ${INSTBIN} ] || mkdir ${INSTBIN}
+- cp ${PROGRAMS} ${INSTBIN}/
+- - rm -f ${INSTBIN}/getsockname
+- ln -s getpeername ${INSTBIN}/getsockname
+- [ -d ${INSTMAN} ] || mkdir ${INSTMAN}
+- [ -d ${INSTMAN}/man1 ] || mkdir ${INSTMAN}/man1
+- cp ${MANPAGES} ${INSTMAN}/man1/
++ ${BSD_INSTALL_MAN} ${MANPAGES} ${INSTMAN}/man1/
++ ${BSD_INSTALL_PROGRAM} ${PROGRAMS} ${INSTBIN}/
++ ln -f -s ${INSTBIN}/getpeername ${INSTBIN}/getsockname
+
+ clean :
+ rm -f ${FOBJS} ${HOBJS} ${SOBJS} ${GOBJS}
diff --git a/net/netpipes/pkg-comment b/net/netpipes/pkg-comment
new file mode 100644
index 000000000000..1305d3a1590a
--- /dev/null
+++ b/net/netpipes/pkg-comment
@@ -0,0 +1 @@
+A group of shell utilities to connect programs to sockets
diff --git a/net/netpipes/pkg-descr b/net/netpipes/pkg-descr
new file mode 100644
index 000000000000..fd130bd11c7f
--- /dev/null
+++ b/net/netpipes/pkg-descr
@@ -0,0 +1,5 @@
+Netpipes is a collection of utilities which attempts to provide the
+functionality of pipes over a network.
+
+ - Daniel O'Connor
+ doconnor@ist.flinders.edu.au
diff --git a/net/netpipes/pkg-plist b/net/netpipes/pkg-plist
new file mode 100644
index 000000000000..288454f6e3d7
--- /dev/null
+++ b/net/netpipes/pkg-plist
@@ -0,0 +1,8 @@
+bin/faucet
+bin/hose
+bin/sockdown
+bin/getpeername
+man/man1/faucet.1.gz
+man/man1/hose.1.gz
+man/man1/sockdown.1.gz
+man/man1/getpeername.1.gz