aboutsummaryrefslogtreecommitdiff
path: root/net/netpipes
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 06:52:59 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 06:52:59 +0000
commit42d57a80e550d99534e6046defa1a5ec5a99df78 (patch)
tree232dd4dfc1133bbebd127e206ef061b1563dffdc /net/netpipes
parent7e7b6c424cfe1cf59b22ebc135c87d8880b1df0b (diff)
downloadports-42d57a80e550d99534e6046defa1a5ec5a99df78.tar.gz
ports-42d57a80e550d99534e6046defa1a5ec5a99df78.zip
Updated to netpipes-4.2
PR: ports/10506 Submitted by: Michael Haro mharo@area51.fremont.ca.us
Notes
Notes: svn path=/head/; revision=17275
Diffstat (limited to 'net/netpipes')
-rw-r--r--net/netpipes/Makefile11
-rw-r--r--net/netpipes/distinfo2
-rw-r--r--net/netpipes/files/patch-aa43
-rw-r--r--net/netpipes/pkg-plist5
4 files changed, 37 insertions, 24 deletions
diff --git a/net/netpipes/Makefile b/net/netpipes/Makefile
index c558b58fa00c..f8105f3fbb39 100644
--- a/net/netpipes/Makefile
+++ b/net/netpipes/Makefile
@@ -3,17 +3,18 @@
# Date created: 12th April 1997
# Whom: doconnor@gsoft.com.au
#
-# $Id: Makefile,v 1.5 1998/08/10 12:04:38 steve Exp $
+# $Id: Makefile,v 1.6 1998/11/23 01:05:55 flathill Exp $
#
-DISTNAME= netpipes4.0
-PKGNAME= netpipes-4.0
+DISTNAME= netpipes-4.2-export
+PKGNAME= netpipes-4.2
CATEGORIES= net
-MASTER_SITES= ftp://ftp.purplefrog.com/pub/netpipes/old/
+MASTER_SITES= ftp://ftp.purplefrog.com/pub/netpipes/
MAINTAINER= doconnor@gsoft.com.au
+NO_WRKSUBDIR= yes
MAN1= faucet.1 hose.1 sockdown.1 getpeername.1 encapsulate.1 \
- timelimit.1
+ timelimit.1 netpipes.1
.include <bsd.port.mk>
diff --git a/net/netpipes/distinfo b/net/netpipes/distinfo
index e94f58374212..cf7d0c866e12 100644
--- a/net/netpipes/distinfo
+++ b/net/netpipes/distinfo
@@ -1 +1 @@
-MD5 (netpipes4.0.tar.gz) = 522bcf3653c63c19d6a9ec53b98fe2cd
+MD5 (netpipes-4.2-export.tar.gz) = 36f7b3120e00c9c74cb6619334de419f
diff --git a/net/netpipes/files/patch-aa b/net/netpipes/files/patch-aa
index 89e5070d9e20..272ce1c0ed48 100644
--- a/net/netpipes/files/patch-aa
+++ b/net/netpipes/files/patch-aa
@@ -1,24 +1,24 @@
---- Makefile.orig Wed Apr 15 11:49:24 1998
-+++ Makefile Wed Apr 15 11:50:42 1998
+--- Makefile.orig Wed Oct 28 12:30:03 1998
++++ Makefile Tue Mar 9 03:10:00 1999
@@ -17,7 +17,7 @@
# You probably want to change this:
#INSTROOT = ${HOME}
--INSTROOT = /depot/collections0/netpipes4.0
+-INSTROOT = /depot/collections0/netpipes4.1
+INSTROOT = ${PREFIX}
+ #INSTROOT = /usr/local
INSTBIN = ${INSTROOT}/bin
INSTMAN = ${INSTROOT}/man
+@@ -59,7 +59,7 @@
+ #CFLAGS = -DPOSIX_SIG -DHAVE_INET_ATON $(CDEBUGFLAGS)
-@@ -52,7 +52,7 @@
- #CFLAGS = -DUSE_IOCTL -DNO_MEMMOVE -DNO_STRERROR $(CDEBUGFLAGS)
-
- # Linux
+ # Linux (developed with RedHat 4.2, libc5)
-CFLAGS = -DUSE_IOCTL -DPOSIX_SIG -DHAVE_INET_ATON $(CDEBUGFLAGS)
+#CFLAGS = -DUSE_IOCTL -DPOSIX_SIG -DHAVE_INET_ATON $(CDEBUGFLAGS)
# SGI
#CFLAGS = -DSYSV $(CDEBUGFLAGS)
-@@ -61,7 +61,7 @@
+@@ -71,7 +71,7 @@
#CFLAGS = -DPOSIX_SIG $(CDEBUGFLAGS)
# FreeBSD
@@ -27,21 +27,32 @@
# AIX 4.1.4 and 3.2.5
#CFLAGS = -DPOSIX_SIG -DAIX $(CDEBUGFLAGS)
-@@ -103,14 +103,9 @@
- ${CC} ${CFLAGS} -o $@ ${EOBJS} ${LDLIBS}
+@@ -104,8 +104,7 @@
+ SSLLIB = -L../SSLeay-0.8.1 -lssl -lcrypto
+
+ MANPAGES = netpipes.1 faucet.1 hose.1 \
+- sockdown.1 getpeername.1 timelimit.1 encapsulate.1 \
+- ssl-auth.1
++ sockdown.1 getpeername.1 timelimit.1 encapsulate.1
+ PROGRAMS = faucet hose sockdown getpeername timelimit encapsulate
+
+ all : ${PROGRAMS}
+@@ -138,15 +137,9 @@
+ ${CC} ${CFLAGS} ${SSLINC} -c $<
install : all
-- [ -d ${INSTROOT} ] || mkdir ${INSTROOT}
-- [ -d ${INSTBIN} ] || mkdir ${INSTBIN}
+- test -d ${INSTROOT} || mkdir ${INSTROOT}
+- test -d ${INSTBIN} || mkdir ${INSTBIN}
- cp ${PROGRAMS} ${INSTBIN}/
- - rm -f ${INSTBIN}/getsockname
- ln -s getpeername ${INSTBIN}/getsockname
-- [ -d ${INSTMAN} ] || mkdir ${INSTMAN}
-- [ -d ${INSTMAN}/man1 ] || mkdir ${INSTMAN}/man1
+- - [ -x ssl-auth ] && cp ssl-auth ${INSTBIN}/
+- test -d ${INSTMAN} || mkdir ${INSTMAN}
+- test -d ${INSTMAN}/man1 || mkdir ${INSTMAN}/man1
- cp ${MANPAGES} ${INSTMAN}/man1/
+ ${BSD_INSTALL_MAN} ${MANPAGES} ${INSTMAN}/man1/
+ ${BSD_INSTALL_PROGRAM} ${PROGRAMS} ${INSTBIN}/
+ ln -f -s ${INSTBIN}/getpeername ${INSTBIN}/getsockname
- clean :
- rm -f ${FOBJS} ${HOBJS} ${SOBJS} ${GOBJS} ${TOBJS} ${EOBJS}
+ #
+
diff --git a/net/netpipes/pkg-plist b/net/netpipes/pkg-plist
index 7b9898270f48..25c997745a86 100644
--- a/net/netpipes/pkg-plist
+++ b/net/netpipes/pkg-plist
@@ -1,6 +1,7 @@
+bin/encapsulate
bin/faucet
+bin/getpeername
+bin/getsockname
bin/hose
bin/sockdown
-bin/getpeername
-bin/encapsulate
bin/timelimit