aboutsummaryrefslogtreecommitdiff
path: root/net/netpipes
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-04 10:30:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-04 10:30:30 +0000
commitde1e6359e456b8793b50d25d232c637d1d973f3a (patch)
tree5af563266d1c1cec9fb8706b679206f29565a4d2 /net/netpipes
parentc1f7f4fc6ca5a12d28f51116eef7816067e9a577 (diff)
downloadports-de1e6359e456b8793b50d25d232c637d1d973f3a.tar.gz
ports-de1e6359e456b8793b50d25d232c637d1d973f3a.zip
Notes
Diffstat (limited to 'net/netpipes')
-rw-r--r--net/netpipes/Makefile6
-rw-r--r--net/netpipes/files/patch-Makefile (renamed from net/netpipes/files/patch-aa)8
-rw-r--r--net/netpipes/pkg-plist8
3 files changed, 15 insertions, 7 deletions
diff --git a/net/netpipes/Makefile b/net/netpipes/Makefile
index f76f7322f085..48831a31e752 100644
--- a/net/netpipes/Makefile
+++ b/net/netpipes/Makefile
@@ -14,8 +14,8 @@ COMMENT= A group of shell utilities to connect programs to sockets
CONFLICTS= timelimit-[0-9]*
NO_WRKSUBDIR= yes
-MAN1= faucet.1 hose.1 sockdown.1 getpeername.1 encapsulate.1 \
- timelimit.1 netpipes.1
-NO_STAGE= yes
+do-install:
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKDIR} STAGEDIR=${STAGEDIR} install
+
.include <bsd.port.mk>
diff --git a/net/netpipes/files/patch-aa b/net/netpipes/files/patch-Makefile
index 77fdc782931b..97b8b6147e1e 100644
--- a/net/netpipes/files/patch-aa
+++ b/net/netpipes/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig Wed Oct 28 12:30:03 1998
-+++ Makefile Fri Jun 7 00:23:28 2002
+--- Makefile.orig 1998-10-29 07:00:03.000000000 +1030
++++ Makefile 2014-05-11 13:28:21.742500328 +0930
@@ -17,7 +17,7 @@
# You probably want to change this:
#INSTROOT = ${HOME}
-INSTROOT = /depot/collections0/netpipes4.1
-+INSTROOT = ${PREFIX}
++INSTROOT = ${STAGEDIR}/${PREFIX}
#INSTROOT = /usr/local
INSTBIN = ${INSTROOT}/bin
INSTMAN = ${INSTROOT}/man
@@ -61,7 +61,7 @@
- cp ${MANPAGES} ${INSTMAN}/man1/
+ ${BSD_INSTALL_MAN} ${MANPAGES} ${INSTMAN}/man1/
+ ${BSD_INSTALL_PROGRAM} ${PROGRAMS} ${INSTBIN}/
-+ ln -f -s ${INSTBIN}/getpeername ${INSTBIN}/getsockname
++ ln -f -s getpeername ${INSTBIN}/getsockname
#
diff --git a/net/netpipes/pkg-plist b/net/netpipes/pkg-plist
index 25c997745a86..3c4d8fbae0ab 100644
--- a/net/netpipes/pkg-plist
+++ b/net/netpipes/pkg-plist
@@ -5,3 +5,11 @@ bin/getsockname
bin/hose
bin/sockdown
bin/timelimit
+man/man1/encapsulate.1.gz
+man/man1/faucet.1.gz
+man/man1/getpeername.1.gz
+man/man1/hose.1.gz
+man/man1/netpipes.1.gz
+man/man1/sockdown.1.gz
+man/man1/timelimit.1.gz
+