aboutsummaryrefslogtreecommitdiff
path: root/net/netscript/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-28 07:02:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-28 07:02:47 +0000
commit58a3b044399f7c620a30e89b77cb946e04c0a75e (patch)
treea0b9faa0a8c8eb8157ce460071ca6527b0aab971 /net/netscript/Makefile
parent0cdb193c88637a6932b807445d29207a9ab6a098 (diff)
downloadports-58a3b044399f7c620a30e89b77cb946e04c0a75e.tar.gz
ports-58a3b044399f7c620a30e89b77cb946e04c0a75e.zip
upgrade to 1.6.4
Notes
Notes: svn path=/head/; revision=50676
Diffstat (limited to 'net/netscript/Makefile')
-rw-r--r--net/netscript/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/net/netscript/Makefile b/net/netscript/Makefile
index 9734e6385f5c..9b87bf2cd6b6 100644
--- a/net/netscript/Makefile
+++ b/net/netscript/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= netscript
-PORTVERSION= 1.6.3
-PORTREVISION= 1
+PORTVERSION= 1.6.4
+PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,10 +16,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+WANT_GTK= yes
-do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} -DARPA -DBSD_T netscript.c -o netscript
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GTK)
+USE_GTK= yes
+ALL_TARGET= gbsd
+.else
+ALL_TARGET= bsd
+.endif
+
+post-patch:
+ @${PERL} -pi -e "s,gtk-config,${GTK_CONFIG},g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/netscript ${PREFIX}/bin
@@ -27,7 +36,7 @@ do-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>