aboutsummaryrefslogtreecommitdiff
path: root/net/netscript
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-30 13:25:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-30 13:25:41 +0000
commitc03d6e53e3b0c3cf3660590d778a5c739ef5ebba (patch)
tree1f70f87d48118374be6eda496eebda3edccf13c0 /net/netscript
parent4ceed7f194939f372f3a718c65dcfab1dbae6d11 (diff)
downloadports-c03d6e53e3b0c3cf3660590d778a5c739ef5ebba.tar.gz
ports-c03d6e53e3b0c3cf3660590d778a5c739ef5ebba.zip
add netscript
(portable/multi-platform) lightweight tcp socket scripting
Notes
Notes: svn path=/head/; revision=43311
Diffstat (limited to 'net/netscript')
-rw-r--r--net/netscript/Makefile25
-rw-r--r--net/netscript/distinfo1
-rw-r--r--net/netscript/pkg-comment1
-rw-r--r--net/netscript/pkg-descr13
-rw-r--r--net/netscript/pkg-plist11
5 files changed, 51 insertions, 0 deletions
diff --git a/net/netscript/Makefile b/net/netscript/Makefile
new file mode 100644
index 000000000000..07a4405de158
--- /dev/null
+++ b/net/netscript/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: netscript
+# Date created: May 30, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= netscript
+PORTVERSION= 1.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.realhalo.org/netscript/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+ALL_TARGET= bsd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/netscript ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/examples/netscript
+ (cd ${WRKSRC}/examples ; \
+ ${INSTALL_DATA} * ${PREFIX}/share/examples/netscript)
+
+.include <bsd.port.mk>
diff --git a/net/netscript/distinfo b/net/netscript/distinfo
new file mode 100644
index 000000000000..cbc00257266c
--- /dev/null
+++ b/net/netscript/distinfo
@@ -0,0 +1 @@
+MD5 (netscript-1.6.0.tgz) = 2376df4d995909b2205ab2f89ce67dbf
diff --git a/net/netscript/pkg-comment b/net/netscript/pkg-comment
new file mode 100644
index 000000000000..4271f8d5c299
--- /dev/null
+++ b/net/netscript/pkg-comment
@@ -0,0 +1 @@
+(portable/multi-platform) lightweight tcp socket scripting
diff --git a/net/netscript/pkg-descr b/net/netscript/pkg-descr
new file mode 100644
index 000000000000..663a7623386d
--- /dev/null
+++ b/net/netscript/pkg-descr
@@ -0,0 +1,13 @@
+ __ _ __
+ _ __ ___| /_ ___ ___ _ __(_)_ __ | /_ (portable/multi-platform) lightwei-
+| '_ \./ _ \ __/ __)/ __| '__| | '_ \| __) ght tcp socket scripting. intende-
+| | | | ._/ |_(__ \ (__| | | | |_) ) |_ d for (non-)experienced persons to
+|_| |_|\___|\__|___/\___|_| |_| .__/ \__) be able to use to automate situati-
+[TCP socket scripting program] |_| [1.6.0] ons, built on a word-to-word rules-
+ et response system. includes wild-
+card support, character replacement, random replacement, argument inclusion,
+server timeout, initial send, display altering, multiple character dump forma-
+ts, telnet protocol support, logging, program to socket dumping, executable
+ruleset support, reverse binding, and module support among other things.
+
+WWW: http://netscript.sourceforge.net/
diff --git a/net/netscript/pkg-plist b/net/netscript/pkg-plist
new file mode 100644
index 000000000000..7e2668d57754
--- /dev/null
+++ b/net/netscript/pkg-plist
@@ -0,0 +1,11 @@
+bin/netscript
+share/examples/netscript/README
+share/examples/netscript/binddump.ruleset
+share/examples/netscript/dictd.ruleset
+share/examples/netscript/ftpd.ruleset
+share/examples/netscript/httpd.ruleset
+share/examples/netscript/ircd.ruleset
+share/examples/netscript/pop3d.ruleset
+share/examples/netscript/smtpd.ruleset
+share/examples/netscript/telnetd.ruleset
+@dirrm share/examples/netscript