aboutsummaryrefslogtreecommitdiff
path: root/net/ng_mikrotik_eoip
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-15 04:44:10 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-15 04:44:10 +0000
commit3038d98e4e91ac85e69ab2f5dd40ebea38b41cbf (patch)
tree091fd3f1006750ca02570eaefed7af79fa33e2f6 /net/ng_mikrotik_eoip
parent3d4a17dce1e23a9f3ace2421094b8a1b123c9fd5 (diff)
downloadports-3038d98e4e91ac85e69ab2f5dd40ebea38b41cbf.tar.gz
ports-3038d98e4e91ac85e69ab2f5dd40ebea38b41cbf.zip
net/ng_mikrotik_eoip: Fix PTABLE option
Options helpers are ineffective when set after bsd.port.options.mk. Move them before that point. Reported by: tobik (in D19553)
Notes
Notes: svn path=/head/; revision=495762
Diffstat (limited to 'net/ng_mikrotik_eoip')
-rw-r--r--net/ng_mikrotik_eoip/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/ng_mikrotik_eoip/Makefile b/net/ng_mikrotik_eoip/Makefile
index 14a3025cc26f..24624cfa6a32 100644
--- a/net/ng_mikrotik_eoip/Makefile
+++ b/net/ng_mikrotik_eoip/Makefile
@@ -19,6 +19,8 @@ PTABLE_DESC= Use O(1) lookup for tunnel hooks
# which increases memory usage for each node by 65536*sizeof(hook_p). You probably want
# this option if you have many tunnels with single remote IP.
+PTABLE_MAKE_ARGS= NO_LINEAR_HOOK_LOOKUP=1
+
KMODDIR?= /boot/modules
PLIST_SUB+= KMODDIR=${KMODDIR} \
PORTNAME=${PORTNAME}
@@ -29,8 +31,6 @@ PLIST_SUB+= KMODDIR=${KMODDIR} \
IGNORE= requires kernel source files
.endif
-PTABLE_MAKE_ARGS= NO_LINEAR_HOOK_LOOKUP=1
-
do-install:
${MKDIR} "${STAGEDIR}${KMODDIR}"
${INSTALL_KLD} ${WRKSRC}/${PORTNAME}.ko "${STAGEDIR}${KMODDIR}"