aboutsummaryrefslogtreecommitdiff
path: root/net/ngrep
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-09-11 08:53:19 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-09-11 08:53:19 +0000
commitc96abf74df6f5fc7d89fb3eef6943a3d504591a0 (patch)
tree4be42cfc8a5cdffcce35b048a860f6cf40da4ffa /net/ngrep
parentbdf567e4f28e124e08715b44f99e8669ed382507 (diff)
downloadports-c96abf74df6f5fc7d89fb3eef6943a3d504591a0.tar.gz
ports-c96abf74df6f5fc7d89fb3eef6943a3d504591a0.zip
Notes
Diffstat (limited to 'net/ngrep')
-rw-r--r--net/ngrep/Makefile35
-rw-r--r--net/ngrep/distinfo4
2 files changed, 25 insertions, 14 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index 305ff6797129..6bb4ff555ef9 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -7,21 +7,24 @@
#
PORTNAME= ngrep
-PORTVERSION= 1.43
+PORTVERSION= 1.44
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= edwin@mavetju.org
COMMENT= Network grep
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-pcre \
- --disable-pcap-restart \
- --enable-dropprivs-onlyroot \
- --mandir=${PREFIX}/man/
-ALL_TARGET= ngrep
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
+ALL_TARGET= ngrep
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man/ --disable-pcap-restart
+
+OPTIONS= PCRE "Use PCRE instead of GNU regex" on \
+ PORTS_PCAP "Use ports PCAP instead of system PCAP" off \
+ IPV6 "Enable IPv6 support" on
MAN8= ngrep.8
PLIST_FILES= bin/ngrep
@@ -31,11 +34,19 @@ PORTDOCS= CHANGES.txt CREDITS.txt INSTALL.txt LICENSE.txt \
.include <bsd.port.pre.mk>
+.if defined(WITH_PCRE)
+CONFIGURE_ARGS+= --enable-pcre
+.endif
+
.if !defined(WITH_PORTS_PCAP)
-CONFIGURE_ARGS+=--with-pcap-includes=/usr/include
+CONFIGURE_ARGS+= --with-pcap-includes=/usr/include
.else
-CONFIGURE_ARGS+=--with-pcap-includes=${LOCALBASE}/include
-LIB_DEPENDS= pcap.2:${PORTSDIR}/net/libpcap
+CONFIGURE_ARGS+= --with-pcap-includes=${LOCALBASE}/include
+LIB_DEPENDS= pcap.2:${PORTSDIR}/net/libpcap
+.endif
+
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
.endif
post-install:
@@ -43,9 +54,9 @@ post-install:
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
@if [ -f ${WRKSRC}/${file} ]; then \
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}; \
else \
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}; \
fi
.endfor
.endif
diff --git a/net/ngrep/distinfo b/net/ngrep/distinfo
index 7ac902da4be0..78fd74a638af 100644
--- a/net/ngrep/distinfo
+++ b/net/ngrep/distinfo
@@ -1,2 +1,2 @@
-MD5 (ngrep-1.43.tar.bz2) = 835e7b52a45c55637f2435a79c7b570c
-SIZE (ngrep-1.43.tar.bz2) = 447819
+MD5 (ngrep-1.44-1.tar.bz2) = c8aed4d0fac077cc09524b3c7d623974
+SIZE (ngrep-1.44-1.tar.bz2) = 451130