aboutsummaryrefslogtreecommitdiff
path: root/net/nitroshare/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-04 08:33:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-04 08:33:16 +0000
commitaae5aa5ab6ac9bb55312eefa61ac9a6778fe037e (patch)
treeb4573c41d86bc3a31ca1959a914ad120e1164c5a /net/nitroshare/Makefile
parent42e2fa3e82d35676adc1da38cc347e94be5a06f0 (diff)
downloadports-aae5aa5ab6ac9bb55312eefa61ac9a6778fe037e.tar.gz
ports-aae5aa5ab6ac9bb55312eefa61ac9a6778fe037e.zip
Notes
Diffstat (limited to 'net/nitroshare/Makefile')
-rw-r--r--net/nitroshare/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/nitroshare/Makefile b/net/nitroshare/Makefile
new file mode 100644
index 000000000000..796e7a521cfa
--- /dev/null
+++ b/net/nitroshare/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= nitroshare
+DISTVERSION= 0.3.4-642
+DISTVERSIONSUFFIX= -g2046ccb
+CATEGORIES= net
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Network file transfer application
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libqhttpengine.so:www/qhttpengine \
+ libqmdnsengine.so:net/qmdnsengine
+
+USES= cmake:outsource qt:5
+USE_GITHUB= yes
+GH_PROJECT= ${PORTNAME}-desktop
+USE_QT= core gui network widgets buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>