aboutsummaryrefslogtreecommitdiff
path: root/net/ntopng
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-06-16 22:22:30 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-06-16 22:22:30 +0000
commit6d29e326c4d932aa8d8fd3d725bc9f086f1eb784 (patch)
tree990f6e67d6d6a348776f12970e1c5310ff887f09 /net/ntopng
parentb3f77acdb8f317d47b42ed1e89a24ff7e7d6b8d8 (diff)
downloadports-6d29e326c4d932aa8d8fd3d725bc9f086f1eb784.tar.gz
ports-6d29e326c4d932aa8d8fd3d725bc9f086f1eb784.zip
Fix script to use md5 and not md5sum.
PR: 243110 Submitted by: Tomoyuki Sakurai <trombik1973@gmail.com>
Notes
Notes: svn path=/head/; revision=539383
Diffstat (limited to 'net/ntopng')
-rw-r--r--net/ntopng/Makefile1
-rw-r--r--net/ntopng/files/patch-httpdocs_misc_ntopng-add-user.sh18
2 files changed, 19 insertions, 0 deletions
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index ca3386b9fd10..5197725609af 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ntopng
PORTVERSION= 4.0.d20200615
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
diff --git a/net/ntopng/files/patch-httpdocs_misc_ntopng-add-user.sh b/net/ntopng/files/patch-httpdocs_misc_ntopng-add-user.sh
new file mode 100644
index 000000000000..6d63cf1fe211
--- /dev/null
+++ b/net/ntopng/files/patch-httpdocs_misc_ntopng-add-user.sh
@@ -0,0 +1,18 @@
+--- httpdocs/misc/ntopng-add-user.sh.orig 2020-06-15 13:08:57 UTC
++++ httpdocs/misc/ntopng-add-user.sh
+@@ -111,13 +111,13 @@ function validate_username {
+
+ function password_md5 {
+ #make sure the md5 utility works as expected
+- local admin_md5=`echo -n admin | md5sum | cut -c 1-32`
++ local admin_md5=`echo -n admin | md5 | cut -c 1-32`
+ if [[ $admin_md5 != "21232f297a57a5a743894a0e4a801fc3" ]]
+ then
+ echo "md5sum not working as expected"
+ return 1
+ fi
+- NTOPNG_PASSWORD_MD5=`echo -n $NTOPNG_PASSWORD | md5sum | cut -c 1-32`
++ NTOPNG_PASSWORD_MD5=`echo -n $NTOPNG_PASSWORD | md5 | cut -c 1-32`
+ return 0
+ }
+