aboutsummaryrefslogtreecommitdiff
path: root/net/ntopng
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-08-22 12:55:15 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-08-22 12:55:15 +0000
commit7ab256a73e5910613400a16284cf4d97408b414e (patch)
treea61e1c192e03d700b650ffd0c39c8b6f5198ec02 /net/ntopng
parent189e7976d8e1c57b7d60608f6e26d4e5dfbd3426 (diff)
downloadports-7ab256a73e5910613400a16284cf4d97408b414e.tar.gz
ports-7ab256a73e5910613400a16284cf4d97408b414e.zip
- Update to newer upstream snapshot
- Silence portlint warning about variable ordering
Notes
Notes: svn path=/head/; revision=448518
Diffstat (limited to 'net/ntopng')
-rw-r--r--net/ntopng/Makefile8
-rw-r--r--net/ntopng/distinfo6
-rw-r--r--net/ntopng/files/patch-Makefile.in32
3 files changed, 9 insertions, 37 deletions
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index 6d6874885764..c428e9759e98 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ntopng
-PORTVERSION= 3.0.2017.06.05
+PORTVERSION= 3.0.2017.08.12
CATEGORIES= net
MAINTAINER= madpilot@FreeBSD.org
@@ -20,19 +20,19 @@ LIB_DEPENDS= librrd.so:databases/rrdtool \
libsodium.so:security/libsodium
BUILD_DEPENDS= bash:shells/bash
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
USES= autoreconf cpe gmake libtool localbase mysql pathfix pkgconfig \
shebangfix sqlite ssl
SUB_FILES= ntopng-geoipupdate.sh pkg-deinstall
SHEBANG_FILES= httpdocs/misc/ntopng-add-user.sh
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
USERS= ntopng
GROUPS= ntopng
USE_GITHUB= yes
GH_ACCOUNT= ntop
-GH_TAGNAME= 3de9516
+GH_TAGNAME= 8e2a743
CPE_VENDOR= ntop
diff --git a/net/ntopng/distinfo b/net/ntopng/distinfo
index 184b7e69a300..c6daef2fbb7b 100644
--- a/net/ntopng/distinfo
+++ b/net/ntopng/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496678053
-SHA256 (ntop-ntopng-3.0.2017.06.05-3de9516_GH0.tar.gz) = 48f5bb14f1d82c5dc8a220e7e4d7e2f5fec2accf6fd8efa65af98654072c016f
-SIZE (ntop-ntopng-3.0.2017.06.05-3de9516_GH0.tar.gz) = 23019840
+TIMESTAMP = 1503329023
+SHA256 (ntop-ntopng-3.0.2017.08.12-8e2a743_GH0.tar.gz) = 3adf3f00eb94da7981831d03ee9ba554caf6315e5cbd9bbb25cff590db2dac17
+SIZE (ntop-ntopng-3.0.2017.08.12-8e2a743_GH0.tar.gz) = 23022290
diff --git a/net/ntopng/files/patch-Makefile.in b/net/ntopng/files/patch-Makefile.in
index c4bddeb155fe..9819175dea33 100644
--- a/net/ntopng/files/patch-Makefile.in
+++ b/net/ntopng/files/patch-Makefile.in
@@ -1,19 +1,6 @@
---- Makefile.in.orig 2017-06-01 07:18:57 UTC
+--- Makefile.in.orig 2017-08-12 15:15:33 UTC
+++ Makefile.in
-@@ -51,8 +51,10 @@ else
- endif
- ######
- ifeq ($(OS), $(filter $(OS), FreeBSD))
-- LIBNBPF_HOME=${PWD}/../PF_RING/userland/nbpf
-- LIBNBPF_LIB=$(LIBNBPF_HOME)/libnbpf.a
-+ ifneq (, $(wildcard "${PWD}/../PF_RING/userland/nbpf/libnbpf.a"))
-+ LIBNBPF_HOME=${PWD}/../PF_RING/userland/nbpf
-+ LIBNBPF_LIB=$(LIBNBPF_HOME)/libnbpf.a
-+ endif
- endif
- ######
- HTTPCLIENT_INC=${PWD}/third-party/http-client-c/src/
-@@ -79,7 +81,7 @@ endif
+@@ -89,7 +89,7 @@ endif
HAS_ZEROMQ=$(shell pkg-config --exists libzmq; echo $$?)
ifeq ($(HAS_ZEROMQ), 0)
ZEROMQ_INC = $(shell pkg-config --cflags libzmq)
@@ -22,18 +9,3 @@
ifeq ($(wildcard $(ZMQ_STATIC)),)
ZEROMQ_LIB = $(shell pkg-config --libs libzmq)
else
-@@ -178,10 +180,10 @@ geoip:
- cp ~/dat_files/* httpdocs/geoip; gunzip -f httpdocs/geoip/*.dat.gz ; \
- else \
- cd httpdocs/geoip; \
-- wget -nc http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz; \
-- wget -nc http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz; \
-- wget -nc http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz; \
-- wget -nc http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz; \
-+ fetch http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz; \
-+ fetch http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz; \
-+ fetch http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz; \
-+ fetch http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz; \
- gunzip -f *.dat.gz ; \
- fi
-