aboutsummaryrefslogtreecommitdiff
path: root/net/ntp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2017-03-23 05:51:59 +0000
committerCy Schubert <cy@FreeBSD.org>2017-03-23 05:51:59 +0000
commit34d196cb529008a75cd10eedac165a5974bf5e89 (patch)
tree13a4bd294c0e8b42b99c3940bb48d6ac6a38a3fa /net/ntp
parent04f1110d2b9aad6d81e2559cd1dee5aef387123e (diff)
downloadports-34d196cb529008a75cd10eedac165a5974bf5e89.tar.gz
ports-34d196cb529008a75cd10eedac165a5974bf5e89.zip
Update 4.2.8p9 --> 4.2.8p10
Notes
Notes: svn path=/head/; revision=436756
Diffstat (limited to 'net/ntp')
-rw-r--r--net/ntp/Makefile3
-rw-r--r--net/ntp/distinfo6
-rw-r--r--net/ntp/files/patch-libntp_libssl__compat.c12
-rw-r--r--net/ntp/files/patch-ntpd__refclock__mx4200.c31
4 files changed, 27 insertions, 25 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index ea937f01e311..5f58ed417d5a 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ntp
-PORTVERSION= 4.2.8p9
-PORTREVISION= 4
+PORTVERSION= 4.2.8p10
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
diff --git a/net/ntp/distinfo b/net/ntp/distinfo
index bb7df1ca3bde..996c5d9922fc 100644
--- a/net/ntp/distinfo
+++ b/net/ntp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479794099
-SHA256 (ntp-4.2.8p9.tar.gz) = b724287778e1bac625b447327c9851eedef020517a3545625e9f652a90f30b72
-SIZE (ntp-4.2.8p9.tar.gz) = 7231884
+TIMESTAMP = 1490246780
+SHA256 (ntp-4.2.8p10.tar.gz) = ddd2366e64219b9efa0f7438e06800d0db394ac5c88e13c17b70d0dcdf99b99f
+SIZE (ntp-4.2.8p10.tar.gz) = 6998648
diff --git a/net/ntp/files/patch-libntp_libssl__compat.c b/net/ntp/files/patch-libntp_libssl__compat.c
index 14117da9c86e..8809f7433112 100644
--- a/net/ntp/files/patch-libntp_libssl__compat.c
+++ b/net/ntp/files/patch-libntp_libssl__compat.c
@@ -1,11 +1,11 @@
---- libntp/libssl_compat.c.orig 2016-11-21 12:28:40 UTC
-+++ libntp/libssl_compat.c
-@@ -23,7 +23,7 @@
- #include "ntp_types.h"
+--- libntp/libssl_compat.c.orig 2017-02-01 01:47:13.000000000 -0800
++++ libntp/libssl_compat.c 2017-03-22 22:29:56.409257000 -0700
+@@ -26,7 +26,7 @@
+ /* ----------------------------------------------------------------- */
/* ----------------------------------------------------------------- */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+-#if defined(OPENSSL) && OPENSSL_VERSION_NUMBER < 0x10100000L
++#if defined(OPENSSL) && (OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER))
/* ----------------------------------------------------------------- */
#include "libssl_compat.h"
diff --git a/net/ntp/files/patch-ntpd__refclock__mx4200.c b/net/ntp/files/patch-ntpd__refclock__mx4200.c
index f0181520b7c3..6a809f3ad19f 100644
--- a/net/ntp/files/patch-ntpd__refclock__mx4200.c
+++ b/net/ntp/files/patch-ntpd__refclock__mx4200.c
@@ -1,6 +1,6 @@
---- ntpd/refclock_mx4200.c.orig 2014-12-19 11:56:52 UTC
-+++ ntpd/refclock_mx4200.c
-@@ -1572,7 +1572,7 @@ mx4200_debug(struct peer *peer, char *fm
+--- ntpd/refclock_mx4200.c.orig 2017-03-21 06:04:19.000000000 -0700
++++ ntpd/refclock_mx4200.c 2017-03-22 22:34:58.631582000 -0700
+@@ -1572,7 +1572,7 @@
* Print debug message to stdout
* In the future, we may want to get get more creative...
*/
@@ -9,17 +9,20 @@
va_end(ap);
}
-@@ -1613,11 +1613,11 @@ mx4200_send(peer, fmt, va_alist)
+@@ -1614,14 +1614,14 @@
+ #else
+ va_start(ap);
+ #endif /* __STDC__ */
+- n = VSNPRINTF((cp, (size_t)(ep - cp), fmt, ap));
++ n = vsnprintf(cp, (size_t)(ep - cp), fmt, ap);
+ va_end(ap);
+ if (n < 0 || (size_t)n >= (size_t)(ep - cp))
+ goto overflow;
- cp = buf;
- *cp++ = '$';
-- n = VSNPRINTF((cp, sizeof(buf) - 1, fmt, ap));
-+ n = vsnprintf(cp, sizeof(buf) - 1, fmt, ap);
ck = mx4200_cksum(cp, n);
+ cp += n;
+- n = SNPRINTF((cp, (size_t)(ep - cp), "*%02X\r\n", ck));
++ n = snprintf(cp, (size_t)(ep - cp), "*%02X\r\n", ck);
+ if (n < 0 || (size_t)n >= (size_t)(ep - cp))
+ goto overflow;
cp += n;
- ++n;
-- n += SNPRINTF((cp, sizeof(buf) - n - 5, "*%02X\r\n", ck));
-+ n += snprintf(cp, sizeof(buf) - n - 5, "*%02X\r\n", ck);
-
- m = write(pp->io.fd, buf, (unsigned)n);
- if (m < 0)