aboutsummaryrefslogtreecommitdiff
path: root/net/ntp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2018-02-02 06:55:52 +0000
committerCy Schubert <cy@FreeBSD.org>2018-02-02 06:55:52 +0000
commitc37e5bb06c569f208bd725b3e03586a4a1ee3448 (patch)
tree4615d96f42cc4089582b707e7b2ea23cbb6cbeca /net/ntp
parent8b382593504de04fb93d7bf8a7be7a879fc63149 (diff)
Notes
Diffstat (limited to 'net/ntp')
-rw-r--r--net/ntp/Makefile2
-rw-r--r--net/ntp/files/patch-ntpd__refclock__ripencc.c38
2 files changed, 39 insertions, 1 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 3167032e1c9f..49e300fe3f81 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8p10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
diff --git a/net/ntp/files/patch-ntpd__refclock__ripencc.c b/net/ntp/files/patch-ntpd__refclock__ripencc.c
new file mode 100644
index 000000000000..d6f134dfd89f
--- /dev/null
+++ b/net/ntp/files/patch-ntpd__refclock__ripencc.c
@@ -0,0 +1,38 @@
+--- ntpd/refclock_ripencc.c.orig 2014-12-18 18:42:01.000000000 -0800
++++ ntpd/refclock_ripencc.c 2017-11-23 19:41:57.473988000 -0800
+@@ -1517,7 +1517,7 @@
+
+ record_clock_stats(&peer->srcadr, logbuf);
+
+- if (!utcflags & UTCF_UTC_AVAIL)
++ if (!(utcflags & UTCF_UTC_AVAIL))
+ return(-1);
+
+ /* poll for UTC parameters once and then if UTC flag changed */
+@@ -3442,7 +3442,7 @@
+ status1, status2;
+ const char
+ *text;
+- static const char const
++ static const char
+ *sc_text[] = {
+ "Doing position fixes",
+ "Don't have GPS time yet",
+@@ -4442,8 +4442,6 @@
+ known = TRUE;
+ }
+ if (known == FALSE) pbuf += sprintf(pbuf, "No known");
+- reserved = reserved;
+-
+ }
+
+ /* 0x8F */
+@@ -5059,7 +5057,7 @@
+ {
+ for (i=0; i<8; i++)
+ {
+- if (Flags&(1<<i)) pbuf += sprintf(pbuf, LeapStatusText[i]);
++ if (Flags&(1<<i)) pbuf += sprintf(pbuf, " %s", LeapStatusText[i]);
+ }
+ }
+ else