aboutsummaryrefslogtreecommitdiff
path: root/net/ntpa
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2018-11-24 03:56:19 +0000
committerBen Woods <woodsb02@FreeBSD.org>2018-11-24 03:56:19 +0000
commitf73023b7d82a12c386309181c83fba1c2ec880f8 (patch)
tree6b62b73b209c2c2cae46fe9e1e03e3993d3d3829 /net/ntpa
parent4d5a2b1df4b941b4d1af33553e6c24e954aa4ddb (diff)
downloadports-f73023b7d82a12c386309181c83fba1c2ec880f8.tar.gz
ports-f73023b7d82a12c386309181c83fba1c2ec880f8.zip
net/ntpa: Use .conf suffix for /usr/local/etc/newsyslog.conf.d/
- Rename the files installed to /usr/local/etc/newsyslog.conf.d/ to end with a '.conf' suffix. - Add pkg-install script to automatically move any copies of the old newsyslog file to the new location if it was modified from the default or delete the old file if it is has not been modified. - Add a note to UPDATING and pkg-message to warn users of this, in case they are using provisioning/configuration management tools which need to be modified. Note the UPDATING entry was committed in r485721. Recent changes to /etc/newsyslog.conf (r340318) will only include files from the /usr/local/etc/newsyslog.conf.d/ directory which end with '.conf' and do not beginning with a '.' character. Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=485725
Diffstat (limited to 'net/ntpa')
-rw-r--r--net/ntpa/Makefile2
-rw-r--r--net/ntpa/pkg-install28
-rw-r--r--net/ntpa/pkg-message16
-rw-r--r--net/ntpa/pkg-plist2
4 files changed, 46 insertions, 2 deletions
diff --git a/net/ntpa/Makefile b/net/ntpa/Makefile
index 911850be1903..ad2412b1b8f0 100644
--- a/net/ntpa/Makefile
+++ b/net/ntpa/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntpa
PORTVERSION= 0.8.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://dist1.innolan.net/ \
http://dist2.innolan.net/
diff --git a/net/ntpa/pkg-install b/net/ntpa/pkg-install
new file mode 100644
index 000000000000..46bb91b84f1d
--- /dev/null
+++ b/net/ntpa/pkg-install
@@ -0,0 +1,28 @@
+#! /bin/sh
+# ex:sw=4 sts=4
+
+move_newsyslog_conf() {
+ oldfile=${PKG_PREFIX}/etc/newsyslog.conf.d/ntpa
+ newfile=${PKG_PREFIX}/etc/newsyslog.conf.d/ntpa.conf
+ samplefile=${PKG_PREFIX}/etc/ntpa/ntpa.newsyslog
+ if [ -f ${oldfile} ]; then
+ echo "Configuration file found in old location: ${oldfile}"
+ if cmp -s ${samplefile} ${newfile} > /dev/null; then
+ echo "Configuration file in new location has not been modified from the default: ${newfile}"
+ echo " => Moving old configuration file to new location"
+ mv -f ${oldfile} ${newfile}
+ else
+ echo "Configuration file in new location has been modified from the default: ${newfile}"
+ echo " => Deleting old configuration file"
+ rm ${oldfile}
+ fi
+ fi
+}
+
+########################################################################
+
+case $2 in
+ POST-INSTALL)
+ move_newsyslog_conf
+ ;;
+esac
diff --git a/net/ntpa/pkg-message b/net/ntpa/pkg-message
index f3043bd74204..026c083f2264 100644
--- a/net/ntpa/pkg-message
+++ b/net/ntpa/pkg-message
@@ -7,3 +7,19 @@ If you are upgrading from a previous version of NTP Analyzer be sure to
take a backup of your database before starting ntpa in upgrade mode.
************************************************************************
+
+The ntpa newsyslog.conf(5) filename has been changed:
+ OLD: ${PREFIX}/etc/newsyslog.conf.d/ntpa
+ NEW: ${PREFIX}/etc/newsyslog.conf.d/ntpa.conf
+
+Any file found at the old location has been automatically moved to
+the new location. This was done to ensure log rotation continued to
+work after change r340318 made to FreeBSD base, where the default
+newsyslog configuration now only includes filenames that end with
+'.conf' and do not begin with '.'.
+
+If you use provisioning/configuration management tools to create or
+edit this file, you will need to change their configuration to use
+the new filename.
+
+************************************************************************
diff --git a/net/ntpa/pkg-plist b/net/ntpa/pkg-plist
index 3cd7ad37c88c..7d463eceec62 100644
--- a/net/ntpa/pkg-plist
+++ b/net/ntpa/pkg-plist
@@ -23,7 +23,7 @@ man/man1/ntpa.1.gz
%%DOCSDIR%%/DATABASE
%%DOCSDIR%%/INSTALL
@dir etc/newsyslog.conf.d
-@sample %%ETCDIR%%/ntpa.newsyslog etc/newsyslog.conf.d/ntpa
+@sample %%ETCDIR%%/ntpa.newsyslog etc/newsyslog.conf.d/ntpa.conf
@sample(,ntpa,640) %%ETCDIR%%/ntpa.conf.sample
@owner www
@group www