aboutsummaryrefslogtreecommitdiff
path: root/net/nusoap
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-09-17 01:37:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-09-17 01:37:28 +0000
commitecd7a9f091dd6e85e30eb524678c530b8561ebc2 (patch)
treecc0c529a7a2a5f3d84f214bfbcab0869095be86c /net/nusoap
parent957d2a35c5aeeed0753029d33cca52def8a3656a (diff)
downloadports-ecd7a9f091dd6e85e30eb524678c530b8561ebc2.tar.gz
ports-ecd7a9f091dd6e85e30eb524678c530b8561ebc2.zip
NuSOAP is a rewrite of SOAPx4, provided by NuSphere and Dietrich
Ayala. It is a set of PHP classes - no PHP extensions required - that allow developers to create and consume web services based on SOAP 1.1, WSDL 1.1 and HTTP 1.0/1.1. WWW: http://sourceforge.net/projects/nusoap/ PR: ports/116174 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=199582
Diffstat (limited to 'net/nusoap')
-rw-r--r--net/nusoap/Makefile30
-rw-r--r--net/nusoap/distinfo3
-rw-r--r--net/nusoap/pkg-descr6
-rw-r--r--net/nusoap/pkg-plist40
4 files changed, 79 insertions, 0 deletions
diff --git a/net/nusoap/Makefile b/net/nusoap/Makefile
new file mode 100644
index 000000000000..d65a7d265633
--- /dev/null
+++ b/net/nusoap/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: nusoap
+# Date created: 2007-09-07
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nusoap
+PORTVERSION= 0.7.2
+CATEGORIES= net www
+MASTER_SITES= SOURCEFORGE
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= SOAP Toolkit for PHP
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PHP= curl zlib
+USE_ZIP= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} ${WRKSRC}/lib/* ${DATADIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/samples/* ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>
diff --git a/net/nusoap/distinfo b/net/nusoap/distinfo
new file mode 100644
index 000000000000..8be7474139b3
--- /dev/null
+++ b/net/nusoap/distinfo
@@ -0,0 +1,3 @@
+MD5 (nusoap-0.7.2.zip) = 2b01503796b351e0c1a794f3ab9bea28
+SHA256 (nusoap-0.7.2.zip) = 8b5c541c1583217d633cef63b85aec9eced05c16a1a68a0cda00b1a8a561ffcc
+SIZE (nusoap-0.7.2.zip) = 159735
diff --git a/net/nusoap/pkg-descr b/net/nusoap/pkg-descr
new file mode 100644
index 000000000000..d907ac8aafd7
--- /dev/null
+++ b/net/nusoap/pkg-descr
@@ -0,0 +1,6 @@
+NuSOAP is a rewrite of SOAPx4, provided by NuSphere and Dietrich
+Ayala. It is a set of PHP classes - no PHP extensions required - that
+allow developers to create and consume web services based on SOAP 1.1,
+WSDL 1.1 and HTTP 1.0/1.1.
+
+WWW: http://sourceforge.net/projects/nusoap/
diff --git a/net/nusoap/pkg-plist b/net/nusoap/pkg-plist
new file mode 100644
index 000000000000..62f832a47069
--- /dev/null
+++ b/net/nusoap/pkg-plist
@@ -0,0 +1,40 @@
+@comment $FreeBSD$
+%%DATADIR%%/changelog
+%%DATADIR%%/class.nusoap_base.php
+%%DATADIR%%/class.soap_fault.php
+%%DATADIR%%/class.soap_parser.php
+%%DATADIR%%/class.soap_server.php
+%%DATADIR%%/class.soap_transport_http.php
+%%DATADIR%%/class.soap_val.php
+%%DATADIR%%/class.soapclient.php
+%%DATADIR%%/class.wsdl.php
+%%DATADIR%%/class.wsdlcache.php
+%%DATADIR%%/class.xmlschema.php
+%%DATADIR%%/nusoap.php
+%%DATADIR%%/nusoapmime.php
+%%EXAMPLESDIR%%/client1.php
+%%EXAMPLESDIR%%/client2.php
+%%EXAMPLESDIR%%/client3.php
+%%EXAMPLESDIR%%/getfile1client.php
+%%EXAMPLESDIR%%/getfile2client.php
+%%EXAMPLESDIR%%/index.html
+%%EXAMPLESDIR%%/mimeclient.php
+%%EXAMPLESDIR%%/sslclient.php
+%%EXAMPLESDIR%%/wsdlclient1.php
+%%EXAMPLESDIR%%/wsdlclient10.php
+%%EXAMPLESDIR%%/wsdlclient11.php
+%%EXAMPLESDIR%%/wsdlclient12.php
+%%EXAMPLESDIR%%/wsdlclient13.php
+%%EXAMPLESDIR%%/wsdlclient14.php
+%%EXAMPLESDIR%%/wsdlclient2.php
+%%EXAMPLESDIR%%/wsdlclient3.php
+%%EXAMPLESDIR%%/wsdlclient3b.php
+%%EXAMPLESDIR%%/wsdlclient3c.php
+%%EXAMPLESDIR%%/wsdlclient4.php
+%%EXAMPLESDIR%%/wsdlclient5.php
+%%EXAMPLESDIR%%/wsdlclient6.php
+%%EXAMPLESDIR%%/wsdlclient7.php
+%%EXAMPLESDIR%%/wsdlclient8.php
+%%EXAMPLESDIR%%/wsdlclient9.php
+@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry %%DATADIR%%