aboutsummaryrefslogtreecommitdiff
path: root/net/nxproxy
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2010-08-16 18:56:41 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2010-08-16 18:56:41 +0000
commitb342565b1f55612c95e59f8d4c96c7bf0e5f07b6 (patch)
treefaef5e68b93ea1b587f33feae73981bde9ee023f /net/nxproxy
parentbfa66c7d13e586dac7a555f3aa458040221596e4 (diff)
downloadports-b342565b1f55612c95e59f8d4c96c7bf0e5f07b6.tar.gz
ports-b342565b1f55612c95e59f8d4c96c7bf0e5f07b6.zip
Move setsid from x2goclient-cli to nxproxy in preperation for upcoming qt x2goclient
Notes
Notes: svn path=/head/; revision=259392
Diffstat (limited to 'net/nxproxy')
-rw-r--r--net/nxproxy/Makefile5
-rw-r--r--net/nxproxy/files/setsid.c7
2 files changed, 11 insertions, 1 deletions
diff --git a/net/nxproxy/Makefile b/net/nxproxy/Makefile
index 9119fef9f4ce..228ea27fd8da 100644
--- a/net/nxproxy/Makefile
+++ b/net/nxproxy/Makefile
@@ -6,6 +6,7 @@
PORTNAME= nxproxy
DISTVERSION= 3.4.0-2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://x2go.obviously-nice.de/deb/pool-lenny/nxproxy/:nxproxy \
http://x2go.obviously-nice.de/deb/pool-lenny/nxcomp/:nxcomp
@@ -23,7 +24,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS= nxserver-[0-9]*
GNU_CONFIGURE= yes
USE_XORG= ice x11 sm
-PLIST_FILES= bin/nxproxy
+PLIST_FILES= bin/nxproxy bin/setsid
.include <bsd.port.pre.mk>
@@ -44,8 +45,10 @@ pre-configure:
pre-build:
cd ${WRKDIR}/nxcomp; ${MAKE_ENV} ${MAKE}
+ cd ${WRKSRC}; ${CC} ${CFLAGS} ${FILESDIR}/setsid.c -o setsid
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nxproxy ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/setsid ${PREFIX}/bin
.include <bsd.port.post.mk>
diff --git a/net/nxproxy/files/setsid.c b/net/nxproxy/files/setsid.c
new file mode 100644
index 000000000000..09c711d0e638
--- /dev/null
+++ b/net/nxproxy/files/setsid.c
@@ -0,0 +1,7 @@
+#include <unistd.h>
+int main(int argc,char** argv)
+{
+ setsid();
+ execvp(argv[1], argv+1);
+ return 0;
+}