aboutsummaryrefslogtreecommitdiff
path: root/net/nyancat
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-03-30 10:00:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-03-30 10:00:34 +0000
commit4dc29b34c3bd8dbb77e85569736cd65a5762a223 (patch)
treeba62ca1184c2238c90233c8619673adf4a724c49 /net/nyancat
parentb7aca68c162b4d8a912159aa38750101474a1b7e (diff)
downloadports-4dc29b34c3bd8dbb77e85569736cd65a5762a223.tar.gz
ports-4dc29b34c3bd8dbb77e85569736cd65a5762a223.zip
Add net/nyancat, an animated, color, ANSI-text telnet server that renders a
loop of the classic nyan cat animation. Feature safe: yes
Notes
Notes: svn path=/head/; revision=293986
Diffstat (limited to 'net/nyancat')
-rw-r--r--net/nyancat/Makefile27
-rw-r--r--net/nyancat/distinfo2
-rw-r--r--net/nyancat/files/pkg-message.in12
-rw-r--r--net/nyancat/pkg-descr4
4 files changed, 45 insertions, 0 deletions
diff --git a/net/nyancat/Makefile b/net/nyancat/Makefile
new file mode 100644
index 000000000000..9f06e9b4f95f
--- /dev/null
+++ b/net/nyancat/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: nyancat
+# Date created: 30 Mar 2012
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nyancat
+PORTVERSION= 20120330
+CATEGORIES= net games
+MASTER_SITES= CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Animated telnet server that renders a loop of the nyan cat animation
+
+MAKE_JOBS_SAFE= yes
+
+SUB_FILES= pkg-message
+PLIST_FILES= bin/nyancat
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/nyancat/distinfo b/net/nyancat/distinfo
new file mode 100644
index 000000000000..62c78b607479
--- /dev/null
+++ b/net/nyancat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nyancat-20120330.tar.gz) = da2cef9f19699c4e2e6fe9b034c36ad4b0f2f3f9a774e9d017d3ff185264b0f1
+SIZE (nyancat-20120330.tar.gz) = 87006
diff --git a/net/nyancat/files/pkg-message.in b/net/nyancat/files/pkg-message.in
new file mode 100644
index 000000000000..46c12def4ee5
--- /dev/null
+++ b/net/nyancat/files/pkg-message.in
@@ -0,0 +1,12 @@
+================================================================================
+
+To setup a nyancat telnet server via inetd enable inetd in /etc/rc.conf:
+
+inetd_enable="YES"
+
+Add the following lines to /etc/inetd.conf:
+
+telnet stream tcp nowait nobody %%PREFIX%%/bin/nyancat nyancat -t
+telnet stream tcp6 nowait nobody %%PREFIX%%/bin/nyancat nyancat -t
+
+================================================================================
diff --git a/net/nyancat/pkg-descr b/net/nyancat/pkg-descr
new file mode 100644
index 000000000000..02f0a2ecbbf5
--- /dev/null
+++ b/net/nyancat/pkg-descr
@@ -0,0 +1,4 @@
+This is an animated, color, ANSI-text telnet server that renders a loop of the
+classic nyan cat animation.
+
+WWW: http://miku.acm.uiuc.edu/