aboutsummaryrefslogtreecommitdiff
path: root/net/nylon
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-12-07 12:59:29 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-12-07 12:59:29 +0000
commita3b395aa5dc5682b118f13948cd7ea14e3f62ea3 (patch)
treea52eaf58ebafe266a1dc675a56bf160e0783b3eb /net/nylon
parentfeadf43eb5863fd4245e1cf3057c40591a5208a3 (diff)
downloadports-a3b395aa5dc5682b118f13948cd7ea14e3f62ea3.tar.gz
ports-a3b395aa5dc5682b118f13948cd7ea14e3f62ea3.zip
- Link dynamically against libevent
- Cleanup USE_RC_SUBR-handling
Notes
Notes: svn path=/head/; revision=150586
Diffstat (limited to 'net/nylon')
-rw-r--r--net/nylon/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/net/nylon/Makefile b/net/nylon/Makefile
index f9eae74e2ae4..a25935d21ba7 100644
--- a/net/nylon/Makefile
+++ b/net/nylon/Makefile
@@ -15,11 +15,11 @@ MASTER_SITES= http://monkey.org/~marius/nylon/
MAINTAINER= ports@FreeBSD.org
COMMENT= A Unix SOCKS 4 and 5 proxy server
-BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1.1a.1:${PORTSDIR}/devel/libevent
-USE_RC_SUBR= yes
-RC_SCRIPTS_SUB=PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+USE_RC_SUBR= nylon.sh
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
# Necessary for $PREFIX to work:
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -27,14 +27,12 @@ CONFIGURE_ARGS= --with-libevent=${LOCALBASE}
MAN1= nylon.1
-PLIST_FILES= bin/nylon etc/nylon.conf.sample etc/rc.d/nylon.sh
+PLIST_FILES= bin/nylon etc/nylon.conf.sample
-post-extract:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/nylon.sh.in > ${WRKSRC}/nylon.sh
+post-patch:
+ ${REINPLACE_CMD} -e 's/-levent/-levent-1.1a/' ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${FILESDIR}/nylon.conf ${PREFIX}/etc/nylon.conf.sample
- ${INSTALL_SCRIPT} ${WRKSRC}/nylon.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>