aboutsummaryrefslogtreecommitdiff
path: root/net/nylon
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-23 07:57:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-23 07:57:30 +0000
commitb50fc8ce46909bbfac42712ec989019bb7628f11 (patch)
tree5d30269ad62fa02188525aed49c9b8c210d7809e /net/nylon
parent0e4d278613547b3ca1d1b5a8b83a05802a34ca85 (diff)
downloadports-b50fc8ce46909bbfac42712ec989019bb7628f11.tar.gz
ports-b50fc8ce46909bbfac42712ec989019bb7628f11.zip
upgrade to 1.0
PR: 44385 Submitted by: Volker Stolz <vs@foldr.org>
Notes
Notes: svn path=/head/; revision=68638
Diffstat (limited to 'net/nylon')
-rw-r--r--net/nylon/Makefile12
-rw-r--r--net/nylon/distinfo2
-rw-r--r--net/nylon/files/nylon.conf36
-rw-r--r--net/nylon/files/patch-cfg.c19
-rw-r--r--net/nylon/files/patch-err.c24
-rw-r--r--net/nylon/files/patch-src-Makefile.in11
-rw-r--r--net/nylon/pkg-descr2
7 files changed, 59 insertions, 47 deletions
diff --git a/net/nylon/Makefile b/net/nylon/Makefile
index c99ccedab4d4..89d7a2bf2a2f 100644
--- a/net/nylon/Makefile
+++ b/net/nylon/Makefile
@@ -7,14 +7,22 @@
#
PORTNAME= nylon
-PORTVERSION= 0.3
+PORTVERSION= 1.0
CATEGORIES= net
-MASTER_SITES= http://www.citi.umich.edu/u/marius/
+MASTER_SITES= http://monkey.org/~marius/nylon/
MAINTAINER= ports@FreeBSD.org
+BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+# Necessary for $PREFIX to work:
+CONFIGURE_ARGS= --with-libevent=${LOCALBASE}
MAN1= nylon.1
+post-install:
+ ${INSTALL_DATA} ${FILESDIR}/nylon.conf ${PREFIX}/etc
+
.include <bsd.port.mk>
diff --git a/net/nylon/distinfo b/net/nylon/distinfo
index 6396b808544a..c84ef88213ba 100644
--- a/net/nylon/distinfo
+++ b/net/nylon/distinfo
@@ -1 +1 @@
-MD5 (nylon-0.3.tar.gz) = a3900e11c7e56b4309197e0fb7681743
+MD5 (nylon-1.0.tar.gz) = 4457467ae589c70b37ccbce76851700d
diff --git a/net/nylon/files/nylon.conf b/net/nylon/files/nylon.conf
new file mode 100644
index 000000000000..2b509329d677
--- /dev/null
+++ b/net/nylon/files/nylon.conf
@@ -0,0 +1,36 @@
+# sample configuration # marius aamodt eriksen (marius@umich.edu)
+# $Id: nylon.conf,v 1.11 2002/03/27 07:39:53 beriksen Exp $
+# general settings
+[General]
+
+# number of simultaneous connections allowed
+No-Simultaneous-Conn=10
+
+# log connections and other information to syslog? 1: on, 0: off
+Log=1
+
+# be verbose on the console? 1: on, 0: off
+Verbose=0
+
+# store pid file
+#PIDfile=/var/run/nylon.pid
+
+# server settings
+[Server]
+
+# interface to listen to connections
+#Binding-Interface=fxp1
+
+# interface to bind outgoing connections to
+#Connecting-Interface=fxp0
+
+# listening port to bind to
+Port=1080
+
+# allowed is processed first, then deny
+
+# allowable connect ips/ranges
+#Allow-IP=141.0.0.0/8 127.0.0.1 10.0.0.0/24
+Allow-IP=127.0.0.1/32
+# denied connect ips/ranges
+#Deny-IP=10.0.0.0/24
diff --git a/net/nylon/files/patch-cfg.c b/net/nylon/files/patch-cfg.c
deleted file mode 100644
index 48eca8716c95..000000000000
--- a/net/nylon/files/patch-cfg.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- cfg.c.orig Fri Jul 12 11:30:59 2002
-+++ cfg.c Fri Jul 12 11:31:08 2002
-@@ -35,6 +35,8 @@
- * This code was written under funding by Ericsson Radio Systems.
- */
-
-+#include "cfg.h"
-+
- #ifndef WIN32
- #include <sys/param.h>
- #include <sys/mman.h>
-@@ -51,7 +53,6 @@
- #include <err.h>
-
- #include "config.h"
--#include "cfg.h"
-
- struct conf_trans {
- TAILQ_ENTRY (conf_trans) link;
diff --git a/net/nylon/files/patch-err.c b/net/nylon/files/patch-err.c
deleted file mode 100644
index 42d51bef3ccf..000000000000
--- a/net/nylon/files/patch-err.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- ../../work.orig/nylon-0.3/err.c Mon Oct 21 17:54:24 2002
-+++ err.c Mon Oct 21 17:56:03 2002
-@@ -16,7 +16,7 @@
-
- extern int verbose;
-
--char nylon_err[] = { "Error in receiving", /* ERROR_RECV */
-+char *nylon_err[] = { "Error in receiving", /* ERROR_RECV */
- "Error in sending", /* ERROR_SEND */
- "Error in header", /* ERROR_HEAD */
- "Error in address", /* ERROR_ADDR */
-@@ -55,10 +55,10 @@
- #else
- va_start(ap);
- #endif /* __STDC__ */
-- if (fmt && (level <= verbose) && errn < NERRS && errn >= 0) {
-+ if (fmt && (level <= verbose) && errn < NERRS && errn > 0) {
- fprintf(stderr, "nylon: [error] ");
- vfprintf(stderr, fmt, ap);
-- fprintf(stderr, "%s", nylon_err + errn);
-+ fprintf(stderr, "%s", nylon_err[errn - 1]);
- }
- va_end(ap);
- }
diff --git a/net/nylon/files/patch-src-Makefile.in b/net/nylon/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..67f4a4fb3cfb
--- /dev/null
+++ b/net/nylon/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Mon Oct 21 19:32:41 2002
++++ src/Makefile.in Mon Oct 21 19:33:00 2002
+@@ -92,7 +92,7 @@
+ socks4.c socks5.c mirror.c cleanup.c misc.c
+
+
+-CFLAGS = @EVENTINC@ -Wall -g $(AM_CFLAGS)
++CFLAGS += @EVENTINC@ -Wall -g $(AM_CFLAGS)
+ LDADD = @EVENTLIB@ @LIBOBJS@
+
+ EXTRA_DIST = strlcpy.c strlcat.c setproctitle.c strsep.c err.c daemon.c
diff --git a/net/nylon/pkg-descr b/net/nylon/pkg-descr
index a31118ff0d82..5db058a2ab63 100644
--- a/net/nylon/pkg-descr
+++ b/net/nylon/pkg-descr
@@ -1,4 +1,4 @@
nylon is a Unix SOCKS 4 and 5 proxy server. It is compatible with BSD,
Solaris, HP-UX and Linux 2.2 & 2.4.
-WWW: http://mesh.eecs.umich.edu/projects/nylon/
+WWW: http://monkey.org/~marius/nylon/