aboutsummaryrefslogtreecommitdiff
path: root/net/olsrd
diff options
context:
space:
mode:
authorJohn Hay <jhay@FreeBSD.org>2010-05-22 07:38:37 +0000
committerJohn Hay <jhay@FreeBSD.org>2010-05-22 07:38:37 +0000
commit55c91a264d94887e20c9f518744a423372bd7859 (patch)
tree1678c047225deed9b74a6baebbb9ffb7798326ae /net/olsrd
parent052da2fa7106927e9d564742c9eb30f51584e659 (diff)
downloadports-55c91a264d94887e20c9f518744a423372bd7859.tar.gz
ports-55c91a264d94887e20c9f518744a423372bd7859.zip
Upgrade to olsrd 0.6.0.
Notes
Notes: svn path=/head/; revision=254814
Diffstat (limited to 'net/olsrd')
-rw-r--r--net/olsrd/Makefile4
-rw-r--r--net/olsrd/distinfo6
-rw-r--r--net/olsrd/files/patch-Makefile19
-rw-r--r--net/olsrd/files/patch-mcast29
-rw-r--r--net/olsrd/pkg-plist9
5 files changed, 49 insertions, 18 deletions
diff --git a/net/olsrd/Makefile b/net/olsrd/Makefile
index 78456744ed84..fe02ee0fee40 100644
--- a/net/olsrd/Makefile
+++ b/net/olsrd/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= olsrd
-DISTVERSION= 0.5.6-r8
+DISTVERSION= 0.6.0
CATEGORIES= net
-MASTER_SITES= http://www.olsr.org/releases/0.5/ \
+MASTER_SITES= http://www.olsr.org/releases/0.6/ \
http://ftp2.za.freebsd.org/pub/mesh/pc/protocols/olsr/
MAINTAINER= jhay@freebsd.org
diff --git a/net/olsrd/distinfo b/net/olsrd/distinfo
index 9f99b6305831..ec69aa0a006a 100644
--- a/net/olsrd/distinfo
+++ b/net/olsrd/distinfo
@@ -1,3 +1,3 @@
-MD5 (olsrd-0.5.6-r8.tar.bz2) = aef6f4350c44fd0ad015a26621ef9607
-SHA256 (olsrd-0.5.6-r8.tar.bz2) = c6827b232f0849414ff18c2c1deb85697f1a1b600b7d7676553744ce6f1d7fa1
-SIZE (olsrd-0.5.6-r8.tar.bz2) = 765031
+MD5 (olsrd-0.6.0.tar.bz2) = 8425a10e315be5e061143ac310f2424b
+SHA256 (olsrd-0.6.0.tar.bz2) = 472b5a9ef763e689ccf43b831305330314d9912d13386bf4988123c362fe3e3c
+SIZE (olsrd-0.6.0.tar.bz2) = 600333
diff --git a/net/olsrd/files/patch-Makefile b/net/olsrd/files/patch-Makefile
index 688f69fb3eb8..554192a7e788 100644
--- a/net/olsrd/files/patch-Makefile
+++ b/net/olsrd/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2008-01-02 16:00:15.000000000 +0200
-+++ Makefile 2008-01-04 12:23:05.000000000 +0200
-@@ -102,15 +102,15 @@
+--- Makefile.orig 2010-05-13 12:52:55.000000000 +0200
++++ Makefile 2010-05-16 15:51:06.904944901 +0200
+@@ -109,15 +109,16 @@
install_olsrd: install_bin
@echo ========= C O N F I G U R A T I O N - F I L E ============
@echo $(EXENAME) uses the configfile $(CFGFILE)
@@ -10,16 +10,17 @@
- @echo so install a configfile with activated link quality exstensions
- @echo per default.
- @echo can be found at files/olsrd.conf.default.lq
-+ @echo a default configfile. Sample config files are
-+ @echo installed as $(CFGFILE).rfc, $(CFGFILE).lq and
-+ @echo $(CFGFILE).lq-fishey
++ @echo a default configfile. Sample config files are installed
++ @echo as $(CFGFILE).default.full, $(CFGFILE).default.rfc,
++ @echo $(CFGFILE).default.lq and $(CFGFILE).default.lq-fisheye
+ @echo copy and edit one of these to $(CFGFILE)
@echo ==========================================================
mkdir -p $(ETCDIR)
- -cp -i files/olsrd.conf.default.lq $(CFGFILE)
-+ -cp files/olsrd.conf.default.rfc $(CFGFILE).rfc
-+ -cp files/olsrd.conf.default.lq $(CFGFILE).lq
-+ -cp files/olsrd.conf.default.lq-fisheye $(CFGFILE).lq-fisheye
++ -cp files/olsrd.conf.default.full $(CFGFILE).default.full
++ -cp files/olsrd.conf.default.rfc $(CFGFILE).default.rfc
++ -cp files/olsrd.conf.default.lq $(CFGFILE).default.lq
++ -cp files/olsrd.conf.default.lq-fisheye $(CFGFILE).default.lq-fisheye
@echo -------------------------------------------
@echo Edit $(CFGFILE) before running olsrd!!
@echo -------------------------------------------
diff --git a/net/olsrd/files/patch-mcast b/net/olsrd/files/patch-mcast
new file mode 100644
index 000000000000..cf26201e75b0
--- /dev/null
+++ b/net/olsrd/files/patch-mcast
@@ -0,0 +1,29 @@
+--- src/bsd/net.c.orig 2010-01-13 16:49:47.000000000 +0000
++++ src/bsd/net.c 2010-02-10 10:55:16.582716012 +0000
+@@ -494,6 +494,8 @@
+ mcastreq.ipv6mr_multiaddr = ifs->int6_multaddr.sin6_addr;
+ mcastreq.ipv6mr_interface = ifs->if_index;
+
++if (ifs->olsr_socket == sock) {
++
+ OLSR_PRINTF(3, "Interface %s joining multicast %s...", ifs->int_name,
+ olsr_ip_to_string(&addrstr, (union olsr_ip_addr *)&ifs->int6_multaddr.sin6_addr));
+
+@@ -509,6 +511,7 @@
+ perror("Join multicast send");
+ return -1;
+ }
++}
+
+ if (setsockopt(sock, IPPROTO_IPV6, IPV6_MULTICAST_IF, (char *)&mcastreq.ipv6mr_interface, sizeof(mcastreq.ipv6mr_interface)) < 0) {
+ perror("Set multicast if");
+--- src/unix/ifnet.c.orig 2010-01-17 17:32:53.000000000 +0000
++++ src/unix/ifnet.c 2010-02-10 10:55:54.958215804 +0000
+@@ -840,6 +840,7 @@
+ ifp->send_socket = getsocket6(0, ifp);
+
+ join_mcast(ifp, ifp->olsr_socket);
++ join_mcast(ifp, ifp->send_socket);
+
+ if (ifp->olsr_socket < 0) {
+ fprintf(stderr, "Could not initialize socket... exiting!\n\n");
diff --git a/net/olsrd/pkg-plist b/net/olsrd/pkg-plist
index 4665e833c283..fedff99c2cf3 100644
--- a/net/olsrd/pkg-plist
+++ b/net/olsrd/pkg-plist
@@ -1,9 +1,10 @@
sbin/olsrd
-etc/olsrd.conf.rfc
-etc/olsrd.conf.lq
-etc/olsrd.conf.lq-fisheye
+etc/olsrd.conf.default.full
+etc/olsrd.conf.default.rfc
+etc/olsrd.conf.default.lq
+etc/olsrd.conf.default.lq-fisheye
lib/olsrd_dot_draw.so.0.3
-lib/olsrd_dyn_gw.so.0.4
+lib/olsrd_dyn_gw.so.0.5
lib/olsrd_dyn_gw_plain.so.0.4
lib/olsrd_httpinfo.so.0.1
lib/olsrd_mini.so.0.1