aboutsummaryrefslogtreecommitdiff
path: root/net/omnitty
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 13:59:08 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 13:59:08 +0000
commit2e3643f5421f0204ea913ce3bdb99a234d648b2e (patch)
tree39ecce3915017693485fa8a0fe24aeb50bf1485c /net/omnitty
parent5719efe0d328957d28abbdc17253927b70290813 (diff)
downloadports-2e3643f5421f0204ea913ce3bdb99a234d648b2e.tar.gz
ports-2e3643f5421f0204ea913ce3bdb99a234d648b2e.zip
- Support staging
- USES -> gmake - New LIB_DEPENDS definition
Notes
Notes: svn path=/head/; revision=348234
Diffstat (limited to 'net/omnitty')
-rw-r--r--net/omnitty/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/net/omnitty/Makefile b/net/omnitty/Makefile
index 7908cc8f43cb..4e0d74d050dd 100644
--- a/net/omnitty/Makefile
+++ b/net/omnitty/Makefile
@@ -10,24 +10,21 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= rafan@FreeBSD.org
COMMENT= A curses-based SSH multiplexer
-LIB_DEPENDS= rote:${PORTSDIR}/devel/rote
+LIB_DEPENDS= librote.so:${PORTSDIR}/devel/rote
+USES= gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
ALL_TARGET= ${PORTNAME}
-MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/omnitty man/man1/omnitty.1.gz
-PLIST_FILES= bin/${PORTNAME}
-
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} 's|<alloca.h>|<stdlib.h>|' \
${WRKSRC}/machmgr.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>