aboutsummaryrefslogtreecommitdiff
path: root/net/omnitty
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-01 22:15:21 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-01 22:15:21 +0000
commitfdf8800df4e81b1d6b77a1fc3e4a7329efaf167f (patch)
tree67d9cc9cceae2cb39d738420d1dccdce1962ea92 /net/omnitty
parente83fce0aab3d324ce7e35a57a452470666a85504 (diff)
downloadports-fdf8800df4e81b1d6b77a1fc3e4a7329efaf167f.tar.gz
ports-fdf8800df4e81b1d6b77a1fc3e4a7329efaf167f.zip
net/omnitty: Allow greater than 32-character hostnames
PR: 197601 Submitted by: David (catwhisker.org)
Notes
Notes: svn path=/head/; revision=380230
Diffstat (limited to 'net/omnitty')
-rw-r--r--net/omnitty/Makefile14
-rw-r--r--net/omnitty/files/patch-main.c21
2 files changed, 27 insertions, 8 deletions
diff --git a/net/omnitty/Makefile b/net/omnitty/Makefile
index 6bc3aa7cfc30..99ba2c5f86e7 100644
--- a/net/omnitty/Makefile
+++ b/net/omnitty/Makefile
@@ -3,9 +3,9 @@
PORTNAME= omnitty
PORTVERSION= 0.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/omnitty/omnitty/omnitty-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses-based SSH multiplexer
@@ -16,16 +16,14 @@ USES= gmake
GNU_CONFIGURE= yes
LIBS+= -lncurses
-ALL_TARGET= ${PORTNAME}
-
+ALL_TARGET= omnitty
PLIST_FILES= bin/omnitty man/man1/omnitty.1.gz
post-patch:
- ${REINPLACE_CMD} 's|<alloca.h>|<stdlib.h>|' \
- ${WRKSRC}/machmgr.c
+ ${REINPLACE_CMD} 's|<alloca.h>|<stdlib.h>|' ${WRKSRC}/machmgr.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/omnitty ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/omnitty.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/net/omnitty/files/patch-main.c b/net/omnitty/files/patch-main.c
index 5505e23d4ad6..eb93bfa2ccb7 100644
--- a/net/omnitty/files/patch-main.c
+++ b/net/omnitty/files/patch-main.c
@@ -1,5 +1,13 @@
--- main.c.orig 2005-10-26 06:08:25.000000000 +0800
+++ main.c 2011-04-22 23:14:33.000000000 +0800
+@@ -36,6 +36,7 @@
+ /* minimum terminal dimensions to run program */
+ #define MIN_REQUIRED_WIDTH 80
+ #define MIN_REQUIRED_HEIGHT 25
++#define MAX_HOSTNAME_LENGTH 64
+
+ #define REMINDER_LINE "OmNiTTY-R v" OMNITTY_VERSION \
+ " \007F1\007:menu \006F2/3\007:sel \003F4\007:tag" \
@@ -88,6 +88,12 @@
define_key("\e[15~", KEY_F(5)); define_key("\e[17~", KEY_F(6));
define_key("\e[18~", KEY_F(7)); define_key("\e[19~", KEY_F(8));
@@ -13,6 +21,19 @@
getmaxyx(stdscr, h, w);
if (h < MIN_REQUIRED_HEIGHT || w < MIN_REQUIRED_WIDTH) {
+@@ -288,10 +289,10 @@
+ }
+
+ static void add_machine() {
+- static char buf[32];
++ static char buf[MAX_HOSTNAME_LENGTH];
+
+ *buf = 0;
+- if (minibuf_prompt(minibuf, "Add: ", 0xE0, buf, 32)) {
++ if (minibuf_prompt(minibuf, "Add: ", 0xE0, buf, sizeof(buf))) {
+ if (*buf == '@') add_machines_from_file(buf+1);
+ else machmgr_add(buf);
+ }
@@ -335,9 +341,10 @@
while (!quit) {