aboutsummaryrefslogtreecommitdiff
path: root/net/opal3
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-05-26 10:12:14 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-05-26 10:12:14 +0000
commit1af872aa6b5b81dfe630746041737e3d9eb9d2ba (patch)
tree2cdbdb3058c875791ea733b523c224e0f6c226f3 /net/opal3
parent4664863229e684caef42be0e8be16d061e2d8c23 (diff)
downloadports-1af872aa6b5b81dfe630746041737e3d9eb9d2ba.tar.gz
ports-1af872aa6b5b81dfe630746041737e3d9eb9d2ba.zip
Notes
Diffstat (limited to 'net/opal3')
-rw-r--r--net/opal3/files/patch-configurein25
-rw-r--r--net/opal3/files/patch-src::h263codec.cxx13
2 files changed, 35 insertions, 3 deletions
diff --git a/net/opal3/files/patch-configurein b/net/opal3/files/patch-configurein
index 3d6ff53673a9..edff8fef174b 100644
--- a/net/opal3/files/patch-configurein
+++ b/net/opal3/files/patch-configurein
@@ -1,6 +1,8 @@
-*** configure.in.orig Thu May 22 13:25:00 2003
---- configure.in Sat Aug 23 07:52:44 2003
-*************** fi
+Index: configure.in
+diff -c configure.in.orig configure.in
+*** configure.in.orig Thu May 22 21:25:00 2003
+--- configure.in Sun Nov 23 22:51:33 2003
+***************
*** 73,85 ****
dnl ########################################################################
@@ -29,3 +31,20 @@
PWLIBDIR="/usr/local/share/pwlib/"
fi
echo "PWLib prefix set to.... $PWLIBDIR"
+***************
+*** 96,102 ****
+ else
+ AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
+ if test "${H323_AVCODEC:-unset}" != "unset" ; then
+! AVCODECINCLUDEDIR=/usr/local/include/ffmpeg
+ AVCODECLIBDIR=/usr/local/lib
+ fi
+ fi
+--- 96,102 ----
+ else
+ AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
+ if test "${H323_AVCODEC:-unset}" != "unset" ; then
+! AVCODECINCLUDEDIR=/usr/local/include
+ AVCODECLIBDIR=/usr/local/lib
+ fi
+ fi
diff --git a/net/opal3/files/patch-src::h263codec.cxx b/net/opal3/files/patch-src::h263codec.cxx
new file mode 100644
index 000000000000..d8b45f8b078f
--- /dev/null
+++ b/net/opal3/files/patch-src::h263codec.cxx
@@ -0,0 +1,13 @@
+Index: src/h263codec.cxx
+diff -u src/h263codec.cxx.orig src/h263codec.cxx
+--- src/h263codec.cxx.orig Fri Jun 6 15:32:08 2003
++++ src/h263codec.cxx Sat Nov 22 23:17:45 2003
+@@ -109,7 +109,7 @@
+ #include "rtp.h"
+
+ extern "C" {
+-#include <avcodec.h>
++#include <ffmpeg/avcodec.h>
+ };
+
+