aboutsummaryrefslogtreecommitdiff
path: root/net/opal
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-22 16:23:34 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-22 16:23:34 +0000
commit4f12f3b1783327d4e833649c63d8e1724bb16588 (patch)
tree69858a5647bf444b8dbaae3a0602f21ce314cc16 /net/opal
parentd2ddcbb5a0935eab677bbd463a5653e4564b369b (diff)
downloadports-4f12f3b1783327d4e833649c63d8e1724bb16588.tar.gz
ports-4f12f3b1783327d4e833649c63d8e1724bb16588.zip
multimedia/x264: General overhaul
- Split x264 into two ports: the CLI application (x264), and the library (libx264). This will allow x264 to use lavf and friends from ffmpeg for decoding and demuxing while preventing a circular dependency between the two: x264 can depend on ffmpeg, but ffmpeg will depend on libx264 rather than x264. - Add the LAVF option to the CLI port, making the dependency on ffmpeg optional. - Update to 0.142.2455. - Amend fixes to local patches so that they can apply to the new upstream files. - Provide the git revision and other version information to the build environment, allowing the CLI binary to display this information (like the Windows builds). - Remove unsupported build options (X11_OUTPUT). - Ensure that the library and CLI ports each have the appropriate options. - Add notes for future contributors who wish to update the ports. - Bump PORTREVISION for all dependent ports. PR: 187805 Differential Revision: https://reviews.freebsd.org/D1159 Submitted by: Andrew Berg <aberg010@my.hennepintech.edu> Approved by: koobs (maintainer, mentor)
Notes
Notes: svn path=/head/; revision=373073
Diffstat (limited to 'net/opal')
-rw-r--r--net/opal/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 3896d557b0b5..864c1312b32d 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opal
PORTVERSION= 3.10.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= GNOME
@@ -142,7 +142,7 @@ PLIST_SUB+= THEORA="@comment "
.endif
.if ${PORT_OPTIONS:MX264} && ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= libx264.so:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= libx264.so:${PORTSDIR}/multimedia/libx264
CONFIGURE_ARGS+= --enable-x264
PLIST_SUB+= X264=""
WITH_VIDEO= yes