aboutsummaryrefslogtreecommitdiff
path: root/net/openbgpd6
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-06-04 17:45:06 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-06-04 17:45:06 +0000
commitc2b35a8093a613f1b6966f295967a4801f73918a (patch)
tree2b52f2208b14548b7d4ac181ac47dfdd6ccfeba7 /net/openbgpd6
parent55e4101a450c7d69fd816c72caef70c8a9e7e439 (diff)
downloadports-c2b35a8093a613f1b6966f295967a4801f73918a.tar.gz
ports-c2b35a8093a613f1b6966f295967a4801f73918a.zip
New port: net/openbgpd6
OpenBGPD is a FREE implementation of the Border Gateway Protocol, Version 4. It allows ordinary machines to be used as routers exchanging routes with other systems speaking the BGP protocol. This is the portable version and it does not have the means to influence kernel routing tables. It is only suitable for route servers/collectors. WWW: http://www.openbgpd.org/ PR: 213445
Notes
Notes: svn path=/head/; revision=503486
Diffstat (limited to 'net/openbgpd6')
-rw-r--r--net/openbgpd6/Makefile32
-rw-r--r--net/openbgpd6/distinfo3
-rw-r--r--net/openbgpd6/files/COPYING21
-rw-r--r--net/openbgpd6/files/openbgpd.in35
-rw-r--r--net/openbgpd6/files/patch-Makefile.am20
-rw-r--r--net/openbgpd6/files/pkg-message.in6
-rw-r--r--net/openbgpd6/pkg-descr9
-rw-r--r--net/openbgpd6/pkg-plist6
8 files changed, 132 insertions, 0 deletions
diff --git a/net/openbgpd6/Makefile b/net/openbgpd6/Makefile
new file mode 100644
index 000000000000..4496de43de4f
--- /dev/null
+++ b/net/openbgpd6/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= openbgpd
+PORTVERSION= 6.5p0
+CATEGORIES= net
+MASTER_SITES= OPENBSD/OpenBGPD
+PKGNAMESUFFIX= 6
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Free implementation of the Border Gateway Protocol, Version 4
+
+LICENSE= ISCL
+LICENSE_FILE= ${FILESDIR}/COPYING
+
+USES= autoreconf libtool uidfix
+USE_RC_SUBR= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+
+SUB_FILES= pkg-message
+
+USERS= _bgpd
+GROUPS= _bgpd
+
+CONFLICTS= zebra-[0-9]* quagga-[0-9]*
+
+OPTIONS_DEFINE= IPV6LLPEER
+OPTIONS_DEFAULT= IPV6LLPEER
+IPV6LLPEER_DESC= Support nexthop using IPv6 link-local address
+IPV6LLPEER_MAKE_ARGS= -DIPV6_LINKLOCAL_PEER
+
+.include <bsd.port.mk>
diff --git a/net/openbgpd6/distinfo b/net/openbgpd6/distinfo
new file mode 100644
index 000000000000..106b1935ec8b
--- /dev/null
+++ b/net/openbgpd6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556692508
+SHA256 (openbgpd-6.5p0.tar.gz) = 20c1a40bafcbbea60c4ecc6dd2e87fcba6847bfad62739b705a3806b6b442a56
+SIZE (openbgpd-6.5p0.tar.gz) = 677691
diff --git a/net/openbgpd6/files/COPYING b/net/openbgpd6/files/COPYING
new file mode 100644
index 000000000000..e5897e688b8b
--- /dev/null
+++ b/net/openbgpd6/files/COPYING
@@ -0,0 +1,21 @@
+$FreeBSD$
+
+Copyright (c) 2003-2007 Henning Brauer <henning@openbsd.org>
+Copyright (c) 2002 Daniel Hartmeier <dhartmei@openbsd.org>
+Copyright (c) 2003, 2004, 2006 Claudio Jeker <claudio@openbsd.org>
+Copyright (c) 2003, 2004 Markus Friedl <markus@openbsd.org>
+Copyright (c) 2004 Damien Miller <djm@openbsd.org>
+Copyright (c) 2006, 2007, 2008 Reyk Floeter <reyk@openbsd.org>
+Copyright (c) 2006, 2007 Pierre-Yves Ritschard <pyr@openbsd.org>
+
+Permission to use, copy, modify, and distribute this software for any
+purpose with or without fee is hereby granted, provided that the above
+copyright notice and this permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+WHATSOEVER RESULTING FROM LOSS OF MIND, USE, DATA OR PROFITS, WHETHER IN
+AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT
+OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/net/openbgpd6/files/openbgpd.in b/net/openbgpd6/files/openbgpd.in
new file mode 100644
index 000000000000..cddf6528f2bb
--- /dev/null
+++ b/net/openbgpd6/files/openbgpd.in
@@ -0,0 +1,35 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: bgpd
+# REQUIRE: LOGIN abi
+# BEFORE: securelevel
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable openbgpd:
+#
+# openbgpd_enable="YES"
+# openbgpd_flags="<set as needed>"
+#
+# See bgpd(8) for openbgpd_flags
+
+. /etc/rc.subr
+
+name=openbgpd
+rcvar=openbgpd_enable
+
+extra_commands=reload
+command="%%PREFIX%%/sbin/bgpd"
+required_files="%%PREFIX%%/etc/bgpd.conf"
+
+: ${openbgpd_enable=NO}
+
+check_process()
+{
+ /bin/pgrep -f 'bgpd: parent.*'
+}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/openbgpd6/files/patch-Makefile.am b/net/openbgpd6/files/patch-Makefile.am
new file mode 100644
index 000000000000..da85a8ad6103
--- /dev/null
+++ b/net/openbgpd6/files/patch-Makefile.am
@@ -0,0 +1,20 @@
+--- Makefile.am.orig 2019-05-01 11:22:14 UTC
++++ Makefile.am
+@@ -19,13 +19,14 @@
+ EXTRA_DIST = README.md VERSION bgpd.conf
+
+ install-data-hook:
+- @if [ ! -d "$(DESTDIR)$(localstatedir)/run" ]; then \
++ if [ ! -d "$(DESTDIR)$(localstatedir)/run" ]; then \
+ $(INSTALL) -m 755 -d "$(DESTDIR)$(localstatedir)/run"; \
+ fi
+- @if [ ! -d "$(DESTDIR)$(sysconfdir)" ]; then \
++ if [ ! -d "$(DESTDIR)$(sysconfdir)" ]; then \
+ $(INSTALL) -m 755 -d "$(DESTDIR)$(sysconfdir)"; \
+ fi
+- @if [ ! -f "$(DESTDIR)$(sysconfdir)/bgpd.conf" ]; then \
++ $(INSTALL) -m 644 "$(srcdir)/bgpd.conf" "$(DESTDIR)$(sysconfdir)/bgpd.conf.sample"; \
++ if [ ! -f "$(DESTDIR)$(sysconfdir)/bgpd.conf" ]; then \
+ $(INSTALL) -m 644 "$(srcdir)/bgpd.conf" "$(DESTDIR)$(sysconfdir)/bgpd.conf"; \
+ else \
+ echo; \
diff --git a/net/openbgpd6/files/pkg-message.in b/net/openbgpd6/files/pkg-message.in
new file mode 100644
index 000000000000..db9af6122ff0
--- /dev/null
+++ b/net/openbgpd6/files/pkg-message.in
@@ -0,0 +1,6 @@
+------------------------------------------------------------------
+OpenBGPD has been successfully installed.
+
+Configuration file must be created at %%PREFIX%%/etc/bgpd.conf
+and permission set to 0600.
+------------------------------------------------------------------
diff --git a/net/openbgpd6/pkg-descr b/net/openbgpd6/pkg-descr
new file mode 100644
index 000000000000..79dc946dcb12
--- /dev/null
+++ b/net/openbgpd6/pkg-descr
@@ -0,0 +1,9 @@
+OpenBGPD is a FREE implementation of the Border Gateway Protocol, Version 4.
+It allows ordinary machines to be used as routers exchanging routes with
+other systems speaking the BGP protocol.
+
+This is the portable version and it does not have the means to
+influence kernel routing tables. It is only suitable for route
+servers/collectors.
+
+WWW: http://www.openbgpd.org/
diff --git a/net/openbgpd6/pkg-plist b/net/openbgpd6/pkg-plist
new file mode 100644
index 000000000000..76795a6b9942
--- /dev/null
+++ b/net/openbgpd6/pkg-plist
@@ -0,0 +1,6 @@
+sbin/bgpctl
+sbin/bgpd
+man/man5/bgpd.conf.5.gz
+man/man8/bgpctl.8.gz
+man/man8/bgpd.8.gz
+@sample etc/bgpd.conf.sample