aboutsummaryrefslogtreecommitdiff
path: root/net/openh323
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-01 07:25:16 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-01 07:25:16 +0000
commit59148f4e81638fdc9520227a72436fefefab65fd (patch)
tree9c50865fad9dae51a76e84961ed684c985588c2a /net/openh323
parentbf1ee3290e60cf814992d9e666f310d200bb95c8 (diff)
downloadports-59148f4e81638fdc9520227a72436fefefab65fd.tar.gz
ports-59148f4e81638fdc9520227a72436fefefab65fd.zip
Notes
Diffstat (limited to 'net/openh323')
-rw-r--r--net/openh323/Makefile7
-rw-r--r--net/openh323/distinfo6
-rw-r--r--net/openh323/files/patch-include-h4601.h12
-rw-r--r--net/openh323/files/patch-include-mediafmt.h19
-rw-r--r--net/openh323/files/patch-src-h261codec-cxx11
-rw-r--r--net/openh323/files/patch-src-h323caps.cxx58
-rw-r--r--net/openh323/files/patch-src-h323ep-cxx11
-rw-r--r--net/openh323/files/patch-src-h323pluginmgr-cxx13
-rw-r--r--net/openh323/files/patch-src-mediafmt.cxx12
-rw-r--r--net/openh323/pkg-plist1
10 files changed, 143 insertions, 7 deletions
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index f10845d97734..f37b801a4d9a 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= openh323
-PORTVERSION= 1.18.0
-PORTREVISION= 6
+PORTVERSION= 1.19.0.1
CATEGORIES= net
-MASTER_SITES= http://www.voxgratia.org/releases/
-DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+DISTNAME= openh323/${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
EXTRACT_SUFX= tar.gz
MAINTAINER= steve@energistic.com
diff --git a/net/openh323/distinfo b/net/openh323/distinfo
index 6390742847a1..b675e6a858da 100644
--- a/net/openh323/distinfo
+++ b/net/openh323/distinfo
@@ -1,3 +1,3 @@
-MD5 (openh323-v1_18_0-src-tar.gz) = d7043ba34b5038f0113b099ede0884fb
-SHA256 (openh323-v1_18_0-src-tar.gz) = 26b4c9cf21dc1c92edf1583046670fce6be5b13045ef5d06e11403d36ffff218
-SIZE (openh323-v1_18_0-src-tar.gz) = 3742730
+MD5 (openh323/openh323-v1_19_0_1-src-tar.gz) = e7ba3ae6b50d0d02c5cbe9ed3a3152c4
+SHA256 (openh323/openh323-v1_19_0_1-src-tar.gz) = a4909d8d26a50eec42d3bfb6b88ff53ef0a714e6c6b6cf381b783050a09d31ea
+SIZE (openh323/openh323-v1_19_0_1-src-tar.gz) = 3959271
diff --git a/net/openh323/files/patch-include-h4601.h b/net/openh323/files/patch-include-h4601.h
new file mode 100644
index 000000000000..8022ba51565b
--- /dev/null
+++ b/net/openh323/files/patch-include-h4601.h
@@ -0,0 +1,12 @@
+diff -ruN include/h4601.h.orig include/h4601.h
+--- include/h4601.h.orig 2006-06-08 09:26:16.000000000 -0400
++++ include/h4601.h 2007-12-31 15:10:41.000000000 -0500
+@@ -61,6 +61,7 @@
+
+ #include "h225.h"
+ #include "transports.h"
++#include <ptlib/pluginmgr.h>
+ #include <ptclib/url.h>
+
+
+
diff --git a/net/openh323/files/patch-include-mediafmt.h b/net/openh323/files/patch-include-mediafmt.h
new file mode 100644
index 000000000000..641449b9142a
--- /dev/null
+++ b/net/openh323/files/patch-include-mediafmt.h
@@ -0,0 +1,19 @@
+--- ../openh323.orig/work/openh323_v1_18_0/include/mediafmt.h 2005-11-30 08:05:01.000000000 -0500
++++ include/mediafmt.h 2008-01-05 23:12:39.000000000 -0500
+@@ -163,9 +163,13 @@
+ RTP_DataFrame::PayloadTypes GetPayloadType() const { return rtpPayloadType; }
+
+ enum {
+- DefaultAudioSessionID = 1,
+- DefaultVideoSessionID = 2,
+- DefaultDataSessionID = 3
++ FirstSessionID = 1,
++ DefaultAudioSessionID = 1,
++ DefaultVideoSessionID = 2,
++ DefaultDataSessionID = 3,
++ DefaultH224SessionID = 4,
++ DefaultExtVideoSessionID = 5,
++ LastSessionID = 5
+ };
+
+ /**Get the default session ID for media format.
diff --git a/net/openh323/files/patch-src-h261codec-cxx b/net/openh323/files/patch-src-h261codec-cxx
new file mode 100644
index 000000000000..ff426c9fde64
--- /dev/null
+++ b/net/openh323/files/patch-src-h261codec-cxx
@@ -0,0 +1,11 @@
+diff -ruN src/h261codec.cxx.orig src/h261codec.cxx
+--- src/h261codec.cxx 2006-06-06 04:05:40.000000000 -0400
++++ src/h261codec.cxx 2007-12-31 15:17:29.000000000 -0500
+@@ -279,6 +279,7 @@
+ #include "h245.h"
+ #include "rtp.h"
+
++#include <ptlib/video.h>
+ #include "vic/p64.h"
+ #include "vic/p64encoder.h"
+
diff --git a/net/openh323/files/patch-src-h323caps.cxx b/net/openh323/files/patch-src-h323caps.cxx
new file mode 100644
index 000000000000..164315e4c9e6
--- /dev/null
+++ b/net/openh323/files/patch-src-h323caps.cxx
@@ -0,0 +1,58 @@
+--- src/h323caps.cxx.orig 2006-05-16 07:36:01.000000000 -0400
++++ src/h323caps.cxx 2007-12-31 15:28:02.000000000 -0500
+@@ -2076,7 +2076,7 @@
+ PINDEX simultaneous,
+ const PString & name)
+ {
+- PINDEX reply = descriptorNum == P_MAX_INDEX ? P_MAX_INDEX : simultaneous;
++/* PINDEX reply = descriptorNum == P_MAX_INDEX ? P_MAX_INDEX : simultaneous;
+
+ PStringArray wildcard = name.Tokenise('*', FALSE);
+
+@@ -2109,6 +2109,46 @@
+ }
+
+ return reply;
++*/
++
++
++
++
++ PINDEX reply = descriptorNum == P_MAX_INDEX ? P_MAX_INDEX : simultaneous;
++
++ PStringArray wildcard = name.Tokenise('*', FALSE);
++
++ H323CapabilityFactory::KeyList_T stdCaps = H323CapabilityFactory::GetKeyList();
++
++ for (unsigned session = OpalMediaFormat::FirstSessionID; session <= OpalMediaFormat::LastSessionID; session++) {
++ for (H323CapabilityFactory::KeyList_T::const_iterator r = stdCaps.begin(); r != stdCaps.end(); ++r) {
++ PString capName(*r);
++ if (MatchWildcard(capName, wildcard) && (FindCapability(capName) == NULL)) {
++ OpalMediaFormat mediaFormat(capName);
++ if (!mediaFormat.IsValid() && (capName.Right(4) == "{sw}") && capName.GetLength() > 4)
++ mediaFormat = OpalMediaFormat(capName.Left(capName.GetLength()-4));
++ if (mediaFormat.IsValid() && mediaFormat.GetDefaultSessionID() == session) {
++ // add the capability
++ H323Capability * capability = H323Capability::Create(capName);
++ PINDEX num = SetCapability(descriptorNum, simultaneous, capability);
++ if (descriptorNum == P_MAX_INDEX) {
++ reply = num;
++ descriptorNum = num;
++ simultaneous = P_MAX_INDEX;
++ }
++ else if (simultaneous == P_MAX_INDEX) {
++ if (reply == P_MAX_INDEX)
++ reply = num;
++ simultaneous = num;
++ }
++ }
++ }
++ }
++ simultaneous = P_MAX_INDEX;
++ }
++
++ return reply;
++
+ }
+
+
diff --git a/net/openh323/files/patch-src-h323ep-cxx b/net/openh323/files/patch-src-h323ep-cxx
new file mode 100644
index 000000000000..29e80a67bd5f
--- /dev/null
+++ b/net/openh323/files/patch-src-h323ep-cxx
@@ -0,0 +1,11 @@
+diff -ruN src/h323ep.cxx.orig src/h323ep.cxx
+--- src/h323ep.cxx.orig 2006-06-09 02:30:12.000000000 -0400
++++ src/h323ep.cxx 2007-12-31 13:11:13.000000000 -0500
+@@ -793,6 +793,7 @@
+ #include <ptclib/url.h>
+ #include <ptclib/pils.h>
+ #include <ptclib/enum.h>
++#include <ptlib/sound.h>
+
+ #if defined(H323_RTP_AGGREGATE) || defined(H323_SIGNAL_AGGREGATE)
+ #include <ptclib/sockagg.h>
diff --git a/net/openh323/files/patch-src-h323pluginmgr-cxx b/net/openh323/files/patch-src-h323pluginmgr-cxx
new file mode 100644
index 000000000000..e3546d1dbe2c
--- /dev/null
+++ b/net/openh323/files/patch-src-h323pluginmgr-cxx
@@ -0,0 +1,13 @@
+diff -ruN src/h323pluginmgr.cxx.orig src/h323pluginmgr.
+cxx
+--- src/h323pluginmgr.cxx.orig 2005-08-05 13:11:03.000000000 -0400
++++ src/h323pluginmgr.cxx 2007-12-31 15:04:53.000000000 -0500
+@@ -1305,7 +1305,7 @@
+ PTRACE(4, "H323PLUGIN\tCannot instantiate static codec plugin " << *r);
+ } else {
+ PTRACE(4, "H323PLUGIN\tLoading static codec plugin " << *r);
+- RegisterStaticCodec(*r, instance->Get_GetAPIFn(), instance->Get_GetCodecFn());
++ RegisterStaticCodec(r->c_str(), instance->Get_GetAPIFn(), instance->Get_GetCodecFn());
+ }
+ }
+ }
diff --git a/net/openh323/files/patch-src-mediafmt.cxx b/net/openh323/files/patch-src-mediafmt.cxx
new file mode 100644
index 000000000000..084c50685c93
--- /dev/null
+++ b/net/openh323/files/patch-src-mediafmt.cxx
@@ -0,0 +1,12 @@
+diff -ruN src/mediafmt.cxx.orig src/mediafmt.cxx
+--- src/mediafmt.cxx.orig 2005-01-11 02:12:13.000000000 -0500
++++ src/mediafmt.cxx 2007-12-31 14:48:26.000000000 -0500
+@@ -395,7 +395,7 @@
+ OpalMediaFormatFactory::KeyMap_T & keyMap = OpalMediaFormatFactory::GetKeyMap();
+ OpalMediaFormatFactory::KeyMap_T::const_iterator r;
+ for (r = keyMap.begin(); r != keyMap.end(); ++r) {
+- if (r->first.Find(search) != P_MAX_INDEX) {
++ if (r->first.find(search) != P_MAX_INDEX) {
+ *this = *OpalMediaFormatFactory::CreateInstance(r->first);
+ break;
+ }
diff --git a/net/openh323/pkg-plist b/net/openh323/pkg-plist
index 9b9416f9772c..fde845ac0e93 100644
--- a/net/openh323/pkg-plist
+++ b/net/openh323/pkg-plist
@@ -46,6 +46,7 @@ include/openh323/h450pdu.h
include/openh323/h460.h
include/openh323/h501.h
include/openh323/h501pdu.h
+include/openh323/h4601.h
include/openh323/hid.h
include/openh323/ixjDefs.h
include/openh323/ixjidb.h