aboutsummaryrefslogtreecommitdiff
path: root/net/openh323
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-10 21:30:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-10 21:30:34 +0000
commit8dcfd3da34900ca743948f825061df44fea4ea27 (patch)
treed9b5f4ffa8ba874761b2da0ecb1235362a03f961 /net/openh323
parent4c44860299f2b768b886621ae340c62bf4411c54 (diff)
downloadports-8dcfd3da34900ca743948f825061df44fea4ea27.tar.gz
ports-8dcfd3da34900ca743948f825061df44fea4ea27.zip
Notes
Diffstat (limited to 'net/openh323')
-rw-r--r--net/openh323/Makefile8
-rw-r--r--net/openh323/distinfo4
-rw-r--r--net/openh323/files/patch-configurein63
-rw-r--r--net/openh323/files/patch-include+h263codec.h19
-rw-r--r--net/openh323/files/patch-include-ffh263codec.h12
-rw-r--r--net/openh323/files/patch-include-h263codec.h19
-rw-r--r--net/openh323/files/patch-src-ffh263codec.cxx19
-rw-r--r--net/openh323/files/patch-src::h263codec.cxx20
8 files changed, 71 insertions, 93 deletions
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index d5856d94fff5..52ec78d313d4 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openh323
-PORTVERSION= 1.12.0
-PORTREVISION= 5
+PORTVERSION= 1.12.2
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -18,7 +17,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A H323 Video Conferencing library
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build
-
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
.include <bsd.port.pre.mk>
@@ -28,7 +26,7 @@ LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
# If it is not present, extract it from the comms/ixj port
.if !exists(/usr/include/sys/telephony.h)
.if !exists(/usr/local/include/sys/telephony.h)
-PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/comms/ixj:patch
+PATCH_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/comms/ixj:patch
.endif
.endif
.endif
@@ -40,7 +38,7 @@ USE_BISON= yes
USE_GMAKE= yes
USE_OPENLDAP= yes
-USE_AUTOCONF_VER= 253
+USE_AUTOCONF_VER= 259
GNU_CONFIGURE= yes
PWLIBDIR!= cd ${PORTSDIR}/devel/pwlib && make -V WRKSRC
CONFIGURE_ENV= PWLIBDIR=${PWLIBDIR} OPENH323DIR=${WRKSRC}
diff --git a/net/openh323/distinfo b/net/openh323/distinfo
index bc1860481dea..76c84d0a1a8c 100644
--- a/net/openh323/distinfo
+++ b/net/openh323/distinfo
@@ -1,2 +1,2 @@
-MD5 (openh323_1.12.0.tar.gz) = f7932f0a17d6afafc7332036a4b5d392
-SIZE (openh323_1.12.0.tar.gz) = 2325128
+MD5 (openh323_1.12.2.tar.gz) = 15f0b12b60769d03eca9e498050776f3
+SIZE (openh323_1.12.2.tar.gz) = 2343354
diff --git a/net/openh323/files/patch-configurein b/net/openh323/files/patch-configurein
index edff8fef174b..28578a9c1175 100644
--- a/net/openh323/files/patch-configurein
+++ b/net/openh323/files/patch-configurein
@@ -1,50 +1,19 @@
-Index: configure.in
-diff -c configure.in.orig configure.in
-*** configure.in.orig Thu May 22 21:25:00 2003
---- configure.in Sun Nov 23 22:51:33 2003
+*** configure.in.orig Mon Jun 6 14:34:14 2005
+--- configure.in Mon Jun 6 14:41:03 2005
***************
-*** 73,85 ****
+*** 109,115 ****
+ if test "${H323_AVCODEC:-unset}" != "unset" ; then
+ AC_SUBST(H323_AVCODEC, 1)
+ AC_DEFINE(H323_AVCODEC, 1, "ffmpeg based avodec found")
+! AVCODECINCLUDEDIR=/usr/local/include/ffmpeg
+ AVCODECLIBDIR=/usr/local/lib
+ STDCCFLAGS="$STDCCFLAGS -I${AVCODECINCLUDEDIR}"
- dnl ########################################################################
- dnl get pwlib directory
-! if test "${PWLIBDIR:-unset}" == "unset" ; then
- PWLIBDIR=`ptlib-config --prefix`
- fi
-! if test "x$PWLIBDIR" == "x/usr" -o "x$PWLIBDIR" == "x/usr/"; then
- PWLIBDIR="/usr/share/pwlib/"
- fi
-! if test "xPWLIBDIR" == "x/usr/local" -o "x$PWLIBDIR" == "x/usr/"; then
- PWLIBDIR="/usr/local/share/pwlib/"
- fi
- echo "PWLib prefix set to.... $PWLIBDIR"
---- 73,85 ----
+--- 109,115 ----
+ if test "${H323_AVCODEC:-unset}" != "unset" ; then
+ AC_SUBST(H323_AVCODEC, 1)
+ AC_DEFINE(H323_AVCODEC, 1, "ffmpeg based avodec found")
+! AVCODECINCLUDEDIR=/usr/local/include
+ AVCODECLIBDIR=/usr/local/lib
+ STDCCFLAGS="$STDCCFLAGS -I${AVCODECINCLUDEDIR}"
- dnl ########################################################################
- dnl get pwlib directory
-! if test "${PWLIBDIR:-unset}" = "unset" ; then
- PWLIBDIR=`ptlib-config --prefix`
- fi
-! if test "x$PWLIBDIR" = "x/usr" -o "x$PWLIBDIR" = "x/usr/"; then
- PWLIBDIR="/usr/share/pwlib/"
- fi
-! if test "xPWLIBDIR" = "x/usr/local" -o "x$PWLIBDIR" = "x/usr/"; then
- PWLIBDIR="/usr/local/share/pwlib/"
- fi
- echo "PWLib prefix set to.... $PWLIBDIR"
-***************
-*** 96,102 ****
- else
- AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
- if test "${H323_AVCODEC:-unset}" != "unset" ; then
-! AVCODECINCLUDEDIR=/usr/local/include/ffmpeg
- AVCODECLIBDIR=/usr/local/lib
- fi
- fi
---- 96,102 ----
- else
- AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
- if test "${H323_AVCODEC:-unset}" != "unset" ; then
-! AVCODECINCLUDEDIR=/usr/local/include
- AVCODECLIBDIR=/usr/local/lib
- fi
- fi
diff --git a/net/openh323/files/patch-include+h263codec.h b/net/openh323/files/patch-include+h263codec.h
deleted file mode 100644
index 171efe102701..000000000000
--- a/net/openh323/files/patch-include+h263codec.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- include/h263codec.h.orig Sat Feb 19 11:29:15 2005
-+++ include/h263codec.h Sat Feb 19 11:38:52 2005
-@@ -92,6 +92,7 @@
- struct AVCodec;
- struct AVCodecContext;
- struct AVFrame;
-+struct AVCodecParserContext;
-
- ///////////////////////////////////////////////////////////////////////////////
-
-@@ -478,7 +479,7 @@
- send. Note that for every encode thread, this 1 method is called. Consequently,
- code is required to separate out packets from different encode threads.
- */
-- static void RtpCallback(void *data, int size, int packetNumber);
-+ static void RtpCallback(AVCodecContext *s, void *data, int size, int packetNumber);
-
- protected:
- BOOL Resize(int width, int height);
diff --git a/net/openh323/files/patch-include-ffh263codec.h b/net/openh323/files/patch-include-ffh263codec.h
new file mode 100644
index 000000000000..4329c3f7ef76
--- /dev/null
+++ b/net/openh323/files/patch-include-ffh263codec.h
@@ -0,0 +1,12 @@
+*** include/ffh263codec.h.orig Mon Aug 4 00:03:16 2003
+--- include/ffh263codec.h Mon Jun 6 14:54:31 2005
+***************
+*** 96,101 ****
+--- 96,102 ----
+ struct AVCodec;
+ struct AVCodecContext;
+ struct AVFrame;
++ struct AVCodecParserContext;
+
+ ///////////////////////////////////////////////////////////////////////////////
+
diff --git a/net/openh323/files/patch-include-h263codec.h b/net/openh323/files/patch-include-h263codec.h
new file mode 100644
index 000000000000..de0bf299f3bd
--- /dev/null
+++ b/net/openh323/files/patch-include-h263codec.h
@@ -0,0 +1,19 @@
+*** include/h263codec.h.orig Mon Aug 4 00:03:22 2003
+--- include/h263codec.h Mon Jun 6 14:57:16 2005
+***************
+*** 426,432 ****
+ send. Note that for every encode thread, this 1 method is called. Consequently,
+ code is required to separate out packets from different encode threads.
+ */
+! static void RtpCallback(void *data, int size, int packetNumber);
+
+ protected:
+ BOOL Resize(int width, int height);
+--- 426,432 ----
+ send. Note that for every encode thread, this 1 method is called. Consequently,
+ code is required to separate out packets from different encode threads.
+ */
+! static void RtpCallback(AVCodecContext *s, void *data, int size, int packet Number);
+
+ protected:
+ BOOL Resize(int width, int height);
diff --git a/net/openh323/files/patch-src-ffh263codec.cxx b/net/openh323/files/patch-src-ffh263codec.cxx
new file mode 100644
index 000000000000..3669cbe8779d
--- /dev/null
+++ b/net/openh323/files/patch-src-ffh263codec.cxx
@@ -0,0 +1,19 @@
+*** src/ffh263codec.cxx.orig Fri Aug 8 01:52:14 2003
+--- src/ffh263codec.cxx Mon Jun 6 15:28:05 2005
+***************
+*** 140,146 ****
+ #define MSVC_OPENH323 1
+
+ extern "C" {
+! #include <avcodec.h>
+ };
+
+
+--- 140,146 ----
+ #define MSVC_OPENH323 1
+
+ extern "C" {
+! #include <ffmpeg/avcodec.h>
+ };
+
+
diff --git a/net/openh323/files/patch-src::h263codec.cxx b/net/openh323/files/patch-src::h263codec.cxx
deleted file mode 100644
index dee9c412d539..000000000000
--- a/net/openh323/files/patch-src::h263codec.cxx
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/h263codec.cxx.orig Fri Jun 6 08:32:08 2003
-+++ src/h263codec.cxx Sat Feb 19 11:19:36 2005
-@@ -109,7 +109,7 @@
- #include "rtp.h"
-
- extern "C" {
--#include <avcodec.h>
-+#include <ffmpeg/avcodec.h>
- };
-
-
-@@ -836,7 +836,7 @@
- }
-
-
--void H323_H263Codec::RtpCallback(void *data, int size, int /*packetNumber*/)
-+void H323_H263Codec::RtpCallback(AVCodecContext* /*s*/, void *data, int size, int /*packetNumber*/)
- {
- encodedPackets.AppendH263Packet(data, size);
- }