aboutsummaryrefslogtreecommitdiff
path: root/net/openh323
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-20 07:32:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-20 07:32:56 +0000
commitc92e60e03ada4277fc0af1f0b2b47895cbe90562 (patch)
tree990d819a8578eee6165c1601e215b23e9a9aa663 /net/openh323
parenta82a0364dc18ce9b2333e4c7b12970acd386af10 (diff)
downloadports-c92e60e03ada4277fc0af1f0b2b47895cbe90562.tar.gz
ports-c92e60e03ada4277fc0af1f0b2b47895cbe90562.zip
Notes
Diffstat (limited to 'net/openh323')
-rw-r--r--net/openh323/Makefile15
-rw-r--r--net/openh323/pkg-plist1
2 files changed, 10 insertions, 6 deletions
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index e98e21bfa789..7a6091918561 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -13,12 +13,12 @@ DIST_SUBDIR= openh323
MAINTAINER= ports@FreeBSD.org
COMMENT= A H323 Video Conferencing library
-LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
+LIB_DEPENDS= libpt_r.so:${PORTSDIR}/devel/pwlib
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
-USES= bison
-USE_GMAKE= yes
+USES= bison gmake
+USE_GCC= yes
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -29,16 +29,15 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${WRKSRC}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= BUILDTIME="YES"
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.ifdef (WITH_FFMPEG)
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-rfc2190avcodec=${LOCALBASE}/include/ffmpeg
.endif
.ifdef (WITH_SPEEX)
-LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex
CONFIGURE_ARGS+= --enable-localspeex=no
.else
CONFIGURE_ARGS+= --enable-localspeex=yes
@@ -52,4 +51,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/configure.ac
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libh323_r.so.1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pwlib/codecs/audio/*.so
+
.include <bsd.port.post.mk>
diff --git a/net/openh323/pkg-plist b/net/openh323/pkg-plist
index fde845ac0e93..ae232c5b69ab 100644
--- a/net/openh323/pkg-plist
+++ b/net/openh323/pkg-plist
@@ -88,3 +88,4 @@ lib/pwlib/codecs/audio/lpc10_audio_pwplugin.so
lib/pwlib/codecs/audio/speex_audio_pwplugin.so
@dirrm lib/pwlib/codecs/audio
@dirrm lib/pwlib/codecs
+@dirrmtry lib/pwlib