aboutsummaryrefslogtreecommitdiff
path: root/net/openldap22/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-11-08 07:48:20 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-11-08 07:48:20 +0000
commit7a7daa00f1fb03960b5dc6988f35c98d38bd5515 (patch)
treebe82d34c3bd9289d3cd0f6db169e71138434ff87 /net/openldap22/Makefile
parenta907c2f75354806b4714db4b702e5cb69e3c0579 (diff)
downloadports-7a7daa00f1fb03960b5dc6988f35c98d38bd5515.tar.gz
ports-7a7daa00f1fb03960b5dc6988f35c98d38bd5515.zip
Notes
Diffstat (limited to 'net/openldap22/Makefile')
-rw-r--r--net/openldap22/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/net/openldap22/Makefile b/net/openldap22/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap22/Makefile
+++ b/net/openldap22/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS= --localstatedir=/var/run \
CONFIGURE_ARGS+= --enable-wrappers
.endif
-.if defined(WITH_DB2)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
- LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+= -I${LOCALBASE}/include/db2 -D_THREAD_SAFE
CONFIGURE_ARGS+= --enable-ldbm \
--with-ldbm-api=db2
.endif
+.if defined(WITH_SASL)
+LIB_DEPENDS= sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+= -I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
BINS= bin/ldapadd \
bin/ldapdelete \
bin/ldapmodify \