aboutsummaryrefslogtreecommitdiff
path: root/net/openldap24-server
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2017-09-27 06:57:59 +0000
committerXin LI <delphij@FreeBSD.org>2017-09-27 06:57:59 +0000
commitd4da9b7abe528e7c694f8e86f2a018b3c0712208 (patch)
tree78af9a3b38e4f22606d4202bafdea85ce8aa5089 /net/openldap24-server
parent3a69d61f8954ff5a3134c6098efc6288cf6633a2 (diff)
downloadports-d4da9b7abe528e7c694f8e86f2a018b3c0712208.tar.gz
ports-d4da9b7abe528e7c694f8e86f2a018b3c0712208.zip
Reorder several variable definitions in Makefile.
PR: ports/222405 Submitted by: Yasuhiro KIMURA <yasu utahime org>
Notes
Notes: svn path=/head/; revision=450722
Diffstat (limited to 'net/openldap24-server')
-rw-r--r--net/openldap24-server/Makefile27
1 files changed, 19 insertions, 8 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index cef0e20d89fc..2457c3252ec0 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -13,31 +13,42 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/%SUBDIR%/ \
http://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/
MASTER_SITE_SUBDIR= openldap-release
-
.if defined(CLIENT_ONLY)
.if ${CLIENT_ONLY} == sasl
PKGNAMESUFFIX= -sasl-client
-COMMENT= Open source LDAP client implementation with SASL2 support
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[0-3].*
.else
PKGNAMESUFFIX= -client
-COMMENT= Open source LDAP client implementation
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[0-3].* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
.endif
.else
PKGNAMESUFFIX?= -server
.endif
MAINTAINER= delphij@FreeBSD.org
-COMMENT?= Open source LDAP server implementation
+.if defined(CLIENT_ONLY)
+.if ${CLIENT_ONLY} == sasl
+COMMENT= Open source LDAP client implementation with SASL2 support
+.else
+COMMENT= Open source LDAP client implementation
+.endif
+.else
+COMMENT= Open source LDAP server implementation
+.endif
LICENSE= OPENLDAP
LICENSE_NAME= OpenLDAP Public License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+.if defined(CLIENT_ONLY)
+.if ${CLIENT_ONLY} == sasl
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[0-3].*
+.else
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[0-3].* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
+.endif
+.endif
+
GNU_CONFIGURE= yes
# :keepla because port uses lt_dlopen
USES= cpe libtool:keepla ssl tar:tgz