aboutsummaryrefslogtreecommitdiff
path: root/net/openldap24-server
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2019-11-30 06:19:51 +0000
committerXin LI <delphij@FreeBSD.org>2019-11-30 06:19:51 +0000
commitdb3ed360e4c4399b4823e4e42937df643a131153 (patch)
treeb7f4344c0f65fef4416303712e72ed141ec75a2b /net/openldap24-server
parent60c885cbbe40ef8dc98abca0026f0d0d123ec334 (diff)
downloadports-db3ed360e4c4399b4823e4e42937df643a131153.tar.gz
ports-db3ed360e4c4399b4823e4e42937df643a131153.zip
net/openldap24-server: add support for pbkdf2 password hash
PR: 241471 Submitted by: Joris Dedieu <joris dedieu gmail com>
Notes
Notes: svn path=/head/; revision=518705
Diffstat (limited to 'net/openldap24-server')
-rw-r--r--net/openldap24-server/Makefile25
-rw-r--r--net/openldap24-server/pkg-plist4
2 files changed, 27 insertions, 2 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 19c4219af9b9..0a8f626cb052 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -85,6 +85,7 @@ OPTIONS_DEFINE+= DEREF DYNGROUP DYNLIST MEMBEROF PPOLICY PROXYCACHE
OPTIONS_DEFINE+= REFINT RETCODE RWM SEQMOD SSSVLV SYNCPROV TRANSLUCENT
OPTIONS_DEFINE+= UNIQUE VALSORT SMBPWD SHA2 DYNAMIC_BACKENDS SASL
OPTIONS_DEFINE+= LMPASSWD
+OPTIONS_DEFINE+= PBKDF2
OPTIONS_DEFINE+= OUTLOOK
OPTIONS_DEFINE+= LASTBIND
OPTIONS_DEFINE+= KQUEUE
@@ -130,6 +131,7 @@ VALSORT_DESC= With Value Sorting overlay
SMBPWD_DESC= With Samba Password hashes overlay
SHA2_DESC= With SHA2 Password hashes overlay
LMPASSWD_DESC= With LM hash password support (DEPRECATED)
+PBKDF2_DESC= With PBKDF2 hash password support
DYNAMIC_BACKENDS_DESC= Build dynamic backends
OUTLOOK_DESC= Force caseIgnoreOrderingMatch on name attribute (experimental)
LASTBIND_DESC= With lastbind overlay
@@ -467,6 +469,12 @@ PLIST_SUB+= SHA2=""
PLIST_SUB+= SHA2="@comment "
.endif
+.if ${PORT_OPTIONS:MPBKDF2}
+PLIST_SUB+= PBKDF2=""
+.else
+PLIST_SUB+= PBKDF2="@comment "
+.endif
+
.if ${PORT_OPTIONS:MLASTBIND}
PLIST_SUB+= LASTBIND=""
.else
@@ -506,7 +514,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extrapatch-outlook-servers__slapd__schema_prep.c
.endif
.if ${PORT_OPTIONS:MKQUEUE}
-BUILD_DEPENDS+= autoconf>0:devel/autoconf
+USE_AUTOTOOLS+= autoconf
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-ITS6300
.endif
@@ -580,6 +588,12 @@ post-build:
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
${MAKE_ARGS} prefix="${PREFIX}" all)
.endif
+.if ${PORT_OPTIONS:MPBKDF2}
+ @(cd ${BUILD_WRKSRC}/contrib/slapd-modules/passwd/pbkdf2 && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${MAKE_ARGS} prefix="${PREFIX}" all)
+.endif
+
.if ${PORT_OPTIONS:MLASTBIND}
@(cd ${BUILD_WRKSRC}/contrib/slapd-modules/lastbind && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
@@ -621,13 +635,20 @@ post-install:
${MAKE_ARGS} prefix="${PREFIX}" install)
${RM} ${STAGEDIR}${PREFIX}/libexec/openldap/pw-sha2.a
.endif
+.if ${PORT_OPTIONS:MPBKDF2}
+ (cd ${WRKSRC}/contrib/slapd-modules/passwd/pbkdf2 && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${MAKE_ARGS} prefix="${PREFIX}" install)
+ ${RM} ${STAGEDIR}${PREFIX}/libexec/openldap/pw-pbkdf2.a
+.endif
+
.if ${PORT_OPTIONS:MLASTBIND}
(cd ${WRKSRC}/contrib/slapd-modules/lastbind && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
${MAKE_ARGS} prefix="${PREFIX}" install)
${RM} ${STAGEDIR}${PREFIX}/libexec/openldap/lastbind.a
.endif
-.if ${PORT_OPTIONS:MDYNAMIC_BACKENDS} || ${PORT_OPTIONS:MSMBPWD} || ${PORT_OPTIONS:MSHA2}
+.if ${PORT_OPTIONS:MDYNAMIC_BACKENDS} || ${PORT_OPTIONS:MSMBPWD} || ${PORT_OPTIONS:MSHA2} || ${PORT_OPTIONS:MPBKDF2}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/openldap/*.so
.endif
.if ${PORT_OPTIONS:MDYNAMIC_BACKENDS} || ${PORT_OPTIONS:MSLAPI}
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index 9fbbc2ef7ec8..c7a151d98c11 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -93,6 +93,10 @@
%%SHA2%%libexec/openldap/pw-sha2.so
%%SHA2%%libexec/openldap/pw-sha2.so.0
%%SHA2%%libexec/openldap/pw-sha2.so.0.0.0
+%%PBKDF2%%libexec/openldap/pw-pbkdf2.la
+%%PBKDF2%%libexec/openldap/pw-pbkdf2.so
+%%PBKDF2%%libexec/openldap/pw-pbkdf2.so.0
+%%PBKDF2%%libexec/openldap/pw-pbkdf2.so.0.0.0
%%SMBPWD%%libexec/openldap/smbk5pwd.la
%%SMBPWD%%libexec/openldap/smbk5pwd.so
%%SMBPWD%%libexec/openldap/smbk5pwd.so.0